Divisi and chord symbols

I think I’m having a basic understanding problem concerning additional staff lines and/or divisi:

I added a staff line in my score above the staff containing a rhythm guitar. That staff contains chord symbols. I want to use the new one to write a guitar solo. Adding a staff duplicates the chord symbols on top of the newly created line – which is not what I want. Deleting the chord symbols from the new top staff deletes the chord symbols on the original staff, too.
I thought ok, being a divisi, Dorico “can’t help” behaving this way. But on the other hand, I didn’t tell Dorico to create a divisi, I only told it to create a new staff starting from the selected bar.
Or is it a divisi by nature?
Did I do something wrong?
And is it “diviso” in singular?…

Ah, one more thing: I tried cmd-x to remove the symbols, then create a new staff above, and cmd-v to restore the symbols. They are pasted on both staves.

How do I get rid of the superfluous chord symbols?

By default, Dorico puts chord symbols on “Rhythm” instruments, so I would expect the chords to appear on any rhythm instrument you add to your score. If you added the new guitar as a separate staff, you should be able to ask it not to display chords in Setup Mode by right-clicking (or whatever the Mac equivalent is) on the Player in the left column. The drop-down menu will give you a Chord Symbols sub-menu, where you can adjust how chords display on that staff.

I’m afraid this is a bug: Dorico shouldn’t be showing the chord symbols on the extra staff. This one slipped through the net, I’m sorry to say. You may find that it’s acceptable for now to set the layout option to make chord symbols appear only above the top staff in the system rather than above specific instruments, but of course that might not be appropriate for the specific layout you’re trying to create. We’ll fix this as soon as possible.

Good to know!