Does your Cubase 9 forget midi output routing?

Hi all,

I’m trying to figure out what exactly is going on here before posting a bug report.

I have a template that I’ve used for years, updating as I go. I has a midi track that’s routed to a neighbouring vsti. In C9, if I save either a template or a project with it routed correctly (in this case to “Harmony - MIDI In”), when I reload it it’s pointing to “RME MIDI Out”, which is my physical MIDI output. I can change it back to Harmony - MIDI In and re-save but when I open the resulting file it will be back to RME MIDI Out.

This happens EVERY TIME I save either that template or a project derived from it. I never had that problem in previous versions of Cubase.

On the other hand, if I create a blank template then add a vsti then a midi track that outputs to the vsti, I don’t have that problem.

Anybody have any thoughts about that?


I have not had the issue you described. Maybe the template is getting corrupted. Try resaving your blank template as another template with a different name and give it a try.

Regards. :sunglasses:

Thanks for the reply, Prock.

I tried that, actually, and the other changes I made saved fine, but not the midi routing.

Weird, no?

Just tried importing all the tracks from a Project based on my template and when I saved that Project as a template I still got the same problem.

Finally I tried loading up my template, deleting the MIDI and Instrument track, saving that template, closing and reloading and recreating those two tracks and it seems to have done the trick: the new template has loaded up with correct routing.

I wonder if there’s a slight difference in how C8.5 and C9 look at midi that might explain that? Luckily in my case I only have a few midi tracks, but in huge orchestral sessions with complex routing I can imagine it being a far bigger problem.

Glad it is sorted. :wink:

Regards :sunglasses: