Dont Ask Me again Tick Box...Keeps asking me again

hi, im a fairly patient and reasonable person but this is starting to really break me, every time i load up Cubase it asks me if i want to use my UR824 driver and i say YES and “Dont ask me again” tick box, and then i close down C8.5 (it closes down fine without crash) and then i load up Cubase again and it asks me if i want to use the UR824 Driver again.
DOnt Ask Again.JPG
is this a fairly obvious bug? is the tick box broken?



As far as I know, this is the latest driver known issue. It’s not on Cubase side (as far as I know), but on the driver side. So you have to wait until the driver update.

thank you Martin for letting me know.

well the drivers are Steinberg so its still their fault. I hope they will be trustworthy to fix it very soon. Especially as the drivers for the unit is a UR824 that still has dropouts of silence (along with other users) so they really need a fix badly

Hi, same issue here with Cubase 8.5 and new USB drivers on UR28M…

Same issue here, it’s annoying as hell but I’m sure it can be fixed.

Here’s hope…

i just tried rolling back to V1.5 firmware and V1.5 drivers and no more dropouts and no more tick box problem!!!

I had this too with UR824 Driver V1.9.10 in addition to that, it would never start up with Direct Monitoring enabled (even though it was checked). You’d have to go to Device Setup and toggle it off and back on. Downgrading to v1.9.9 fixed both issues… at least with cubase pro 8.5.30

Hi friends, would you try uninstall the TOOLS only?
That fixed it…

AND: it fixed the realtime performance problems massively…

Would be interesting if there’s someone else?

Argh, I wasted several hours tracking this down until I found this thread.
I am back now on 1.9.9 driver which fixes those problems.

I wanted to add that the beta driver has this same issue.


We are currently preparing a TOOLS for UR28M and 824 update that should address this issue. Sorry for the delay and the long silence!

Sounds great, Ed, thank you!



Getting a bit tedious with this dialog that stops Cubase from initializing unless you perform yet two clicks EVERY TIME you start/restart.

  1. [x ]“Please, don’t ask again”
  2. [ OK ]


A new driver has been released. Doesn’t this driver fix the issue?

hehe, I just found that by myself, thanks anyway, I’ll try it later today! :sunglasses:

IT’S GONE !!! :sunglasses: :sunglasses: :sunglasses: The damn dialog is gone haha! Thanks anyone who like to be thanked!

Good to know, thank you for the info.

Yeah! Good to know about the problems AND good to know about solutions.