Don't show bar number with Rehearsal Mark

This option is there in Layout-bar numbers but doesn’t seem to work. It is switched on but the bar number is still visible.
Or am I missing something?

This hasn’t happened to me; I just tried turning it off and on again, and it works as expected. Can you post a zipped Dorico file as an example?

Test Chor mit Dorico.dorico.zip (358 KB)
here is one example. The bar number 3 shouldn’t be visible because of the rehearsal mark but it is visible.

ReRei

I’ve just tried this in your example. In Engrave mode, select the bar number 3, then go into Properties and turn on the “hide bar number” switch and tick the “hide bar number” box. (Slightly oddly, this is in the “Time signatures” group in the Properties panel.) This worked for me.

Michael

Hi Michael

Thanks for the workaround.
So it didn’t work for you ever with the “hide bar number with rehearsal mark” setting in layout option?

Thanks for uploading your score - under Engraving Options/Rehearsal Marks, if I select “Left-aligned with systemic barline” (see attached picture), then the bar number disappears at the rehearsal mark. But if I select “To the right of clef and key signature” (as you did in your score) the bar number remains visible, even if “Hide bar numbers at rehearsal marks” is selected under Layout Options/Bar Numbers.

I don’t know if this is the intended behavior, or if it is a bug. If the rehearsal mark is to the right, then it doesn’t collide with the bar number, so maybe Dorico thinks it’s OK to keep the bar number visible.

Thank you Stephen for investigating your time for that issue.
In fact the setting “to he right of the clef and key signature” wasn’t set be me but it was the default setting of Dorico when I tested the vocal manuscript paper of Dorico. And also when I imported an xml file this was the standard setting.
It is in any case irritating that we have a setting and it doesn’t work as expected. Thus I assume it’s a bug.
Thanks again for your help.

No, it is certainly not the default behaviour of Dorico to show the bar number to the right of the clef and key signature: you must have changed that setting yourself. The rehearsal mark will be hidden if it’s in the same place as the rehearsal mark, so if you have the rehearsal mark in its default position (i.e. to the right of the clef and key signature) and the bar numbers in this position, then the bar number will be hidden; but if the bar number is in its default position (i.e. aligned with the systemic barline) and the rehearsal mark in its default position, the bar number will still be shown. This is intentional behaviour and not a bug.

Ah. Now I understand the situation. I misread Stephen. When he talked about the alignment I meant the alignment of the bar number but me meant the alignment of the rehearsal mark. Sorry.

My assumption was that the option of hiding the bar number when there is a rehearsal mark should also work no matter where the rehearsal mark is aligned to.

I was playing with this a little more, and it works even better than I thought. If the rehearsal mark is placed to the right of the clef, and it is a letter or number, then the bar number will appear. But if you change the rehearsal mark to show bar number, then the regular bar number is hidden. Very nice!