Dorico 2 Timeout Loading Omnisphere

Hi,

Trying out Dorico 2.1.10.1080 / VSTAudioEngine 2.1.10.328.

I’ve whitelisted Omnisphere (2.5.1 d 64-bit) and a few other VST2s and get the message:

_Scanning

C:\Program Files\Steinberg\vstplugins\Omnisphere.dll

A timeout may have occurred. Check if the plug-in is displaying a message or click ‘Cancel’ to put the plug-in on the blacklist._

I’ve tried rebooting and removing all other entries from the whitelist except for Omnisphere to no avail.

Please help!
Mike

Did you try using Alt+Tab to switch between the open windows to see whether or not Omnisphere is indeed somehow displaying a dialog or error message behind Dorico’s splash screen?

See if the solution I posted on this thread (https://www.steinberg.net/forums/viewtopic.php?f=246&t=139123) helps you out.

Hi Damiel - no message from Omnisphere to be seen (if you click the D2 splash quickly enough, it hides itself). Now I’m clueless.

Thanks, but I already know it’s Omnisphere causing the problem as, once it’s been blacklisted, everything is fine. Pity Omnisphere is the one VST I want to use (at that price, of couse it is! :laughing: ).

Pitty… Steinberg should make it so if a Plugin fails to load after let’s say, 5 atemps in a row, it gets ignored do it doesn’t cause these problems. I don’t like having to move melodyne to another folder every time I start Dorico either :frowning:

OK, not so much of a problem since I can MIDI the output over to Reaper (which I prefer, especially since I’m sure ReWire support will available some day :smiley:). I’ll keep trying it whenever updates to either product become available and see if I can find some useful log entrries somewhere. In the meantime, I have 28 days of trial left and must forge on … to talk about my MIDI issue … :laughing:

Thanks for listening!

Just upgraded to 2.2.0.1108 to see if that would help - it didn’t. I suspect that it’s simply the time Omni takes to load that’s making Dorico think it’s bust - nothing I can do about that (I’m on a 2.1 GHz cpu with a 7200 RPM disk and nothing special about the RAM - plenty there to drive Omni VSTs directly from Reaper MIDI but the inital load is time-consuming).

Incidentally, MIDI to Reaper (thence to VST) is stuttery, jittery, buttery and cattery, so that went nowhere.

We haven’t had problems reported with other VST plugins (aside from some of the Waves ones which can put up a licence message box, which makes Dorico appear to hang). Have you tried asking on the Omnisphere forum (if there is such a thing?)

How long does it take on your machine to load Omnisphere in other host applications?

The starter of this topic don’t state whether he uses a PC or a Mac but Omnisphere is loading properly on my Mac without ptoblems.

It’s a PC, natch. So, from a cold start (copied a large file to clear the disk cache, loaded Omni into a new track in Reaper with nothing else open) takes about ten seconds.

Loading into another track with Omni already loaded on the first (disk cache cleared again) takes about six seconds.

Left Reaper open with Omni loaded and started Dorico, same timeout message.

Incidentally, when Reaper scans the VST libraries (which contain Omni plus a small heap of other VSTs) on startup it takes less than a second.

I’ll see what Spectrasonics can tell me, if anything.

Could you please start with a piano template, then go to Play Mode and add an Omnisphere instance.
Then, after you get the error message, choose from the main menu Edit > Create Diagnostic Report.
That will create a zip file on your desktop, please send it to ‘u dot stoermer at steinberg dot de’.
Thanks

With you as far as “Add an Omni instance” - I can’t do that since Omni gets blacklisted during the initial scan. Found Create Diagnostic Report under the Help menu and sent to you - hope it’s revealing.

True, I found Omnisphere on your blacklist. So that means that our vstscanner process tried to load Omnisphere but found an issue with it and therefore blacklisted it.
Once blacklisted, the audio engine will not even try to load it ever again.
Please try following: Go to C:\Users<yourname>\AppData\Roaming\Steinberg\VSTAudioEngine2_64 and delete the file Vst2xPlugin Blacklist VSTAudioEngine.xml
Then on the next startup the scanner will try to load it again. Let’s see if it gets blacklisted again.

By the way, what version of Omnisphere do you have? Is it up to date?

Furthermore, I’ve noticed that you have a pretty outdated HALion Sonic SE. You have version 2.0, but 3.2 is the current version.
If you want, you can dowload it from here: https://www.steinberg.net/index.php?id=downloads_halion_sonic_se_3&L=0

OK, I’ve done two things - upgraded HALion Sonic SE, and roasted a turkey while Dorico started up. I’m imagining this latter is relevant because I didn’t get the chance to click the Cancel button on the warning dialog, so Dorico might have “extra-whitelisted” Omnisphere or something (I’m guessing here - it might have been the HALion Sonic SE upgrade that achieved the fix).

Anyway, Omnisphere is now up and running happily, I have several instances active with test tracks making a lot of noise.

Ulf - I was already deleting the blacklist file between every Dorico startup; Omnisphere was at its latest version.

Thanks to all for your help. :smiley: