Dorico 3.0.10 doesn't see some third party plugins

I’ve upgraded to Catalina. Dorico doesn’t see some of the third party VST3 plugins in the VST rack. It does see Pianoteq, but not VE Pro 7, or Synchron Player for instance. I’ve used these in Catalina Beta before. Not sure what is going on.

I did reset all of the tccutil items. Dorico did not ask to allow it to control Synsopos. This is new behavior.

Dorico did ask to allow access to Network volumes. But nothing else.

Are there some other permissions that need to be set?

The missing plugins are showing up in the vst3blacklist file. I’ve deleted the vstaudioengine3 folder in preferences. This doesn’t help.

Whitelisting the vst2 version works. Not gonna be satisfactory though.

We’ll need to see the logs, Dave. Please do Help > Create Diagnostic Report and attach the resulting zip file here.

Dorico Diagnostics.zip (363 KB)
Here are the logs.

For EastWest Play on OSX 10.14.5. I opened vst3Blacklist.xml in text editor. Play was still black listed.

I didn’t know what to delete so I just put a 1 in front of Play.vst3. (1Play.vst3). I saved it and opened Dorico. Play is now working properly.

Play crapped out when I first instantiated it but the second time it worked.


initially I added Play VST to the white list and that did not work.

Do the people at Vienna say that all of their plug-ins are fully qualified for Catalina? I had a look on their web site but wasn’t able to find any clear information (e.g. for VE Pro 7 it says a minimum OS version of 10.10 and a recommended version of 10.13 or higher, but it doesn’t say whether 10.15 is actually supported).

The updated audio engine in Dorico 3.0.10 is also crashing, so I need to try to symbolise those logs to find out why. Can you see whether there are any crash logs for any of the Vienna plug-ins in ~/Library/Logs/DiagnosticReports?

I’ll check the crash logs in the morning. As for the compatibility, VE pro server runs fine, just Dorico can’t see the VST3 version as a plugin. But I can run it and load instances etc outside of Dorico.

Logic Pro X works with both AU and AU3 formats.

Dorico works with VST2 format when it’s whitelisted.

Those Dorico crashes happened because I force quit from a hung endpoint setup screen that wouldn’t close after trying to save an endpoint setup when VE pro was not available (exclamation marks in the vst rack).

There are no Dorico crash logs in the diagnostics you submitted, only crashes in the VST audio engine. And two of them look to my untrained eye to be similar to the crashes that Sam Reed is experiencing in this thread.

If you can point me to the info on the (hard to navigate) VSL site where it provides chapter and verse about Catalina support for its products I’d find that helpful.

Right. Those were vst Audio Engine crashes. But they happened as I said.

I don’t have any more “official” info about the VSL compatibility than you. But the vst3 version worked in beta versions of Catalina. And those other formats work.

One other thing I noticed. The vst3blacklist file has a bunch of plugins listed, none of which were listed in version 3.0. Is it possible that a single plugin can cause the remaining plugins that are checked after the one that fails to also fail the plugin scan?

I don’t know for sure, but I don’t think so. My guess is there’s a more systemic issue with the VSL plug-ins, the release version of Catalina, and our VST scannnig components, on your system at any rate.

There are non-vsl plugins also failing in that blacklist. Melodyne comes to mind. I don’t think the plugins are the issue since the other formats work in other apps.

Are there any cache files that need to be cleaned up from version 3.0?

Is there a link to an archive installer for Dorico 3.0? I’d like to install that and see if the vst3blacklist is any different.

In the Console application, under UserLogs (I think) are there any crash reports from the vst3scanner?

no vst2scanner crash reports.

also, no Vienna plugin crashes since the update.

Dorico 2.2.20 can see all of my plugins as before. There are no entries in the vst3blacklist file.

Dorico 3.0.10 cannot see any of the VSL plugins.

This issue is resolved. See this thread:

https://www.steinberg.net/forums/viewtopic.php?f=246&t=170085&p=908645#p908645