Dorico 3.1 Noteperformer No Harmonics Playback?

I have the latest versions of both Dorico and Noteperformer but the string harmonics aren’t playing back. I looked through my expression map for pt.naturalHarmonic1 but didn’t find it anywhere. Is there something I need to do to get this to work?

Try selecting the NotePerformer expression map in Play > Expression Maps and clicking the ‘Reset to Factory’ button to make sure it’s the latest available version.

I rechecked to make sure I have v.3.3.1 of noteperformer. In the expression maps page there is a ‘reset to library defaults’ which I clicked on but still no harmonics playback. Any other suggestions would be helpful, thanks.

You should be able to hear the difference playing back the attached project. (191 KB)

Interesting! The harmonic note (notated at sounding pitch, which is normal for the violin) has very little second harmonic content in its sound, whereas the second, non-harmonic note has quite a bit of second harmonic content. Just what you’d expect.

I tried this same side-by-side comparison with the harp, and it, too, reveals a difference in sound, so NotePerformer is definitely changing the sound when it encounters a note written as a harmonic. The problem with the harp, though, is that NotePerformer is treating it like a violin and assuming that the notated pitch is supposed to be the sounding pitch. This is probably because there’s only one expression map for NotePerformer. It looks like the harp needs its own expression map so that an octave transposition takes place when it encounters a note written as a natural harmonic. If that’s not possible, then perhaps Dorico could do the transposition itself as a special case when it encounters a natural harmonic and the instrument is a harp.

Here’s a tricky work-around for the harp. In upstem voice 1, enter the desired note one octave high and turn on the natural harmonic property. In a second voice, add the desired note at its normal written pitch at the same rhythmic position as the higher note and turn on the natural harmonic property. Suppress playback of this note. Go to Engrave Mode and hide the stem of the higher octave note, and adjust the voice column index property of the lower octave note so the two notes are aligned. Flip its stem if necessary. Go back to Write Mode and set the Custom Scale of the upper note to 1% so that the notehead and its harmonic circle symbol disappear. When you play this back, you’ll hear the harmonic of the invisible higher note, and you’ll see (but not hear) the lower note with the natural harmonic circle.

1 Like

Since the harp harmonics sound at notating pitch rather than an octave higher in HALion as well as NP, the solution (option) if the Team decides to support it would logically be on the notation side (to apply to instruments from a variety of vendors) rather than specifically to NP and each VST company individually.

Having said that, I do not expect the Team to drop everything they are currently working on just to handle this; but I hope harp harmonics can eventually be handled by Dorico without a work-around since harp harmonics that sound up an octave seems to be semantically sound.

The 2 notes in Daniel’s example did sound different, but the problem I’m having is with artificial harm playback.

Figured it out. Thanks