Dorico 3.1 Windows scaling

Many Windows laptops has a default scaling of 125%, giving normal resolution for browser and programs. With Dorico 3.1 now using this scaling, both menus and panels has become too large, as shown in the screenshot.

I’ve tried changing the compatibility settings to see if this could force scaling back to 100% just for Dorico, but so far to no avail. So I’m looking for a way to reduce the size of Dorico real estate without having to reduce the scaling for all other programs.

So lower the scaling just for Dorico. forgive me if I am wrong, but I think that is what the new improvement to the feature is for.

I can agree here with norseman. Now the scaling of the whole GUI and the Initial loading logo are more like DPI 150%, instead of 125%
For big screens isn’t a serious issue, but for laptops, it is.

Best regards,
Thurisaz

Dorico will now look larger at 125% than it did in 3.0.10 and earlier, because previously when you had Windows set to 125%, Dorico was actually shown at 100%. There’s no option to go back to the old behaviour, because it was wrong. However, if you happen to prefer the old behaviour, according to this article on Microsoft Answers, you can disable display scaling for a given application if need be.

This only works if the application uses another resolution than the Windows default, which is not the case here. But like Thurisaz says scaling now looks more like 150%. The menu font size is bigger than other Windows programs on my laptop, e.g Cubase.

I suppose it was inevitable that some people would prefer the incorrect scaling rather than the correct scaling! I’m afraid I don’t know what we can do about this, because we’re certainly not going to put the wrong behaviour back again. I’m in Austria for the Music Engraving in the 21st Century conference for the weekend, but I’ll take this up with the team on Monday.

I’m also experiencing this problem of size disparity between Dorico and all other programs/Windows itself. I’m on a Lenovo 15.6’’ Laptop with a display resolution of 1920x1080 running Windows 10. My scaling value is 150% to achieve good legibility in every program, but Dorico seems to interpret this value differently from every other application; I would need to set 100% for a usable scaling…
The previous versions behaviour actually made a workaround possible; I set Windows to a custom scaling percentage of 149% and Dorico would fit in by internally rounding to 100%. It would be great maybe to have an option to force a certain scaling factor for the program to compensate for (what appears to be?) an interpretation of the system scaling value by Qt that differs from that of other programs.

Best Regards

Is this topic related to this problem I have? Dorico 3.1 did not change this behaviour:

In the Project Information (Cntl-I) input window, the “Apply” and “Close” buttons are off the bottom of my screen. This is when using Dorico at full screen, but not using the F11 key which hides the Windows task bar.

I can slide this window up a little and barely see the two bottom buttons, but letting go of the mouse causes the window to snap its top to the top of my screen. Buttons are hidden behind the task bar.

My workarounds: (1) click in the “Other Information” window, press Tab once to get to “Close” (which is a stab in the dark, so to speak). (2) (with this laptop), F11 gets rid of the task bar at bottom of screen. (3) Moving the task bar to the right side makes the buttons visible.

Update: I just tried the right windows bar, then put it back to the bottom, and now Project Information looks ok! Go figure…

I find I had to click the partial screen and then the full screen program icons the first time I used an existing, converted Dorico file, but then the screens seem to fit with the new configuration.

running at no (100%) scaling on Windows 10 it all looks fine to me.

100% looks fine for me on a 23 inch 1920 x 1080 screen. The side panel text and icons are a bit bigger than most other programs, but you can close them when you don’t need them. I suppose if you work by selecting everything with the mouse, they would be a bit more intrusive.

If you have a different size screen or different pixel resolution, YMMV of course.

@Daniel and everybody involved here and at QT: THANK YOU! Even though I’m going to retire my Surface Pro 3 in a few months (which has a display resolution that needs to be scaled to 150%), I am very happy about this update - Dorico is much better to work with now.

I found a solution to my problem, maybe it will help others:

You can set an environment variable to tell Qt-Applications to either not auto-scale or use a custom scale factor (in relation to your system-wide scale factor).
How to: https://doc.qt.io/qt-5/highdpi.html#high-dpi-support-in-qt
How to set an environment variable: https://www.howtogeek.com/51807/how-to-create-and-use-global-system-environment-variables/

However, this will apply to all applications that use Qt, so it is only a workaround.


Regards

Excellent! For my 125% Windows scaling I ended up using
QT_SCALE_FACTOR
0.8

Edit: I found the following working better as the first rendered Sib useless:
QT_AUTO_SCREEN_SCALE_FACTOR
0

Awesome, this worked perfectly for VEP 7 as well. Thanks for the tip.