Dorico 3.5.11 Sound won't record when recording video, but it used to!

Recently had to replaced my hard disk which had failed. While the computer was being repaired the latest Dorico update was released. With new hard disk it was easy to install Dorico, which was a clean install of version 3.5.11. Everything seemed to be fine until a problem emerged & I don’t know whether it’s a glitch in the latest Dorico update, or in the sound card, or in the fact that the new hard disk has the latest Windows update (20H2).

Previously I would make rehearsal & demo videos from Dorico using Ashampoo Snap, which can record everything from a selected area of the screen. This always went without any hitch & I could post the result to YouTube so the librettists could see what I’d done with their words, & also demonstrate to potential customers etc. Sound always recorded perfectly with the video.

However I now find the video records perfectly but there’s no sound at all. Snap is set up to record output from the speaker output just as it did before, but now, although I can clearly hear the sound when doing the recording, after saving the video file it’s completely silent.

I have tried the following:

  1. In Device Setup, I changed sample rate from 44100 to 48000, & also changed the Generic Low Latency ASIO driver to ASIO4ALL, but no joy in any of the 4 possible combinations.

  2. Tried recording using a different capture program (by Cyberlink) – this used to work as well, but now get the same result, no sound.

  3. Tried recording videos from YouTube with the same settings in Snap – they all record perfectly with good sound.

The last point suggests perhaps the problem is within Dorico, but I don’t know whether this is a glitch in 3.5.1x or perhaps nevertheless a problem with the sound card driver, - it’s an Asus Strix, though the fact that I can record perfectly from non-Dorico apps makes me wonder if it’s Dorico. If anyone knows how to fix this by tweaking some setting I’d be most grateful.

Also - new forum seems great but not sure how to set up a signature.

Stephen Brown
Windows 10, Dorico Pro 3.5.11, Noteperformer 3.3.2

Click on your avatar at the top right, then Preferences, Profile.

Thanks Dan; I guess that’s where it says “About me”

Hi Stephen, I’d check the Windows Sound Settings (press Win key and then type ‘sound settings’)
In there choose the properties button of your output device and then advanced properties. That brings up a new little dialog. Change to the Advanced tab and there check the ‘allow exclusive access’ option. To what is it set? Likewise, there is a similar option in the driver panel of the Generic Low Latency Driver. Try fiddling with those settings. My guess is, it has to do with Dorico claiming exclusive access to the sound driver.

Hi Ulf

Many thanks for your suggestion. However I’ve tried fiddling with the settings as you suggest to no avail. Current settings for soundcard and for Dorico’s ASIO driver are in the attached picture. Both Dorico and the Sound Card are set to 48000 Hz sample rate as well as allowing exclusive control.

My second device is a Surface Pro hybrid which doesn’t have a sound card, and I can record sound OK on that, which does make me think perhaps the sound card on the desktop may not have been optimally reinstalled when the computer was repaired. At least with the second device I have a workaround for now.

Hi Stephen,
and what if you don’t allow exclusive access?
Also, since it is working on the Surface Pro, try to compare the settings to the other computer.
Though it has a different sound chip, but it’s comparable in regards to those settings like exclusive access.

In the Speakers Properties panel, does it allow you to choose a 16-bit format?

Thank you so much Ulf and Paul. I carried out both your suggestions and it is now working!
I am extremely grateful.
Thanks again!