Dorico 3.5 Change Instrument and Audio Issues

Hello all,

I have created a series of lead sheets using Dorico 3.5, but I’m having issues changing instruments in the Setup panel. When I select the instrument I want to change, I choose the “Change Instrument” option in Setup, but then nothing pops up. This happens on 2 of the 3 charts I’ve been trying to create. Additionally, when I attempt to restart the program, the launcher gets hung up, saying “Audio Engine Process Died.”

This is incredibly frustrating as I need to get charts out ASAP.

Edit: I get the “Audio engine process died” error every other time I launch Dorico 3.5

1 Like

I cannot upload the Diagnostic since I am “new user.”


I just liked both of your posts, hopefully that will be enough for you to get permission to upload the file here.

I am still unable to upload the diagnostics file, and, on a more personal note, have also lost the client I am working for. I have reinstalled both Dorico and the Sounds Installer only to have the exact same issue.

Please advise.

I am running a Windows 10 machine with a Scarlett 2i2 3rd Gen interface.

1 Like

Sorry lolwut, it’s New Year’s Eve, and London is probably swilling champagne at the moment!

1 Like

Happy New Year from London.

Does your instrument have an ossia stave, perhaps? There’s a known limitation when trying to change instrument if ossia staves are involved.

In any case, you may find that you can achieve what you want using a new layout with a Clef and Transposition override - see here.

As to the playback engine failing on launch, this can happen on reloading if Dorico’s crashed or you’ve forced it to quit (is that End Process on Windows?). If you go Ctrl-Alt-Delete/Task Manager and end the VSTAudioEngine process manually, Dorico should then be able to reload the audio engine correctly.

No ossia staves are involved; however, in the 2 charts in question, I did change it from a single line instrument to a grand staff and hid staffs as needed.

It may be that the additional staves are your issue. You may need to copy and paste the content of those staves to new players. There’s a Copy Part Formatting option if you right click on any layout in the right panel of Setup mode, which might save you some time.

If I create new players and copy and paste, the chords symbols disappear.

Right-click on the new player in the left panel of setup mode and go Chord Symbols > Show for all Instruments. Note that this menu is player-specific - if you’re adding a load of non-rhythm players you’ll need to go through the menu for each one.

1 Like

This solved it! Thank you!

1 Like

Except now Dorico won’t boot…

I had to use the task manager to end Dorico, and I still get the same “Audio Engine Process Died.” In the task manager, I don’t see any “VSTAusdioEngine” in the task manager.

It may be that you need to click on the Processes tab to see it, if you’re not already doing that…

Leo’s right, it’s way down in the second list.

@lolwut Please send your diagnostics report to ‘u dot stoermer at steinberg dot de’.

In regards to the “audio engine died”, do you happen to shutdown Dorico and then launch it immediately again? If you are on Windows, you have to wait a couple of seconds before relaunching Dorico.

1 Like

I was never able to find the VSTAudioEngine, but after stepping away for several days, the issue seems to have worked itself out. I’m not sure exactly what happened - perhaps it was related to trying to instrument change a grand staff.

No worries, let us know should it occur again.