Dorico 3.5 Missing VST Plugins in Play mode

Hi Ulf,

I’m glad, that I’ve found this thread, because I, too have the same problem like Tracy (at least it seems to me). I followed Your above instructions to delete and c/p the xml-files, but after starting Dorico it edits the previously manually cleared xml-files and entries noteperformer in the file “Vst2xPlugin Blacklist Dorico 3.5 AudioEngine.xml”. (For me it’s noteperformer, not kontakt). In the Dorico-GUI noteperformer does neither appear in the “allowed” nor in the “blocked” list. As an effect, in Play-Mode there is no entry for the noteperformer plugin in the “VST Instrumente”-List. HSSE with HSO works fine.
Tracy did not post her Zip-File of her folder yet, as you asked:
So here’s mine and the “Dorico”

What could be wrong?
Thanks in advance!

Thorsten (user: “Fitsch”)
Dorico (697 KB)
Dorico 3.5 (656 KB)

Hi Thorsten, I don’t know, yet, what is wrong there. I’m currently on vacation, but I will focus on this issue as soon as I return to work (July 27th). So please be a bit patient, I’m sure we will sort this sooner or later.

Hello Ulf,

thank you for this immediate answer! ( Boah, ich brech’ mir mit dem Englisch hier noch einen ab: ich wünsche Ihnen einen wunderschönen, erholsamen Urlaub. Möglichst völlig ohne irgendwelche XML-Dateien oder dll’s :slight_smile: )

I don’t know, if this could help analyzing what’s going on: after my last posting here, I entered the directory/path to the 32-Bit-Noteperformer-Plugin in the Dorico-GUI and restarted Dorico. Then the plugin “noteperformer32” appears in the “blocked” list in the GUI. I could move this “noteperformer32”-Entry into the “allowed”-List. After restarting the computer, it still appeares in this allowed-list, but I still cannot chose any noteperformer in the Play-Mode-VST-Instruments-List.
I can’t force the “noteperformer64.dll” to appear in one of the “blocked” or “allowed”-Lists via this way.
The version of this noteperformer-plugins (as shown via the properties of “noteperformer32.dll” and “noteperformer64.dll”) is - downloaded it today.


Thorsten (user: “Fitsch”)

Hi Thorsten,
vielen Dank, geht nicht ganz ohne XLMs und DLLs, aber ich mache das auch gerne fuer unsere Kunden.

And no, Dorico is 64bit only, so 32bit plug-ins won’t work at all. The fault must be on our side, somewhere in the vstscanner, but I will find out.

Dear Ulf,

I’ve got a little guilty conscience (schlechtes Gewissen) to poste again. It’s just because I’ve got time now - but I’m really fine, if you will answer or analyze it further when your vacation is over! If anyone ever will use the german saying “Servicewüste”, then I will disagree and answer: Steinberg and the Steinbergian’s perform an exceptional, extraordinarily support - have a look at them, this is the definition of service!

So here’s a screenshot that might give additional information. The errorlevel of the vst2scan is “0”. I’m just a little confused by the but I don’t think, Dorico get’s confused by this tag-value and adds it to the black-list because of this!?



Thorsten, thanks for your kind words.

That’s what confuses me as well - not the vendor version - but the fact that the output of the vstscanner looks perfectly normal. With that errorlevel and output the plug-in should normally not land on the blacklist, but still it does. So I have to find out what exactly is going on there.

Tracy does not respond anymore, so Thorsten, could you please zip up the folder C:\Users<yourname>\AppData\Roaming\Steinberg\VSTAudioEngine3_64 and post here. Please have a close look at the path, it is the folder of the previous Dorico 3.0 audio engine. Thanks

did you definitely replace the contents of the blacklisted file clearly shown in your attachment with a clean one like the attached? If you replace the file as in Ulf’s suggestion instead of editing it, then you must rename it as well to Vst2xPlugin Infos Dorico 3.5 AudioEngine.xml. If that’s all correct, then it does no harm to looks at the Preferences–>VST PLug-ins list. If NotePerformer is listed on the right hand side then move it to allowed.

Your Noteperformer version seems the same as mine and not an earlier one which has caused many of these issues.
Vst2xPlugin Blacklist (343 Bytes)

Hello Ulf, hello dko22,

here’s the zipped Folder:

After starting Dorico I go to Preferences->VST-Plugins and clear the audio-engine-cash. This makes Dorico deleting most of the files in the folder:
C:\Users<yourname>\AppData\Roaming\Steinberg\Dorico 3.5 AudioEngine_64
Then I start Dorico again.
During the start the files in this folder are recreated. The two files in this folder:
Vst2xPlugin Blacklist Dorico 3.5 AudioEngine.xml
Vst2xPlugin Infos Dorico 3.5 AudioEngine.xml
contain now entries for noteperformer64.
But in Preferences->VST-Plugins noteperformer is neither in the “blocked” nor the “allowed”-List.
Noteperformer is available as Playback-Template.
But the noteperformer-plugin does not show properly in the list in Play-Mode “VST-Instruments”, there it is “02 - !! Not…erformer !!” resp. “—”.
No sound.

Then I exactly follow the steps in the above post of Ulf’s “Fri Jul 10, 2020 10:07 am”. Yes, this steps lead to an XML-File “Vst2xPlugin Infos Dorico 3.5 AudioEngine.xml”, which is not empty, but has an empty content; a valid XML-Structure, containing no information.

Then I Start Dorico.
The File “Vst2xPlugin Infos Dorico 3.5 AudioEngine.xml” gets altered during this startup. Now the XML-Structure contains the information about noteperformer64.dll, as given in my post “Fri Jul 17, 2020 6:00 pm”.

But in Preferences->VST-Plugins noteperformer is neither in the “blocked” nor the “allowed”-List.
Noteperformer is available as Playback-Template.
But the noteperformer-plugin does not show properly in the list in Play-Mode “VST-Instruments”, there it is “02 - !! Not…erformer !!” resp. “—”.
No sound.

Thanks a lot for Your help and support in advance!

Thorsten (505 KB)

Hallo Thorsten, ich habe Dir eine private message geschickt, bitte einmal lesen. Danke

with luck, Ulf has sorted it now!

Just in case not, I myself am a little confused about the current contents of the Dorico 3.5 AudioEngine_64 folder. In your first upload NotePerformer was listed in both the black list and the Plugin Infos. it should be in the Plugin Infos only of course and there’s no way it should be blank (unless there are configurations which work which look totally different from my own in which I should probably give up… )

No, not solved, yet. But I want to try something with Thorsten, and so not to confuse everyone else here, I sent him a private message.

And you are right, NotePerformer shall only appear in the plug-in infos file and not in the blacklist. But also if it is in the infos file, there needs to be proper information in there, and in the fault case it seems to be something essential missing. I still need to figure out…

I’ll leave you to it, Ulf as I don’t want to meddle. it looks to me that Thorsten still don’t have the config files how we’d want them, Hope you’re enjoying your holiday, anyway!

Hello to everybody with the problem of NotePerformer being blacklisted for no reason. Well, it took me some time to figure it out, but I think I have found a solution to it. User Fitsch I could help already with a workaround, but now I have a proper solution, and that is a fix in the vst2xscanner binary. I could reproduce the problem on my machine and now it is working for me, but I want to verify this fix with other people. So please, anyone who still faces this issue of NotePerformer being blacklisted, please get in touch with me via mail to ‘u dot stoermer at steinberg dot de’, and I will provide you the new binary as well as detailed instructions.

I have the same problem now, not with NotePerformer but Kontakt 5. I know, there are other threads about this problem, but I didn’t find a solution there. So I hope here is the right place.

My system:
Latest Win 10, Dorico 3.5.11, Kontakt 5, FastTrackPro ASIO driver.
All installation paths are default. No other VST plugins are installed.
Standalone Kontakt works.

After choosing Kontakt in the Preferences and moving the VSTs from blacklist to whitelist:
Kontakt still doesn’t appear in the VST instruments dropdown in PLAY mode.

What I tried:
Reinstalling both, Dorico and Kontakt 5.
I removed the folder Dorico 3.5 AudioEngine_64 completely.
After restarting Dorico, in the newly builded folder: Kontakt ist still in the Vst2xPlugin Blacklist Dorico 3.5 AudioEngine.xml. Strange: inside the programm it is listed under whitelisted plugins.
I’ve read this post : but I couldn’t find any solution which works for me.
I’ve uploaded a diagnostic file here:!AkKdmRRzCUQbjOU6J--jOukwapS-gg?e=2rGYND

Thanks for help,


Hi Peter, I have sent you an e-mail with instructions.

Hello Mr. Ulf, currently I’m having the same problem right now. I want to use Kontakt 6 on Dorico but any of the solutions I found here are working for me. Vst2xPlugin Blacklist Dorico 3.5 AudioEngine.xml (7.4 KB) the entire Native instruments folder is blacklisted, even though I whitelisted them just a minute ago. Could you please send the solution email to me?

Hi Carlo, have you already updated to Dorico 3.5.12? That update now contains the fixed components.

Kindly assist me with the following plug-in issues in Dorico 4 on a M1 Mac (Big Sur):

Although NotePerformer and SINE Player are whitelisted, they are not available in the VST Rack.

Also, although Play, and Kontakt are available in the VST Rack, they do not open when I select them. I never had these issues with Dorico 3.5.

I have attached the diagnostic report. Thank you very much.

Dorico (1.1 MB)

Welcome to the forum, @scoremasters. Are you running Dorico 4 under Rosetta? That will be necessary for any VST plug-ins that are not yet Universal, i.e. that do not yet support the M1 architecture.

Please see pages 51 and 52 in the Dorico 4 Version History PDF for instructions on how to run Dorico 4 under Rosetta.

Thank you so much Daniel for your swift reply. It resolved the plug-ins issues. I appreciate it immensely.


1 Like