Dorico 3.5 Opening Problem


I just updated to 3.5.

I get the message as if I was not entitled to use the full version! (see attachment)

What did I miss?

I also have NotePerformer out of order with this update. Fortunately, I still have the 3.1 version with NotePerformer still working.

Also, I still have problems to open Dorico, even the 3.1 version, getting the following message : Failed to send the GetInfo message (see attachment)

Help needed,


I’m afraid this is the same old problem you’ve been experiencing for a while, Louis. Dorico doesn’t work satisfactorily with the USB-eLicenser on some Macs, and yours is one of the “lucky” ones.

Please check that you are using the current version of eLicenser Control Center, which is 6.11.0.something (I forget the exact build number). And please try a different USB port on your Mac if you are able.

I am using a lot of software, for years : Logic Pro X, Sibelius, Vienna and all their VST’s and all the other regulars used on a daily basis. So understand my discomfort to be told a compatilibilty problem with my iMac Pro (2017) is at the source of my problem.

I always work with the latest version of eLicenser.

For now, I’ll have to settle with version 3.1.

I need something more specific in order to help me.

Thank you,

There’s no difference between Dorico 3.1 and Dorico 3.5 with regard to the eLIcenser. I would expect you to have identical rates of success or failure when using either version on your Mac when using the USB-eLicenser, I’m afraid. I’m not an expert on the internals of the eLicenser system, but from what I understand from my colleagues, the problem relates to the way that the eLicenser communicates with the host application and with the actual USB-eLicenser across the USB interface. As I’ve explained to you in private messages on this subject, work is ongoing to solve those problems, and when the updated eLicenser Control Center software is available, I believe these problems will be eradicated. Version 6.12.0.whatever-it-was had an initial version of this new underlying communication system implemented, and the early signs were good, but at some point some other incompatibilities were discovered and that version has been withdrawn again temporarily until these remaining incompatibilities can be fixed. The team continues to work on it and I do expect a solution in due course, though I cannot say when it will come.

Thank you for the technical explanation. It does help me to understand.

Now, what should I do with this problem of access to the full of Dorico (message being : This project contains more players than this version of Dorico allows, it will open read-only, so you can play and print it bu not edit it)?

Is it related to the eLicenser problem?

NotePerformer is still not working although I cleared the cache. In the Play section, I can see « !!NotePerformer!! » But no possibility to pick it is not available.

Therefore it might be wise for me to wait for an upgrade which would resolve at least this problem with NP. The eLicenser factor being somewhat out of your hands.

I really appreciate your input.

Thank you.

Yes, Dorico is running as Dorico SE because it cannot obtain the correct license from your USB-eLicenser, and so it runs with the more limited SE feature set.

It should be possible to get NotePerformer working regardless of the eLicenser problem, though. This thread probably contains the solution.

True sad story: I went from some USB wonkiness on my MacBook Pro 2017 ( I know, not quite the same) to a painful USB related death at a time in the quarantine when it seemed that teachers and school children had purchased every decent laptop in the city. Everything (power, monitor) plugs into the USB bus via a dongle so…

Turns out its kind of a thing on the internet, including the iMac, and some chipsets are problematic. Just saying I would seriously consider changing out any Mac 2017 with a sign of USB weirdness for more than one reason. Don’t be me :slight_smile:

I did check the thread about NP. No luck at this point.

Regarding the iMac (2017), I need to point out the fact no problems occur with the use of eLicencer for all the other software that depends on it. Only with Dorico. So that might help to focus the solution.

Again, thank you for your advice and help.

Would you please do Help > Create Diagnostics Report and post the corresponding zip file here? Thanks

Dear Ulf,

You’ll find enclosed herewith the zip file.

Thank you for your help,

Dorico (321 KB)

Hi Louis, thanks. I had a look at your diagnostics and yet another case where NotePerformer got blacklisted.
Please see thread and check the mentioned recipe. Does that help you?

Dear Ulf,

The link you gave me looks for a PC as I don’t find any of the files the thread is referring to.
I don’t want to be too difficult, but I expect Dorico to open as usual with the NotePerformer running without having me being a computer technician. Although I can work around some problems, here I have to put away the 3.5 version. I still have some issues with eLicenser as you know.
I cannot spend more time at this point. So I’ll wait for a workable solution involving a minimum of participation on my side. I really like Dorico and fortunately 3.1 is still working.

I would be willing to allow some screen sharing with you if the problems would be solved.

Yours truly,


Hi Louis, I’m sorry, then here is something very simple I’m asking you to do:
Open the Dorico Preferences dialog and choose the VST Plug-ins tab and scroll down until you find a button called ‘Clear Audio Engine Cache’. Press that, close the dialog and then restart Dorico. If after that still no NotePerformer is turning up, we can arrange for a screen sharing session. Cheers, Ulf

Hi Ulf,

I tried it before. At your request, I did it again without any luck again.

I accept with gratitude your kind offer for a screen sharing.

When would it be possible for you ?


Hi Louis,
please mail me at ‘u dot stoermer at steinberg dot de’ and we’ll sort the details.
If I’m right then you are 5 hours behind Middle European time, right?
Is a time like now convenient for you, it’s 9pm here now.

The problem is now resolved!

Thanks to Ulf with the help of the screen sharing.

The upcoming update of eLicenser as cleared the opening and accessibility to the complete version of Dorico 3.5 and my old 3.1.

Regarding NotePerformer, you need to get the latest version 3.3. This way, Dorico 3.5 can see it.

Just make sure the Audio Driver in Dorico is properly set in order to hear it : Edit/Device Setup

Also, before you open Dorico, make sure NotePerformer is out of the Blacklist. On a Mac, you can find the Blacklist file following this path :

Macintosh HD/User/username/Library/Preferences/Dorico 3.5 AudioEngine/Vst2xPlugin Blacklist Dorico 3.5 AudioEngine.xml

I hope it helps others