Dorico 3.5 suspend audio checkbox removed?

Hi everyone (first post here so hoping this is ok!),

I’ve had a look to see if this had been posted about since 3.5 released, but can’t find anything - I’ve just upgraded from 3 to 3.5, and have noticed that the tickbox under preferences for ‘Suspend audio device in background’ (I’ve attached a pic) is no longer present, only the button for ‘Audio Device Setup…’, which is meaning Dorico always has exclusive control of my audio. I’ve seen in other posts about using the tickbox on the generic low latency asio for this, however I run everything through a Tascam US-16x08 interface so am not using that specific asio.

Everything worked great in the previous version while this feature was present (as well as in Cubase where the functionality is the same, still has this, and works great because of it) - I could notate and listen in Dorico and flick to something else and listen to that, for example transcribing from Youtube or Spotify etc, but can no longer do this without that tickbox. I’ve checked my Windows sound settings and those of the interface to confirm it isn’t set to allow exclusivity of certain programs, but as it stands I can’t hear anything outside of Dorico unless I shut it down, without that tickbox being there.

Has anyone else noticed this? I’m kind of hoping it’s just moved somewhere or something and I can’t find it, as I’m kind of at a loss with what to do without this option…!

Thanks and hope everyone is safe and well,
Joe

Welcome to the forum, Joe. Yes, the ‘Suspend audio engine when application is in the background’ checkbox has indeed been removed in Dorico 3.5, and the underlying option has been disabled. This feature was responsible for a great many crashes on both Windows and Mac, and we decided to remove it until such time as we can figure out how to achieve a stable result when it’s active. I don’t believe we fully understand the reasons for the instability when this option is active, but as I understand it there’s something about the fact that Dorico and its audio engine are running as separate processes and the manner of their communication that leads to the problem. This fundamental architecture isn’t likely to change, but perhaps we will figure out a way of bringing it back in future.

I’m sorry it’s inconvenient to you not to have that option any longer. I would hope you would be able to achieve some kind of settings in Edit > Device Setup that would still allow you to hear both Dorico and other applications on your computer, but I’m afraid as a Mac user I can’t personally provide the magic incantation you might need.

I don’t have your interface, but the Tascam website has some recently updated drivers that suggest it now works better with multiple clients (they merged their “Basic” driver with their “Mixing” driver). Perhaps you can give that a shot? https://tascam.com/us/product/us-16x08/download

Hi guys,

Thanks for the responses on this - I’m loving the software aside from this. I’m on the latest driver for the interface so it looks like there’s not a lot I can do at the moment, fingers crossed it can come back in the future!

Thanks,
Joe

Joe could try using VB voicemeeter https://www.vb-audio.com/Voicemeeter/

This works for me. You feed your Dorico output into Voicemeeter main virtual input and then your windows audio (eg spotify/youtube) into your Voicemeeter virtual Aux input. I can make a short video on this on Youtube if you or anyone is interested.

I hope you guys find a solution, as the omission is a real problem for me using YouTube and other sources to make transcriptions for my students. It worked OK in Dorico 3.0 for many months. Windows 10, mediocre computer with ASIO for all on Behringer USB mixer :slight_smile:. No crashes, so I’m surprised it disappeared. I’m back to Dorico 3.0 for now. But I’m going to try Voicemeeter.

Although I don’t use Windows myself, I believe it’s pretty simple to set up. See e.g. this earlier post by FredGUnn.

Not sure if I should post this here, but I have recently purchased a Steinberg UR22C Audio Interface as my old Audio Interface is no longer supported by the manufacturer and is unable to connect to my new M1 Mac Mini.

With Dorico running, I open Safari to view YouTube (perhaps Dorico tutorial videos), and I get no sound from YouTube. I have to close Dorico, for the sound to work. I have read things from another thread that makes it sound as if this shouldn’t be a problem, but I am unable to make it work.

Any suggestions?

Robby

On macOS, that’s very unusual. I have a UR22C connected to my own M1 MacBook Pro and have no problems at all like that. Do you definitely have the latest version of the UR22C drivers installed?

1 Like

I’m 99% sure I do. V3.0.5 is what the software says.

Robby

I have a no-longer made (and probably soon to be no longer supported, if not already so) Thunderbolt Display connected to my Mac mini. When the UR22C is connected to the Mac mini, and I have Dorico open, Safari is trying to run the sound to the Thunderbolt Display, whose volume is reduced to just about zero. I can hear faint mumblings.

I cannot find any setting anywhere to force the application in the foreground to use the UR22C.

Robby

This might sound stupid, but did you make sure to have the UR22C selected as your systemwide output device in system preferences → sound → output?

I did. I set it as my system wide device.

Robby

I have looked through every possible setting that I can think of, I have left a message on the Hardware forum for the UR Series, and I cannot seem to find out what is going on.

Since this is a M1 Mac mini (not a pro machine) I wonder if it has to do with the UR22C being powered through the USB. And more importantly through a USB hub. Of the 2 USB ports on this machine, one is for the USB e-licenser, the other is for the USB hub, as I have my MIDI keyboard, my Stream Deck, and my external USB hard drive all connected.

Nonetheless, it still seems weird to me. Would the e-licenser work connected to the USB hub, and I use that slot for the UR22C? It’s been 5+ years since I bought the e-licenser, and I thought I read/heard that it had to be plugged into the physical port on the computer and not a hub. Am I remembering this correctly? Or am I completely wrong?

Robby

Something weird is going on…

When Dorico is closed, Steinberg UR22C is selected as my default sound device. As shown in the picture in an earlier reply.

However, when I open Sound preferences AFTER Dorico is open, it shows that Display Audio is my default device. If I change it while Dorico is open, it shows the change occurred, but does not reroute the sound. It still uses the Display Audio.

The UR22C control software is very minimal. It just allows me to select the the type of USB port it is plugged in to.

For now I think I can live with this, as I can adjust the volume on my keyboard for the display audio, but the whole things seems bizarre that it is switching between sources when I am setting it up not to do so.

Robby

Edit: And just to be clear, when I close Dorico, Youtube/Safari will then use the UR22C as the sound output device, and I can control the volume with the volume on the UR22C.

I just read this recommendation today.
Voicemeeter is now installed and working beautifully.
Many thanks tor the tip!

Incidentally, I’m using an EVGA Nu Audio sound card, which sounds great.

Yes, for MacOS, that is weird. However, there are a few quirks in CoreAudio. I would create a Multi-Output device in Audio Midi Setup.app.

This is a mechanism for creating virtual sound outputs that include more than one real device. However, there’s no reason why you can’t have only one device – your UR22C.

Then set System output to this device. You can try leaving Dorico’s output to the ‘real’ UR22C, or change it to the Multi-Output one.