Dorico 4 and Dorico 3.5.12 on Windows 11 ARM within Parallels Desktop

Dear developers and dear non-English users,

I need a Dorico-instance on Windows because Dorico 4 still does not support the Korean Input System in Lyrics popover.
Thus, I have tried to install Dorico 4 or Dorico 3.5.12 on Windows 11 ARM within Parallels Desktop onto an M1 machine.
At first, I had tried it without ‘Steinberg Download Assistant’. However, installing ‘Steinberg Library Manager’ failed. The installer shows an error box in which the following messages are displayed:

Then I tried it using ‘Steinberg Download Assistant’, but the same problem occurred as follows:

What could be the problem, and how could I resolve it?

The error with installing the Steinberg Library Manager typically means that Windows is running some other installer at the same time - this might not even be anything to do with Steinberg, it could be a system update or something like Dropbox’s auto-update. I would try rebooting your computer and then re-running Steinberg Download Assistant.

The second message is correct - the Dorico installer needs the Steinberg Library Manager to be installed first.

Thank you, but it is bizarre.
There were no other installers, and I rebooted Windows five times. There is no Dropbox as well. I will inspect again.

I rebooted in safe mode, and installing ‘Steinberg Library Manager’ still failed. No other installers are running.
It is strange. I had not this problem when installing Dorico 3.5 onto Windows 10 within Parallels Desktop onto an intel machine.

I reinstalled Windows 11 using Parallels Desktop on the M1 machine. At this time, I firstly installed ‘Steinberg Download Assistant’. After that, it tried to install ‘Steinberg Library Manager’, but the ‘Steinberg Library Manager’ was not installed.

Did Steinberg Library Manager install successfully this time?

I did not separately install it. However, ‘Steinberg Download Assistant’ did not successfully install it.

Could you try downloading and installing it from here: https://o.steinberg.net/en/support/content_and_accessories/steinberg_library_manager.html

I did it on my first virtual machine on m1MAX MacBook Pro.
I do not think that it will work on the second virtual machine on m1MAX.
However, I will do again because you recommend it…
I will report again.
Thanks!

The same error occurs.
I think that normal users cannot resolve the problem.

I think it’s worth pointing out that we do not officially support Windows 11 ARM edition, and nor do we officially support running our software under virtualisation.

1 Like