Dorico 4 mixer oddness

Hi all. Noticing a few odd things in D4 mixer.

firstly, when you move a fader on a VST, it takes quite a while before the sound level changes, it’s like it is ramped slowly up and down. If this is by design, I suggest the design be revisited, as it makes the job of setting levels more difficult. Actual mixing desks don’t do this.

secondly, (and I realise that the instruments with NotePerformer are multiplexed onto only a couple of VST instances)… the faders for the instruments do nothing. I’m used to Sibelius, where the faders on channels for the instruments flow through as CC1 messages to the VST, and so actually have an effect on the instrument’s output level. These channel strips seem to be pretty much decorative only, as the faders do nothing, the pan does nothing.

The reverb level at the end does nothing either.

Understand with NotePerformer, that NP is doing the reverb via CC, and the actual mixing. It would be great if there were some way to integrate the NP mixer into the Dorico Mixer (extend the VST interface for that).

1 Like

I’ve also noticed some of these things:

  1. The faders seem to have some kind of delay to take effect.
  2. The faders seem to be somewhat “toned down”: Pulling faders (of VST instrumetns) all the way up only results in a slightly louder tone, almost not noticable.
  3. MIDI faders seem to not have any influence at all.
  4. Reverb level: @adrien you have to open the reverb plugin and active it (for example by loading one of the presets). Initially it is not activiated, thus the fader has no effect. (I was confused by this, too.)

The REVerence effect is enabled by default. There’s been no change in that area since the previous version of Dorico.

The faders in the Mixer don’t have any rate-limiting on them, which is why they can feel like they lag behind your movements. We will add rate-limiting so that they feel more responsive. In the meantime you should find that decisive, larger movements produce a faster response.

The MIDI faders do indeed evoke a response. If you open e.g. HALion Sonic SE and look at the Mix page, then waggle the corresponding MIDI fader for that channel in the Mixer, you will see the Level move up and down as expected.

NotePerformer is its own beast. I’m afraid I’ve not used it for a year since I switched over to an Apple silicon Mac, so I can’t remember the details, but obviously its approach to mixing and balancing is by design completely different to that of all other VSTs.

I’m having mixer oddness here as well. This morning, I created a new lead sheet entirely in D4 . Vibes and a chord track. Both tracks play correctly. I’m sending both tracks to the FX channel, which is running REVerence, but neither is reaching the FX channel. I’m testing it with Dorico Beep, and that is getting to the FX channel, so I can confirm FX and REV are working.

Then I noticed that the vibes and chord track are not lighting their meters when playing. (Mute, unmute, and the faders work, so I can confirm they are the correct tracks.) I went to the mixer in the lower zone, and at first the meters were lighting, and now they’re not. I’ve closed and re-opened the project, restarted D4, and rebooted. The project plays fine, but the meters do not light in either the lower zone or the big mixer. (Win 11, all latest updates.)

edit: I just opened the same file on my Win 11 laptop. I had to switch from Halion 6 to Halion SE, but got the same results, the project plays, but the meters do not light. Perhaps something is now corrupt in the project.

I am very reluctant to report any niggles - this is niggle is small once you are aware of it, and this release is really something awesome.

Nonetheless you have to be a little careful using the mixer if you have a laptop with an external monitor. What I have found on Windows 10 is that if you:

  1. drag the mixer to the external monitor (to the right of my laptop screen, should that matter).
  2. Shutdown Dorico first, then Laptop
  3. Pack up and go elsewhere (IE: no external monitor plugged in)
  4. Start Docio and bring up the mixer.

That the mixer is never visible. It is still “on” the external monitor. Or at least so it seems as when you re-plug in an external monitor it shows up fine.

same here on windows 10: sends on instruments don’t send any signal to the fx channel. Doric beep does. The bug is independent of the VST inserted on the fx channel; it happens with reverence and other plugins as well.

That’s very odd – again, although the Mixer has a different user interface than it did in Dorico 3.5, under the hood it’s doing the same thing. I’ve just verified here on my Mac that the sends certainly are making their way into REVerence for the plug-ins in my rack. I can’t easily verify this on Windows myself but perhaps @Ulf could check when he gets a moment.

@gdball There are some similar multi-monitor issues being reported. The wondrous Qt framework is supposed to take care of this for us, but I’ll take a look and see if I can figure out a solution for this problem.

Works for me well on Win10

Hi, I can repeat it on both my Win 11 workstation and laptop like this:

  1. Create a new project from template, e.g., solo piano. Enter some notes.
  2. I’m using the HSSE + HSO playback template. The template loads the Halion Sonic SE VST. Playback is fine, as is the send to rev.
  3. In the VST rack, load any other VST in the slot where HSSE was.
  4. In the VST rack, load Halion Sonic SE again. Doing this resets the sends, so you have to re-enable the FX radio button and give it a send value.
  5. HSSE is no longer sending anything to FX. If you turn on Dorico beep, and give it a send value, that works.

OK, sounds like maybe NP is ignoring the level and pan commands from the mixer then, instead of reflecting them in its own mixer, and forcing you to adjust in the NP mixer.

Understood, that’s outside Dorico’s control. I wonder if Arne will rethink that.

Right, thanks – that was the information missing from the original report (or at least I missed it). When you replace a plug-in in the rack, it’s really tearing the whole thing down and setting it back up again, and it does indeed appear to be the case that the FX send is disconnected at that point. Thanks: we’ll take care of this as soon as we can.

2 Likes

Would be nice to get a forced number of instrument busses showing on the Mixer again (even if there is no stave assigned).

It’s good to be able to route internal effects of a plugin to some faders of their own and have that on the mixing desk.

Before we could click the settings cog (where expression maps and such are assigned), tick that box at the bottom, and specify exactly how many outputs to throw up on the mixer.

For the time being we can toggle “Show Unused”, but that gets a bit messy with a 32+ bus instrument.

Also miss being able to hold ctrl and click a fader to have it snap to the mid-way default (most DAWs snap to 0.0, but Dorico has been somewhere in the middle for so long that people have ‘gain-staged’ instrument setups accordingly. Maybe give an ‘option’ in the future for the default snap point to be 0.0 or whatever it’s been in the past?)

can double click or ctrl-click (either works) on the gain number showing just above the fader for this.

Yep, it’s non-standard and the target to click on is much smaller. Would prefer ctrl-click on the fader to return it to the default position as per everything else.

2 Likes

I think I recall Daniel saying the fader control doesn’t currently support this action, so it’s difficult to do.

Is there a way to reconnect the FX send after it was disconnected in this way? This seems to be happening when I change tracks from HALion to Kontakt, if I understand correctly.

If possible, (and if it’s not already doable in a way I don’t know of) it would be really helpful to be able to set up or edit busses and sends like the FX send manually as you might in a DAW, maybe somewhere down the line of updates.

I’m afraid at present, no, there’s no way to reconnect the FX bus. We’ll make sure this gets fixed in the first maintenance update.

Down the line I can definitely see us adding further send busses, absolutely.

4 Likes

This is affecting me as well, with NP.

Why can’t we have a simple send interface like we have in 3.5? THere don’t seem to be sent blocks/faders anywhere in 4.0

I’ve tried to work around it by putting Reverberence on the master stereo bus, but then you ONLY get the reverb tails and not the signal.

What you have in the Mixer in Dorico 4 is what was actually possible in Dorico 3.5, namely that because there’s only a single FX/reverb channel, the only useful parameter is the amount of signal to send to that channel. This problem will be fixed soon – we hope to have the first update out at the start of February.

Hi Tyler, you can put REVerence on the master stereo bus. It defaults to 100% wet, so you’ll just need to change the MIX level in the lower right corner to something much lower. That will give you a mix of the wet and dry signal.

1 Like