Dorico 5 Mixer and VST output channels

With the introduction of spatial positioning in D5, I’ve decided to take the weekend to try to move more of my production out of my VSTs and into Dorico.

As a first and most basic requirement, I need to see the output levels of my instruments updating in the Mixer, which have never been accurate for whatever reason(s), despite my routing all of my instruments to separate outputs in my VSTs (all of which are Kontakt). For example, my string ensembles VST output look like this:

Pretty simple, and as you can see, each output comprises 2 channels: 1|2 for 1st violins, 3|4 for 2nd violins, 5|6 for the violas, etc. I’ve actually got 12 instruments in my rack, but all of them are assigned to one of these 5 outputs. For example, my Violins 1 section is split into two instruments in my rack, but they’re both assigned to the “vln1” output:

Over in Dorico, I’ve got this kind of action going on:

Doubled cello and double bass controls, presumably because I’ve got divisi sections in the score; that seems a little odd to me, but whatever. More control over my sounds, I guess. Yay.

What’s annoying is that only Violin 1 sound is properly visualizing. When I produce viola sound, it visualizes in the Violin 2 mixer. When I produce double bass sound, it shows up in the Viola mixer. My 2nd violins and cellos aren’t producing visual readouts at all (apart from the master output mixer, of course).

If I go back into my VST and assign the output channels thusly, then I get the expected/desired result in Dorico (i.e. all visualizations seem to work OK):

My problem with this is that I cannot ascertain algorithmically how these channel assignments work; neither can I find any interface in Dorico that exposes any correspondence between its internal numbering and the numbering in my VSTs.

Is this just accepted as trial-and-error setup? It kind of blows, because it destroys the intuitive setup in my VSTs. For example, my cello outputs go from looking like this…


… to looking like this:

In case anyone is wondering, this isn’t resolved by restarting Dorico or anything; apparently, these are necessarily permanent tweaks.

Does Dorico reserve four output channels per instrument, is that what I’m seeing? If so, why?

No, I’m afraid there’s nothing clever going on here. Dorico can’t actually interrogate the plug-ins to find out anything about each output, e.g. what you’ve labeled it in the plug-in, etc. It doesn’t even know for sure what instrument is producing the sound that is returned on each output – there is no direct connection between the slot or MIDI channel that Dorico sends instructions on and the audio output on which the signal is returned.

So Dorico makes assumptions: if an instrument is played on MIDI channel 1, it is returned on audio output 1, and so on.

We can’t make this more automatic, but what we do plan to do is make it possible for you to choose between a few presets for common audio routing scenarios, so that you can tell Dorico which assumptions it should make.

In the meantime, you can at least now rename the outputs in Dorico’s Mixer to match what’s going on in your plug-ins. The only thing you can’t do is selectively tell Dorico which outputs really are being used, so rather than using the Unused filter in the Mixer, you might find it better to use the Endpoint Setup dialog to specify how many outputs should appear for each plug-in, and ensure that you don’t leave any gaps in the used outputs in your plug-ins.

Hope that makes some kind of sense – it’s early and I’m still rather run ragged by the busy-ness of the past several days.

Thanks for the fast response, Big D. Sounds like I’ll simply have to fight through figuring out channel-to-output assignments in my VSTs, but as long as everything works consistently, I’ll be satisfied.

Hi, I’m trying something similar and trying to understand the behavior here. In my case, I’ve got 9 VIs in a Kontakt multi, 9 players, 9 staves, 9 midi channels, 1:1 for everything. But even so, I’m getting weird things like player/track/channel 7 coming out of tracks 8 AND 9 in the Dorico mixer. Meanwhile, player/channel/track/stave 8 is audible coming from the stereo out in Dorico, but doesn’t appear to come out of ANY of the actual channels in the mixer itself!

This seems like it’s basically the same issue that started this thread, but it’s very confusing. What’s even more confusing to me is that I’d originally loaded this with the Halion sounds that Dorico defaults with, and THAT had each player routed as you’d expect to each channel in the mixer, so why can’t I create a simple swap out of the sounds? I’m especially confounded by player 7 coming out of 2 channels when Halion didn’t, so somehow Dorico is now reading mixer channels 8 and 9 as having the same inputs when it’s Kontakt but they were separate in Halion.

Hi @Composerbell , you really need to check on Kontakt side. Kontakt has it’s own mixer and you can route any VI to any of the Kontakt outputs. That internal routing of Kontakt you need to check.

This is what my Kontakt outputs look like. It’s as straight forward as I can imagine they be - 1-2 for port 1, 3-4 for port 2, 5-6 for port 3 etc etc. I can’t see any reason why the Halion version loaded up would have been configured any differently. Halion calls them outputs 2, 3, 4, but those must be stereo pairs because the output is clearly not mono when I play a single player with the mixer panned center.

First of all, you are right @Composerbell , the outputs of HALion are by default stereo outputs.
Second, the screenshot of Kontakt shows only the first 6 plug-ins, but not the 7th to 9th plug-in instances, and especially the 7th is crucial here, so could you please scroll the window and post anther screenshot? Thanks

The last few patches aren’t any different from the pattern except they’re the male choir version of the patch.

Thanks for the new screenshot.
Right, it looks okay, but there are 3 channels with the same name “07 Chorus - Men”. Did you really make sure, that each VSTi instance is playing out through the respective channel or are they maybe playing out via just the first “07 Chorus - Men” channel?

I’ve confirmed that as I select a note on each track, it goes to the correct port, instrument, and output within Kontakt. It only get weird when I go to Dorico’s mixer window.

output confirmation

Here’s what happens in the mixer window. The first note I select does it as expected (as do all other players I don’t show here), but the last several show up strange in the Dorico mixer.

mixer error

On those last two though, I still HEAR output, and it shows up on the Dorico stereo out - but nowhere on any actual channel strip in Dorico. Which I really don’t understand, where is the stereo out getting the signal from then??

I’m also now noticing that for these players with the error, they’re also coming out mono. Even when they appear to be coming out of the MR or ML channels (which have panning applied), they’re actually still coming out mono! So it’s somehow IGNORING the panning on the Dorico channels they’re coming out of, to boot!

Meanwhile, the two that don’t appear to output in the mixer at all are still somehow sending to the reverb fx channel (how is that even possible, when that’s a send off of these instrument channels, and none of them are receiving anything in the first place when I select those players??), and the reverb, at least, is still stereo.

Hm, really strange…
Could you please send me the Dorico project file to u dot stoermer at steinberg dot de? Thanks

Thank you!

Thanks for the project, but it is a little difficult for me, because it does load but I don’t have those choir sounds. I can instead load other VSTinstruments, but then the previous routing gets lost in Kontakt. That’s why here my next question:


If you click in Kontakt on that area that I have circled red in the picture, a little window pops up. What does it say in your case, where does that channel get routed to? Also compare that to the other neighbouring channels.

1 Like

I’m in quick browse mode so forgive me if I’ve missed something.

I think I’ve scanned enough of the thread to understand that ‘internal effects’ of a multi-audio output capable program can add confusion.

If something like Kontakt, HALion, Opus/Play, etc, offers built in effects in some sort of ‘shared aux bus’ configuration, it helps to understand which set of audio outputs the ‘aux effects bus’ is assigned.

It can be pretty confusing at first!

Example:
Some symphonic library uses a fancy convolution reverb on an aux send that is ‘shared’ by all slots in the plugin instance in the plugin’s own internal mixer.

I’ll call this an ‘internal AUX bus effect’.

The AUX bus reverb might be set to send its effects out audio ports 1&2.

ARIA always uses 1&2, and it cannot be changed, but I use Bidule to move some things around.
image

More modern players like Kontakt typically allow you to change those aux bus outputs though! So you shouldn’t need that ‘bidule workaround’.

Anyway…the confusion…

So…no matter what you do with the mutes/solo buttons, you might still hear the bleeding of that reverb through ports 1&2.

Often what I’ll do with such plugins is isolate the aux bus reverbs to a fader of its own in the first set of outputs that are not actually hosting a ‘dry instrument’ sound. It might not show up right away in the Dorico Mixer unless you click a tab to show unused outputs.

In this case I’ve configured a Bidule/Aria instance to divert their internal ‘effects bus’ to outputs 11 and 12. So it’s doing:
Violin 1 (1&2)
Violin 2 (3&4)
Viola (5&6)
Cello (7&8)
Piano (9&10)
Built in Aria Reverb (11&12) [a single pair of reverb effects shared by all the instruments slots via ‘send’ knobs in the plugin’s built in mixer]

At first I see no fader for my verbs channel because there is no stave connected to it as an end point in any way. Dorico does still pipe the ‘sound’ through, even tho’ I cannot yet see the fader on the console.

So I click the button in Dorico’s mixer to show ‘Unused’ faders.

I can double click the name field for the outputs my verbs were assigned to and give it a name of my choice (ARIA REVERB in this case).

Once I’ve done this, I can hide the subsequent Bidule/Aria faders I don’t want showing on the mixer anymore in the endpoint settings dialog. (Just show the first 6 sets of stereo outputs)

Alternatively, you could set up an empty hidden player/section stave and connect it to your dedicated ‘reverb channel’. That would force it to show up on Dorico’s Mixer regardless of the state of that ‘Unused’ button.

Obviously, if you’re using all 16 channels of a plugin that only a asks for 32 (16 stereo) during the VST initialization phases, then those aux send effects might ultimately have to share an output with something.

It’s usually not a big deal to allow a plugin’s built in aux bus effects to share a channel with the dry output of one of the instruments. The overall mix is fine.

It does confuse a lot of people when they try to mute/solo things, and see meters bouncing that they don’t figure should be bouncing though! Just ‘knowing/understanding’ why it happens, and that it’s normal helps a ton!

An alternative to jumping through all these hoops is to learn if your plugin has a quick and easy way to simply ‘enable/disable’ or ‘move’ the internal effects when you really ‘need’ to get a clean ‘solo/mute’ thing going on for one of those channels that might be sharing your aux send effects.

I.E.
I soloed my piano, but I’m still hearing a bunch of other junk! Why?

Usually means that a set of outputs is also hosting some sort of aux bussed effects chain that’s built into the plugin itself.

Solutions include isolating the effects to a dedicated fader like I showed above, or just popping open the plugin and temporarily disabling the effects, or moving the outputs of the effects bus to some other set of faders that you’re not trying to solo at the moment.

Greetings from Spain. 1- I assign an audio output for the 16 midi channels. 2- I assign a midi channel to each instrument. 3- same audio output for 16 midi channels. 3- - Look at the screenshot. In short, 1 stereo channel for Audio. 16 midi channels for instruments.

There is no mixing of instrument sounds on different audio buses. I only work with an assigned Audio bus.

“Split instruments routed to first out channel to individual outputs”

I find the fastest way to miss a solution is to assume I have done my part perfectly, that something else is to blame, and to restate what I have done. Since in such cases, since I am the only resource I can control, I have to examine all possibilities to see if there is anything I can correct, even to the extent of starting over from scratch on a test file.

Of course a quirk in the software I am working with may indeed have been the cause of the problem; but since I will have to find the quirk and work around it, I cannot afford to assume it is someone else’s problem.

1 Like

Hi Ulf,

This is what appears when I click the 17|18 output.

This is exactly what I would expect to see. Each instrument is assigned it’s own stereo output, in sequential order.

If something like Kontakt, HALion, Opus/Play, etc, offers built in effects in some sort of ‘shared aux bus’ configuration, it helps to understand which set of audio outputs the ‘aux effects bus’ is assigned.

I can confirm that within Kontakt, I can see it has 4 aux channels set up. While yes, they are assigned to output to 11 through 18 (certainly concerning output choices as I’m using those outputs), I can also confirm that as I check each loaded patch, there is no audio metering on any of those aux channels. So they’re not in use.

Additionally, if any reverb WERE routed to go out 1|2, wouldn’t I then see that meter on the Dorico channel routed to input from Kontakt’s 1|2? Which would be the first vocal track.

I turned on “unused” in the mixer, and holy moly, that’s a lot of channel strips that appeared! I’d now discovered that I don’t apparently know how to scroll left/right in the mixer, because my attempts with my scroll wheel aren’t moving the display at all. So I’m unable to see to the end of the unused channels if any of them are outputting anything.

One thing I’ve noticed that is concerning is that they’re all leveled down by -6.2db, which I thought was something I’d done manually to the channels I was working on, and a few of them even have panning settings similar to tracks I’ve been using! So I have no idea how I’ve altered settings on some of these channel strips I’ve never seen before…

Hi @Composerbell ,
it now starts making sense to me, though I’m still a bit confused.

When you instantiate Kontakt it presents to Dorico very many outputs, stereo and mono, as there are:
“Kt. st. 1”, “Kt. aux 1”, “Kt. aux 2”, “Kt. aux 3”, “Kt. aux 4”, “Kt. unsassigned [1]”, “Kt. unassigned [2]” and so on until "Kt. unassigned [54], so that is a total of 59 output ports. The first 5 of them are stereo and the rest is mono.

Now, for the moment disregard the channel labels in Dorico’s mixer for a moment. They are just names and could be just anything. Important is the real routing underneath, and that is pretty simple. The first Kontakt output port is connected to the first fader/channel in Dorico and then just spilled out in consecutive order. So actually the labelling in Dorico should be really like written above, starting with “Kt. st. 1” and ending with “Kt. unassigned [54]”.
Remember, the first 5 are stereo, after that comes all mono. To play out the 6th instrument as stereo, Kontakt uses 2 mono ports (“Kt. unassigned [1]” & “Kt. unassigned [2]”), but Dorico does not know anything of that internal routing in Kontakt, so the 6th Kontakt instruments plays out it’s left signal through the channel labelled “L3” and the right signal through “MR”. And accordingly the 7th instrument creates level metering on “ML” and “MC”. The 8th and 9th instrument you don’t see, because they are on the “unused” channels.
I don’t know if you could follow this explanation, but what you see in the Dorico mixer is completely logic and sane. Dorico does not know and can’t know that some instruments come in from Kontakt via two mono ports.

That leaves the question, how do you set up the whole thing to make it all work to your expectations? This is something that I can’t answer. How do other users work with Kontakt under the given constraints?

And in regards to scrolling through all the faders in the mixer. Hover with the mouse over the fader area and spin the mouse wheel.