Dorico (always) hanging (on vst scan?) before starting and (sometimes) crashing


I’ve started to run into a new issue. Been using Dorico 4 pretty regularly for a year, and this started happening last couple of days. Haven’t updated Dorico (on latest for Mac) or my Mac (12.6.3 M1).

The issue:

Dorico hangs on startup, and never opens the project browser screen. When I go to activitymonitor, I see “vstscannermaster” using a full core and staying there permanently. Force quitting that process opens the project browser, but when I open my project, I get a crash: (13.3 KB)

The hang at startup without killing the process happens every time. The crash does not happen every time.

I haven’t recently changed the composition of my installed plugins, and other DAWs don’t have issues scanning.


EDIT: Also, I have tried to reset audio engine cache within Dorico, and it hasn’t solved the problem.

Hi @dyross , I need a spindump from the scannermaster, so please start Dorico again and then in Activity Monitor at the top of the window is an icon with 3 dots. Click there and choose Spindump. The corresponding output please post here. Thanks.
Then kill all processes and follow along this line: Go to /Library/Audio/Plug-ins/VST3 and rename that VST3 folder (temporarily) to something else. When you then start up Dorico, does it behave properly?

Hi @Ulf - thanks for the response. Here’s the spindump: (547.2 KB)

Yes, when renaming VST3 folder, Dorico starts up normally.


Hi @dyross , thanks for the data. Unfortunately I can’t see from it, which plug-in is the culprit. But you can quite easily find out with following strategy:

  1. Rename that VST3 folder to something different
  2. Create a new empty VST3 folder
  3. Go to the original/renamed folder and copy half of the plug-ins to the new folder
  4. Start Dorico again and see how it behaves. If it fails again, you know that the culprit is among that half in the new folder, so you throw out half of the plug-ins of that folder and do the same again, i.e. Start Dorico and see how it behaves.
    You see the principle, right? You iterate by always taking half and half again, you can fairly quickly find out the culprit, even if you have lots and lots of plug-ins.

Ok, this is embarrassing.

For some unknown reason, there was an alias/symlink for the VST3 folder itself inside the VST3 folder, creating a clear infinite loop. No idea how that got there, but now that I’ve removed it, things are working normally.

Thanks / sorry!


I’m glad to hear that you have it running again.
And don’t worry, we all make mistakes like that, no need to feel bad.