Dorico and Surface Dial Issue

Just bought a Surface Dial and started setting up an app tool for Dorico. This is just a straightforward mapping of key commands and shortcuts.

Once setup I launched Dorico but the tools were not available on the dial. This failed several times and eventually managed to get a ‘test’ command onto the wheel. I then tried to remove the Dorico app tools from the surface dial, and whilst it appears the app tool has been deleted, it still shows in Dorico.

I have tried the dial with several other apps (Sibelius, Cubase, OneNote, Word etc) and all these work as expected.

I have spent about 90 minutes with Microsoft Support who believe the issue to be Dorico related (especially since it works perfectly with everything else), but I was hoping there was a way to completely get rid of the app tool and start again.

Uninstalling and re-installing the dial does not cure the issue and Dorico still thinks this test app tool is there and ignores and newly created ‘actual’ app tools.

Confusing or what???



What are you expecting Surface Dial to do in Dorico?
Dorico is very definitely not on the list of supported apps here:

You can assign keyboard shortcuts for any apps to surface dial

You can? :astonished: :open_mouth:
Didn’t know that! Dial, here I come! :ugeek:


It’s great. Just having issues with Dorico.

We’ll see if we can get our hands on a Surface Dial and look into this further. It may take us a while.

Yay!!! :sunglasses:

Hi Paul,

I have a Surface Dial now here. I did not have much time, yet, to muck around with it, but the most basic stuff I did with it so far did work for me.
So I set up a custom tool and mapped ctrl + page up as Fast Forward, ctrl + page down as Rewind and space as Start/Stop (of course made sure that the keys match with the commands in the Dorico Preferences) and yes, works beautifully for me.

Maybe you can explain in more detail what you are trying to set up and what does not work with you.


I’m wondering: is there a discrepancy in how you have things mapped? IE-- are the custom commands set on the dial also properly mapped within Dorico itself? (In other words, if you set ctrl+J on the dial for example, is ctrl+J recognized for the same desired commands within the Dorico custom key commands?)

Indeed, that is the premise for making it work. Assign a certain key combination to the custom tool of the dial and then make sure that in the Dorico preferences that key combination is mapped to a certain Dorico command.
So in my case, I did that…and it works.

From reading the documentation/advertising material, if the app (i.e. Dorico) was aware of the Dial, then Dorico could reprogram the Dial short cuts on the fly (for example, change the labels, and make them context-sensitive).

But since the current version of Dorico isn’t Dial-aware, the Dial can only generate a fixed set of keystrokes, which you can customize using the app that comes with the Dial itself. Dorico doesn’t “know” whether you did something using the Dial, or just pressed a key on your computer keyboard.

Hi Ulf

Surface Dial installed and working well except for one frustrating issue.

I have created an App tool (in Settings>Wheel) for music music writing app Dorico.

On launch of Dorico the app tool created was not available (just default tools), even though it is shown as created in settings.

In case this was app specific, I created other app tools for various apps and these all work as expected. So I deleted the Dorico tools and re-created a quick test tool for Dorico. This showed up in Dorico but didn’t have the function I require because it was set up purely as a test.

I have then gone back to settings and edited the Dorico app tool. Here’s the issue. On launching Dorico my newly edited version of the tools is now there, but the earlier test version is.

I have then removed the Dorico tools from Surface Dial and created the tool again. On launching Dorico, the new tool is now showing on the dial but the original test one is.

I have uninstalled and reinstalled the dial twice and also reinstalled Dorico. No change.

When I uninstall and reinstall the dial all previously created tools come back, this seems to show it does not completely uninstall.

I have spent a couple of hours with Microsoft support, but they don’t believe this is the driver not being uninstalled but directly related to Dorico. I asked for help to totally remove Dial and reinstall from scratch but they were unable to assist.

I may be wrong, but to me it appears there must be some kind of (sorry reaching the end of my knowledge now) preference, database type file which stores these custom setups for the dial and it’s this that needs to be removed to be able to start again.



Jees! Been on support with Microsoft for 4 hours. They have no idea how to remove the surface dial from the registry so I can start again with it.

Best MS can come up with is to reinstall my entire system.

Created a new user account on my Surface Pro and that is seeing Dorico as a trial version but Dial works correctly.

Hi Paul,

so the Dial issue is now fully solved for you, right?

In regards to the licensing, please follow the reactivation procedure as described here:

Hope this helps.

Hi Ulf

No it isn’t. Setting up the dial in the new user account has followed exactly the same behaviour as before.
As soon as I set up app tools the problem has reoccurred.

I don’t have a Surface Pro here, just a normal laptop with Win10 and the Dial. With that I can only create one custom tool, so only one assignment for rotate left/right and push, nothing more. But at least that one custom tool works well in conjunction with Dorico.

For your more advanced setup, sorry, I don’t know of how to further help you…

Anyone else here with a Surface Pro and a Dial?

Hi Ulf

Just to confirm we are at the same point.
I can successfully create a custom tool. This is a tool that appears all the time the dial is used.
My issue is creating an app tool.

I click add an app
Dorico does not show in the list of apps
Click browse for more apps and navigate to programs folder and locate dorico
I then create a tool (which can be names) In my case I created a shortcut a named it grid res.
Opening Dorico the new App tool does not show.
If I go to settings and try to create a new app tool Dorico is now on the list of apps but greyed out (which shows that settings believes an app tool has been created).
I am then unable to get back to a state where settings allows an app tool to be created for Dorico.

This is the behaviour experienced in the new user account.

My first attempt, I followed this by managing to create a named (test) tool. I did this by adding dorico again. The tool appeared in dorico but because it was a test, needed to be edited. I am unable to edit of remove this tool.

I have successfully created app specific tools in other applications without issue. Situation seems to only occur in Dorico.



Hi Paul,
I just have a normal laptop with Win10 and I therefore I don’t have that option to create App Tools. My Control Panel just allows me to create a Custom Tool, nothing more. Since you only have trouble setting up App Tools, I can’t help you further at this stage.