Dorico and The Grand vst, bug with velocity curve

Sometimes The Grand resets the velocity curve. Sometimes it happens when opening a project where it was previously ok, sometimes it seems to happen under other circumstances (have not isolated).

Sometimes after fixing it to a correct curve, closing the VST window and opening the VST with Dorico (Play → e), the VST has reset it to zero again. The only workaround seems to be continue clicking and changing various tabs until it seems to set properly.

Obviously can be very annoying when trying to Export audio. Also not sure how to verify it is correct (other than listening carefully to the output, at specific time points, etc) .

This happened in Dorico 4 and now again in Dorico 5.

I don’t personally use The Grand, so I’m not sure whether the velocity curve in the plug-in can be set externally, e.g. via a MIDI message. From what I can see in the Operation Manual, there’s no obvious way to change this parameter automatically from the host. It sounds like it could perhaps be a problem with the plug-in itself rather than with Dorico, since Dorico can only communicate with VST plug-ins via MIDI (it doesn’t yet support the automation of other VST parameters).