Dorico can't play grace notes in the first beat of the first measure

It’s not a big deal (at least for me) but I’ve noticed that Dorico can’t play grace notes in the first beat of the first measure. I attach a picture of an example.
dorico cant play grace notes first measure.png

This is by design: grace notes in the first measure are effectively in negative time. So if your workflow involves video, working to timecode or audio export to another app, then if Dorico shifted time to compensate for that, then the audio would be out of sync. There is an option though so you can allow this: Playback Options > Timing > Flows > Pre-roll before flow. Just set that to something like 0.5 seconds and it should play back correctly.


Talking about playback issues, Dorico can’t play grace notes in the first beat of the first measure of the first flow (I think it’s because they happen before and they should be handled as a pickup measure). It’s a very different playback issue, I know.

I think Ulf just answered that question. Set a pre-roll before flow in playback options->Timing.



Indeed Dan. ; - )

reztes, please don’t post the same question in multiple threads, particularly when you have already not only started your own thread on this topic but also received, within 30 minutes, the correct answer to your query.

I have moved the additional question from the thread you hijacked to this one. Posting the same question in multiple threads is a close relative of thread-bumping, which is considered poor etiquette on this forum, so please refrain in future. Thanks for your consideration!

Thank you for your help.

PS Daniel, the truth is that I wasn’t aware of (the nature of) what I was doing. I’m sorry :frowning: My mind erased the first one.

No problem at all. I’m glad the solution worked for you.

I’m just restarting my homework of migrating from Sibelius and composing from scratch my first guitar/piano arrangements: so I may miss something here.
Anyway I see the same do-not-play issue also for a grace note of the first note of ANY BAR in the flow, in case you are playing back from THAT bar (e.g. select the bar with a grace note for the first note and hit ‘P’).
As expected, setting a pre-roll interval before the first flow does not have any effect: the only workaround I found is to playback from the bar preceding the one in question.

Based on Paul’s explanation, that would seem to be correct because the grace notes do actually get played before the start of the bar, at least in this particular case. I think you just want to start on the end of the previous bar.

I hadn’t thought about it, but I’m very appreciative that Steinberg thought of how it would affect video or any kind of syncing.

1 Like

Thanks Gregory,
you are correct: my expectation is to playback a grace note (more precisely, an “acciaccatura”) even when it is on the first beat of any measure. Actually this problem only shows up when using a “playback-from-selected-bar” command, in order to play from a specific measure.

I use this play mode a lot, to interactively test the best ornaments for arrangements in the composition phase, especially for classic and electric guitar.

I just found another post (Grace note playback - #2 by Rob_Tuley) which explains that Dorico treats slashed grace notes (“acciaccatura”) as PRE-BEAT execution notes. This (I believe) causes the first slashed grace note on a selected bar to belong to the previous bar. The post suggests the workaround of changing the slashed note to unslashed (making the acciaccatura an “appoggiatura”). This worked for me (thanks Rob_Tuley!), with the caveat that the final notation score should be edited before printing, because it may not be consistent with the intended musical execution.
Since my issue is more similar to the one mentioned in the above post, I will add more comments to that post in the next days.

I’m struggling with this. I’ve set values of 5.0 seconds between flows and a pre-roll value of 0.5 seconds. The grace notes sound if play continues after after the previous flow ends, but they don’t sound if play back starts with the grace notes.

Yes, I’m afraid that’s correct. Dorico’s not clever enough to wind back the playhead when you select the rhythmic position at the start of the second flow so that the grace notes are included. You can use Ctrl+F7 (Windows) or Command-F7 (macOS) to nudge the playhead back a few frames and then start playback from there.

Thanks Daniel. Command-F7 works perfectly and Dorico seems to remember that as the start position if I click on rewind to beginning of Flow.