Dorico crashes shortly after XML-import


in Logic Pro X I created an XML-file containing a piano staff with just one quarter note in the upper and lower staff:
(XML file attached)

Importing this file in Dorico, only the upper piano staff is displayed (containg both notes), although the instrument seems to be set to “grand piano”.

In setup-mode, “grand piano” is set, but when I open the change-instrument-dialogue and type the letters PI into the search-field Dorico crashes.
I’ve heard already that Logic doesn’t always create error-free XML-files but I think it is interesting that Dorico does not crash when opening the file but later on.
One (1.55 KB)

I’ve solved the problem by myself.

In the XML-file Logic messes up the attributes-section.

There are two things missing:

the staves-attribute (2 staves)
and the definition of the first clef (treble-clef)

after inserting:



before the first clef definition in the XML, everything looks as expected and Dorico does not crash anymore :slight_smile:

Maybe that ist helpful for someone else :slight_smile:

I will pass this on to the Logic team at Apple in case it’s something they’re able to address in future.

Dorico should not actually import this MusicXML file at all: it is invalid, and Dorico knows it’s invalid, but for some reason it fails to report that validation error to you and abort the import process. We’ll take a look at this in due course to try to make sure it does the right thing in future.

Exactly the same issue - the XML imports but piano though correctly labelled in logic comes up on treble stave only. The moment I try to add a player (piano) it crashes. I also tried setting up a new project including a piano player and importing into that using existing players but it still crashed.

Daniel is there a work around?

Many thanks.

Have you tried editing the musicxml file in a text editor, as AndreasB suggested?

thanks for that - yes it sort of worked, though no sign of the violin part, will play that in manually.

why can’t those lazy guys at logic fix this!? problem has been around for long enough and caused massive inconvenience.