Dorico error connecting audio engine

Good morning,

Having troubles specifically with “Dorico prelude” by Akinola as I can’t play it back (beware I’m using noteperformer 4 in trial mode, and using noteperformer is crucial to me as I’m studying it and trying to see if it’s worth buying). I haven’t tried playing it back with Dorico stock soundset. I haven’t had this problem recently when I tried, it started this morning. Using software licensing with Dorico 4 Elements. Can’t attach diagnostics unfortunately because it’s 274mb heavy…

What exactly happens? What do you do to make it happen? What version of Dorico, and what OS?

If Dorico isn’t starting because it can’t connect to the audio engine, then it means that Dorico crashed, and the VST Audio Engine process from the previous session is still running. Quit that (on MacOS, use Activity Monitor; I’m not sure on Windows). Then Dorico should start.

I launch Dorico and open the project straight away succesfully, wait for the whole thing to load and get the playback commands (play pause rewind) to “color” themselves in order to play the music. When I do, the green timeline bar stays on the first note of the first measure all the time, not moving at all, nothing else happens, if I try to click around randomly the program crashes, if I wait and click pause and play again then the red warning sign in the lower right part of the program lights up and says the above error (error connecting to audio engine). Yes I’m aware of the VSTAudioEngine bug and it’s not this case this time as I’ve thoroughly checked the task manager in the meantime, the process is never running when this occurrs.
OS: Windows 11 22H2
Dorico version: 4.3.31 Elements up-to-date with every sound content available installed.

NOTE: I just realized everything Dorico-related is installed on an hard disk of mine which I’m aware is lightly faulty (bad sectors). Might move everything now elsewhere and update you if the whole thing fixes itself that way

This sounds as if another program is running that has claimed exclusive control of your sound card.

It only happens with Dorico prelude though… by the way: uninstalling and reinstalling on another drive (SSD) doesn’t fix it.

Could you upload the diagnostics to some file sharing site like Dropbox or similar service? That would be great. Otherwise I could also provide some upload space, but not now, I’m on my smart phone.

I’ve uploaded it on dropbox, the diagnostic goes back to yesterday 3:51 pm.

[https://www.dropbox.com/scl/fi/tgxy3grr9m4p21y461xqb/Dorico-Diagnostics.zip?rlkey=gv57tryus9y2bqmv26vmgnkis&dl=0]

Don’t know how to paste the link normally, the forum doesn’t allow me to do that

One can use the Link button (or should be able to paste the link into the message box.)

linkButton

Hi @Andrea0 ,
thanks for the data, contained are quite a few crash files of the audio engine.
It’s always crashing at the same location but it is inside a Microsoft library. I’ve seen this kind of crash before and still have no clue at all what is going on there.
In the meantime, let’s try something different.

You say it is only a problem with the Akinola piece, but all others do play back , right?
I’ve attached a new, stripped down version of that project where all the audio engine data is missing. Does that one load fine with you?Stripped - Dorico Prelude.dorico (698.6 KB)

I swear I don’t have that! It’s weird…

Yes, only with that… and unfortunately not even the stripped down one works :frowning: it’s curious because it used to work a few days ago and now it doesn’t all of a sudden, if I click on the warning sign, it opens the peripherals settings. I use Focusrite USB ASIO with a Focusrite Solo 2nd gen 44.1khz

Is this affecting you?

It’s not really a problem itself, I’m afraid it might be in the future, but for now it seems to be an isolate case, if you want we can close this and if I stumble again on such an issue in the future I’ll open a new thread for it

@Andrea0 , yes, would be good if we can drop this case for now, because it’s a bit like hunting ghosts.
But definitely come back if you encounter again a problem with the playback.
Thanks

Yes I think that too, thank you all! Have a good day

Hi Ulf, I have the same problem ( [error connecting audio engine] and I’m on Mac osx Big Sur with Dorico 5 Elements just installed and never managed to open yet. How can I send you the diagnostic? I’m not allowed to put links here…
Thanks in advance
Marco

Welcome to the forum @Marco_Meloni .

Please send to u dot stoermer at steinberg dot de
Thanks

Marco,

Welcome.

In case you have not seen this, it explains how to gain posting privileges.

1 Like