Dorico for iPad issues and questions

Some issues and questions for the iPad version 1.2.2.1022 (free version). I’m using an iPad mini 6 with iPadOS 15. I’m assuming these are issues with the newest apple hardware and not issues with using an iPad mini vs. a bigger iPad.

Issues:

  1. Secondary drop down boxes hang Dorico (e.g., layout options such as size, rastral size, etc., properties such as string property on tab staff). What happens is the drop down box turns black as it should but no selection list appears. Need to exit program and click elsewhere and then relaunch to get back to a responsive app.

In contrast, Primary drop downs work fine (e.g., switching modes or switching layouts from the main UI)

Some other drop downs that exhibit this behavior:
Bars>Insert Bars>Start of Flow,
Time Signatures>Create Time Signature>Regular,
Preferences>General>all drop downs

  1. Voice selector drop down in the key editor has a similar problem in some files but not all files.

  2. Guitar tuning dialog is not reachable. The secondary dialog does not open. Looks like it tries and then hangs before it gets there. I have to completely force quit Dorico to get a responsive app back.

Can’t delete a player holding two instruments because the secondary dialog is not reachable.

  1. Preferences page colors and background colors dialog is unresponsive

Questions:

  1. How does one assign dynamics to a specific voice?

  2. How does one open the expression map dialog, endpoint setup, and the playback templates dialog?

  3. How does one enable independent playback of voices?

  4. Is there a way to bring up the iPad typing keyboard for shortcuts (e.g., M and N shortcuts to move string)?

1 Like

Welcome to the forum, @dlb, and thanks for your questions about Dorico for iPad.

I do see this myself from time to time too, in dialogs. What you should find is that the second time you tap the menu, it appears reliably. Tap the menu once, and it goes black to suggest that the drop-down has appeared, then tap away elsewhere in the dialog. Tap the menu a second time, and this time the drop-down appears. This is a bug, obviously, but as yet we’ve not been able to fix it.

I’m not entirely sure what the issue here might be. To change the tuning of a guitar, you should be able to expand the card for the player holding the guitar instrument in Setup mode, then see the green instrument label for the guitar itself appear below, then tap the at the right-hand side of the instrument label to open the context menu, and choose Edit Strings and Tuning from that menu. The dialog itself should then open just fine. Whereabouts in this process is it failing for you?

This isn’t possible in the iPad version at the moment: on the desktop version it requires the use of the key combination Alt+Return when closing the dynamics popover, but this doesn’t work on the iPad (which means that a few other “local” creation tasks, like adding a time or key signature to a single staff only, are also not currently possible on the iPad. We’re thinking about the best approach to enable this, and plan to support it in a future update.

None of these dialogs are included in the iPad version at the present time. If the documentation says that they are, please let me know where you’ve seen these references so we can check them: it’s possible that because the iPad documentation is derived from the desktop documentation, we may not have caught every reference to those dialogs.

This is also not currently possible in the iPad version, but is something that we anticipate enabling in a future update.

No, I’m afraid not. To make efficient use of key commands on the iPad you really do need an external keyboard of some kind.

Thanks for responding. With regard to the drop downs that I mentioned, I can’t get these to work no matter what I do. I saw the other thread on this issue. I tried tapping elsewhere and then again on the drop down and no matter where I tap elsewhere (in the dialog or outside the program) this just doesn’t work. I’ve tried this many many times and nothing works.

On the tuning issue… I am unable to expand the card for the instrument (the one with the ellipsis). And this acts differently than the drop down issue. It just hangs the app and I need to force quit.

Hopefully you’ll figure these bugs out soon. I’d be interested to know if anyone else has this specific iPad and can duplicate this problem. Seems less of an issue on older iPads from what I am reading.

Re: the keyboard shortcuts, I could live with the string property for this if I could get the drop down to work. My goal in using the iPad version is to avoid any other items like external keyboard or midi devices (i.e., be as portable as possible). If I need those other items to use the program, I’ll just use the laptop instead because it just became more portable than an iPad mini.

Page 520 of the Dorico for iPad manual says this:
" Tip
You can edit expression maps in the Expression Maps dialog."

Thanks for clarifying what is implemented and what is not on this version.

Feature request for iPad version… Please add a way to call up the on screen text keyboard to assign and use shortcuts. And if you do this, please provide a keyboard that has the option, control and command buttons.

Here’s a GIF of a screen recording made from my iPad (which is an iPad Air 4th generation, so more or less the same hardware as the new iPad Mini) showing opening the Layout Options dialog, tapping on a blank part of the dialog to dismiss the keyboard controls (I have a hardware keyboard attached), then tapping on the Rastral size menu: the first tap it goes blank but no menu appears. I tap in the same place to “close” it again, then tap a third time, and now the menu opens.

ipad-menus

Expanding the player card in Setup mode really shouldn’t cause Dorico to hang: there’s nothing being opened or closed at this point, just the card itself being redrawn.

Are you able to connect your iPad to your Mac via a USB cable and make a screen recording using QuickTime Player in the same manner as I’ve done in my previous reply?

I’ll see if I can create a video for the instrument card issue.

Does it still work for you if you detach that keyboard?

Yes, absolutely.

OK, I tried to make a gif file, but it’s too large to upload. But there is nothing to see there, it just is not responsive to taps in the instrument card. And once I tap it the first time Dorico freezes until I force quit the program. No amount of tapping outside the player card box inside or outside the dialog does anything to make the program responsive again.

I wonder whether the problem might be that on the new iPad Mini, the tap target for expanding the card is too small for that device? If you have two players or more players in your project, can you select another player by tapping anywhere on the card belonging to the other player?

By the way, your iPad Air has an A14 chip, the mini 6 has an A15 chip. So it is somewhat different. Maybe there is an incompatibility.

I was thinking it was the tap targets also, because larger dropdown do work. I have an Apple Pencil so I tried tapping with that so unless the targets are really really small, that ought to work if it’s the tap target size. The mini also more dense resolution than the larger iPads, so this does lend some credibility to that theory.

It’s exceedingly unlikely that the change of CPU/SoC in the iPad Mini would result in any kind of software incompatibility. No previous generation of A-series SoC has introduced such incompatibilities, and Apple have provided no advisories to developers warning them that they need to be aware of it. So I consider that essentially a non-issue.

Are you able to expand the cards in the Layouts panel on the right-hand side in Setup mode? Those tap targets are precisely the same size as the ones in the Players panel on the left.

Yes. And on the left side, I can expand the Guitar to see the player card, but then not the instrument card that shows an ellipsis on the right side of the card. This card looks different than in the desktop version which shows an addition drop down selection list. I don’t know what is behind the ellipsis since it won’t expand.

Is the tap target separate from the control? If so, is it possible that it is offset somehow (maybe due to auto-layout not being consistent between the control and the tap target)?

[Edited…]

Another difference on the desktop, the selection and selection list appears on mouse down. On the iPad, for the controls that work, the control shows it is selected on mouse down, but the selection list doesn’t appear until mouse up. Maybe the tap target is somehow not the same on mouse up as mouse down?

Something else I just noticed. In setup mode I select the guitar drop down, this exposes the instrument card which shows an ellipsis on the right and the instrument name on the left. If I tap just to the right of the word Guitar (which is where the drop down > character is on the desktop version), then the instrument card disappears, but no list appears. But this is different than if I try to tap anywhere else inside that control.

And yes, I’ve tried tapping outside the control and then in that same place to see if the list appears. It doesn’t.

Just to clarify in this thread, I should have been referring to the instrument card not the player card.

I’ve edited all of my above posts for accuracy.

Hi @dlb - the area of Player cards / instrument labels is a bit different on iPad than in the latest desktop version. If you check the iPad manual here, you’ll see the updated and differentiated screenshots.

Instruments don’t have “cards” in the same way Players do - as each instrument only represents one instrument, whereas a single player can hold multiple instruments. The … clickable icon in instrument labels is now always shown, whereas on desktop the > used to be dynamic, ie only appearing where the mouse pointer was hovering. On the iPad, you have to tap/click the … icon to bring up options for that instrument.

Otherwise, the functionality is the same - the > on desktop has always brought up a menu, not expanded the instrument label.

Thank you for sharing this - I shall get this fixed up asap.

Lillie, thanks for the clarification on the terminology. Nevertheless, I am unable to bring up the options for the instrument by clicking the instrument label menu … The app hangs when I do this and I have to force quit to get the app to be responsive again.

Also as I mentioned earlier when I click the region just to the right of the instrument name (where the instrument menu arrow would be on the desktop version), the instrument label disappears (the player card remains the same size as if it is trying to display the instrument label). So there is something amiss in the instrument label control. I suspect there is a tap target left over from the conversion of Dorico to iPad.

I don’t think there’s anything fundamentally wrong with the tap target for the menu that is opened from the instrument label’s button, but we may have to get our hands on one of the new iPad Mini devices to try this out for ourselves. I can’t make any promises as to when that might be (we sadly can’t just magic up £500 devices at the drop of a hat) but I will ask whether we can get hold of one. Sorry for the inconvenience in the meantime.

OK. Thanks for looking into it.