Dorico freezes, then won't start up until after reboot

Hi Guys,
Today I bought Dorico 4 Pro, after having tried out Dorico 4 Elements trial.
Now, I have a huge problem getting the system to run.
It works for a short while, until I assign a playback template to a score. Then the ‘play’ button never gets to green status. Whatever I try, it never changes to green. After a while the entire program stops responding and causing an eternal hourglass. The only way out then is to kill the process with the Windows Task Manager (I’m on windows 11).
When I then restart Dorico 4, it gets to a point where it wants to start the audio engine (waiting
for audio engine initialization), and then halts. It never gets beyond that point . The only way I get it up and running again is a total computer reboot (killing the Dorico process does not help in this).
And no, I do not have euconadapter.dll or a groove agent se folder in a certain place (found that in another thread).
I have included my Diagnostics Report, exported immediately after restarting Dorico after the computer reboot.
Can anyone see what is going on here ?
Thanks for any assistance :slight_smile:

Dorico (2.9 MB)

It sounds to me like the audio engine is crashing or freezing, which would certainly prevent Dorico from restarting properly, because the audio engine is a separate process, and if Dorico can’t communicate with it, it cannot run.

I’ll look at your diagnostics, but in the meantime, I suggest you try completely restarting your computer so that you can be sure all hanging, frozen or zombie processes have exited, and then see if Dorico runs any more smoothly.

Right, I see that of course you rebooted your computer in order to provide the diagnostics. Interestingly they don’t contain any actual crash logs, but they do contain logs produced by the audio engine when it hangs or freezes. I’m not sure how to “read” them but I will try to find out. (@Ulf is really the expect in this area.)

To avoid having to reboot your computer, I suggest you install Process Explorer, which is a kind of advanced version of Windows’s built-in Task Manager. In Process Explorer you can see the individual processes on your computer, so you can see the separate VSTAudioEngine.exe process and kill that if necessary, which should then allow Dorico to restart.

I have rebooted my computer several times tonight. It keeps happening.
I have a feeling it has something to do with de BBCSO Core playback template I downloaded from spitfire, but I could be totally wrong :frowning:
I can also be something with my audio interface (Steinberg UR22C), but downloading and installing the latest driver had no effect :frowning:
I would appreciate a bit of help :slight_smile:

Ah - I have Process Explorer on my system. It’s the one from SysInternals isn’t it.
I’ll keep a watch out for that process… I didn’t know which process to look for. Now I do :slight_smile:

As it seems now, it doesn’t always happen.
I just loaded a project, changed playback template to BBCSO + HSSE + HSO ( Pro)
I added de HSSE and the HSO on ‘auto’ for missing instruments from BBCSO Core.

It played back ok, and as I wanted to try out another .dorico file, I opted for ‘File → Close project’ to free up some memory (I only got 64Gb), and then the entire user interface disappeared. So I can not open another project :frowning:
The process for Dorico4 is still running, but no user interface.

It’s getting weirder and weirder :sleepy:

Killed the process, and now waiting again:
killed the VSTAudioEngine and got another failure:

Have you installed the new HALion Sonic 7 plug-in that was released a couple of days ago? If you have run Steinberg Download Assistant in the past several days then you will have received a new MediaBay update, even if you’ve not got the new HALion Sonic 7 plug-in. I’m really not an expert at reading these logs, and the fact that the audio engine freezes is also itself not necessarily an indication that things are broken, since freezes are not necessarily unrecoverable. However, it does appear that HALion Sonic and MediaBay are shown in each of the freezes, so I wonder whether it could be somehow related to scanning the content or similar.

The messages you’re seeing on Dorico’s splash screen aren’t indicative of specific problems other than that the audio engine isn’t being initialised as Dorico expects.

1 Like

I did not reinstall HALion recently no. I did uninstall Dorico 4 a few times to see if it would unstick me … but didn’t think about Halion…
Will do that next. Just reinstall through the Steinberg Download Assistant I take it ?

reinstalling VST Sounds keeps telling me there are updates… so it seems do nothing…

There’s no need to install the new HALion Sonic 7 plug-in, so I suggest you hold off on doing that, just in case it makes things worse rather than better.

Hi @MeesterP , from the logs I can see that you have both, HALion Sonic SE 3.5 and HALion Sonic 7 installed, and the freeze dumps show that the audio engine gets stuck loading HALion Sonic 7 while connecting to the new MediaService.
I think the best solution for now to get your system stable again is to uninstall HALion Sonic 7 again. Then Dorico will revert to using HALion Sonic SE 3.5 and that should run without trouble.
At the same time, I’ll create a new entry in our bug database about it so our experts can hunt down what is going on there.

Edit: But before uninstalling HALion Sonic 7, could you please bring Dorico into that fail state again? Then, while everything is stuck, please open ProcessExplorer and look for the VSTAudioEngine process, do a right click on and choose from the pop-up menu “Create mini dump”. Follow the instructions and then post the corresponding dump file after zipping it up. The same please do for a process called MediaService that you should find close to the VSTAudioEngine process. This dump of MediaService is most likely more important to us than the audio engine dump. Once you’ve uninstalled HALion Sonic 7 also MediaService will be gone, therefore it is important to do this test before uninstalling HALion Sonic 7. Thanks for your effort.

1 Like

Hi @Ulf ! I can confirm that I also have freezes, but in Cubase, after installing HS7, and all they go to new MediaBay

Hi Ulf,

Thanks for joining in on this topic :slight_smile:

A new day and a fresh start. It proved to be pretty hard to get Dorico in the same state as yesterday, which is weird, because I didn’t uninstall or reinstall anything in the mean time.

I changed Playback templates a lot, and today Dorico didn’t feel like freezing on me, and I have no clue what is different between now and yesterday.

However, I managed a freeze by opening a project, playing it, opening another project (so, 2 instances of Dorico at the same time) and then tried to close the first project. The entire screen went blank (white) showing only the title bar, and a dialog box popped up with somehting like ‘closing’ in it, and ‘not repsonding’… I let that simmer some time, at which point Windows intervened and show the popup with the question if I wanted to close the program (kill it) or wanted to wait a while. I chose, wait, but after a while the same popup came, and I opted for ‘Close the program’. When I tried to start Dorico Pro 4 again, it got stuck at waiting for the AudioEngine.
At this point I created minidumps for Dorico4 and VSTAudioEngine5. There was no process called MediaService) which I can not upload here. Even zipped larger then the 4Mb upload limit. The zipped file is 8.616 Kb. Tell me where I can e-mail the dumps to :slight_smile:


I tried again. Switched my default playback template to HSSE, Opened another project, played it, switched to BBCSO + HSSE + HSO(Pro) template.
In process explorer I saw a process SteinbergMediaBayServer.exe appear… and disappear gain… then I waited a very very long time to have the play button turn green… but that did not happen… It never came to live (it’s 20 minutes or so now…) and getting the ‘not responding’ in the titlebar

I guess I will have to uninstall HALion 7 to see if that helps any.

1 Like

Hi @MeesterP , please e-mail me at u dot stoermer at steinberg dot de.
Maybe the MediaService crashes with you and consequently the client does not get a response any more and thus hangs. I’m looking forward seeing the new dumps.

I uninstalled HALion Sonic 7
Then loaded a score, found out that HALion SE (2 instances) is now being used in stead of HALion Sonic 7, so that’s good… I thought…
But, only the harp from my score is being mapped to a track. Other tracks remain unmapped…
That doesn’t sound to good :frowning:

Are there any crash dumps from SteinbergMediaBayServer? @Ulf if you get hold if any, please send them over … my first rough guess of what is going on here is a restart timing issue of the MediaBayServer, when H7 or HS7 instances get started, stopped and restarted. There would be a workaround I could provide. I keep warching this thread …

Dorico now claims my sound output (steinberg ur22c) exclusively, and doesn’t even release it after it’s closed down.
Now I’m forced to reboot my PC every time I used Dorico.
This is not funny anymore :frowning:

Hi @Sergey_Berezutskiy , if you like to help analysing what goes wrong at your place, I would like to request further information about your setup. Which version of Cubase are you using HS7 with and in which situation is it freezing? We can further activate logging of MediaBay and/or create a ProcDump of Cubase and SteinbergMediaBayServer. You can pm me, or start a thread in the Instruments/HALion forum (I suggest to focus on discussing the Dorico issue here).

1 Like

Hi @Joerg, if the MediaService crashes, where would the crash dumps get written to?