Dorico is becoming unusably slow the bigger the score gets

Dorico always felt a bit slow and sluggish to me, but it becomes borderline unusable when working in a big orchestral score. In this case it’s a template meant for composition with around 50-60 players. Fewer players make the problem less extreme, but still very bad nonetheless.

I’ve attached some videos to demonstrate, I hope they bring the issue across (bit hard to film with only 2 hands haha). Things like note input, or editing existing notes takes way too long to make this even close to an enjoyable experience.

Is this normal? Any way to speed it up? Because I really can’t work like this. :frowning:

This is on the latest version of version 4 FWIW. Using Windows 10, with just Noteperformer, no additional plugins.

EDIT: I just tried the same project on my 2019 MacBook Pro,and there things are buttery smooth. So definitely something weird going on with my Windows setup but I have no idea what it is.
Dorico Diagnostics.zip (1.1 MB)

1 Like

Some more oddities, not sure if they are related.

In the following video, I’m using the text feature, first without the mixer open, then with the mixer opened. As you can see if the mixer is closed, the text gets added fairly smoothly, but as soon as the mixer is open it takes an eternity for the text to appear. Also notice how the mixer window always opens in such a strange way off the screen, which is also very annoying (the same thing happens with the Steinberg Hub every time I open Dorico).

Are you using multiple monitors? This has caused complication in certain instances in the past.

Yes, 4 monitors in fact (3x 1080p and 1x 4k). I just tried unplugging all except one 1080p monitor, and at least the shifting around of notes seemed to be indeed a bit faster (still horribly slow though).

Big scores are problematic with plugins on Dorico - I’ve seen exactly that kind of lag. Haven’t tried NP with a big score - I’d think it would be fine, but you’re finding not. Only solution I’ve found is to use VE Pro, and it would be trivial to set up NP with that I’d think. I only use VEPro with big scores anymore with Dorico. Even on the same machine running VEPro you get fast performance, but your results might vary.

Otherwise just go old school and turn on the silence mapping and hear it in your head. Would be a good check anyhow, if it’s fast with no playback then you’ve proved the problem.

I am currently working on a large score with 57 staves and using VE Pro to host a rather small orch (Berlin Orch Berklee) with a MacPro2013 8-core, 64G RAM, and a 3840 x 2160 monitor (Dual AMD FirePro D500s) and I am also seeing Dorico 4.3 become very sluggish as I work even on only 4 pages. It seemed to become particularly slow as I added a few plugins.

What I found seems to help is restarting everything (including the computer). After restarting, I was able to navigate the same score and setup much more swiftly. However, it is rather painful to have to reboot the computer just to get this refresh. Also, I wonder how it would be if my score were much longer?

I hope Dorico 5 will address some of these practical issues.

I have had the same issue - Dorico becomes very slow quickly across the board. But I am not using any plugins whatsoever - only MIDI out and Dorico Beep.

I also found that restarting the program acts as some kind of a refresh and everything runs quite a bit faster for a short while. In my opinion, it’s not the plugins but rather something to do with rendering for the screen, but I’ve never been able to pinpoint the exact operation that causes the slowdown.

If you click through and view multiple layouts, Dorico performs the spacing calculations for all of them. Try selecting only one layout, closing Dorico, and re-launching, staying only on that layout. It should help somewhat.

2 Likes

Consider getting Mac M1 Pro I have 0 delay on even biggest score maybe a slight freeze when saving but that is it

NotePerformer won’t load inside VEPro, there’s code in it to only allow itself to be loaded inside Finale, Sibelius or Dorico.

Also, even though technically NotePerformer is a plugin, it’s a VSTI, and shouldn’t affect the speed of editing, unless editing causes notes to be sounded. E.g. adding text shouldn’t have any pathway through NotePerformer.

I personally think this is a result of a rules-based layout (which in theory is fantastic) plus the philosophy of everything must be correct all the time. This means as far as I can tell, you adding a note somewhere on page one, won’t complete until it figured out the flow-on effects on page 10, and 11, etc etc.

I think in the end they will have to go to JIT updating, or background calculation of this, and an asynchronous means of entering things which only gets fully built if you do something like save, or export etc, at which point the time penalty isn’t painful.

But when typing a single character and sucking that delay it’s very painful.

I may be way off on all this, but this is just how it appears to work based on my experience.

1 Like

Thanks everyone!
As mentioned I’m only using Noteperformer, so no need for VEPro. I’ve also tried setting the playback templates to the default and to silence, but that didn’t make any difference.
I’ve also already tried deleting all layout except one, but that too didn’t make any noticeable difference to the performance.

BTW I also want to mention: while this problem gets worse the bigger the score gets, the lag is already quite noticeable with just something simple like the default ‘Solo Piano’ template. It’s workable at that point, but still far from a snappy experience because there is still a few hundred ms of delay between every action I take.

2 Likes

It certainly sounds like a problem specific to your Windows system, @Bockbier. I wouldn’t pretend that Dorico can always execute any arbitrary edit in a score of any size in an instant, because it can’t, but certainly you should not be experiencing the kind of delays you’re describing. Are you already in touch with anybody else at Steinberg about this problem at the moment? I don’t want to double up on efforts if you’re already working with any of my colleagues.

Thanks Daniel!
Not yet in the hopes some users here had similar problems in the past and could point me into the right direction, but I’ll write a mail to support later today. :slight_smile:

No, that’s OK – I’m happy to help you, I just want to make sure you’re not already in touch with my colleagues.

We need to get some more detailed performance information from your computer to see what’s going on.

You can create a more detailed trace using a tool called UIforETW, which will allow us to get a super-detailed look at exactly what’s happening. Please follow the steps here to download and install UIforETW:

Run Dorico 4 and open your project, then start recording the trace in UIforETW, then do something that you find especially slow (e.g. input a note), and then stop the trace and save it. Please zip up the traces and send them over to me, and we’ll look more closely at them.

1 Like

Hmmm, yes to see I just started a blank modern orchestra project from the built in template, and I have NP as my default. It is slow … this is on a optimized for music workstation, 24/48 threads HEDT, 128GB RAM, NVMe and the works, it doesn’t get faster than this single or multiple threaded, and I’ve done all the for windows recommended optimizations per Nuendo’s recommendation.

Playing a quick scale, it’s not quite as slow as your example, but not too far off from that. Playing a quick c-g and back one hand scale it takes about 8 seconds to get in … plink, plink, plink … with my hands off the keyboard I’m watching it laboriously put the notes in there. At the speed at which I work it’s probably just on the edge of annoying, but I could maybe live with it. Navigation is fine.

So yeah if you have a less top drawer machine I could see this becoming unusable. I wonder why Dorico note input processing scales with the project size?

when writing big scores, I go for GM, it will be always faster.
Then when I want to check sounds and balances, only then I switch to NP.
I hope it helps

What do you mean “a background rendering process”?

I just tried creating a Modern Orchestra template with NP and doing similar on my M2 (Pro) Mini, and Dorico seemed much more responsive than your results. There’s still a slight delay between pressing they key and the note appearing, but it plays almost instantly.

Just read this thread. I’m on a fast Windows PC, but I’m not experiencing anywhere near the lag shown in the videos in the original post. Here’s a sample file from the Modern Orchestra template, 5 flows, 100 bars each, NP Playback Template, default fonts (I think):
SpeedTest.dorico (616.4 KB)

Using that file, when I input a simple C-G-C scale with a MIDI keyboard, it responds fairly quickly as in the gif below:
scale

When I look in the application.log file, each note input event was usually under 200ms.

This is on a 5950x system, 128GB RAM, RTX 3080, and NVMe drives. Sample rate 24/48kHz. I am only using a single monitor if that ends up making a difference.

If anyone experiencing unusable slowdowns wants to do the C-G-C scale test with the above file on their system, I’d be curious to see what the application.log reports as the times. I’m happy to test with other settings to see if that causes a slowdown, but Dorico in general is pretty speedy for me, certainly nothing like the videos in the first post. (Perhaps I could have input the scale even faster, but I’ve sorta learned what tempo works without errors, so was inputting on auto-pilot there.)