Dorico keeps switching audio output from headphones to mac speakers

Hello, for some reason dorico keeps switching my audio output from my headphones to my computer speakers. At first it wasn’t too bad but now its happening upwards of 5 times every session I compose which is a little frustrating and disrupting my workflow. Does anyone have any suggestions on how to fix this? I don’t think the problem could be external from dorico as it only happens while I’m using dorico. Thanks for any help!

@WilliamT , I see you’ve tagged two different versions of Dorico in your post. Please share more details:

  • version of Dorico that causes the problem
  • Mac OS version (and last restart)
  • Mac model/processor
  • are you doing anything custom in your Mac Audio/MIDI setup?
  • (any third-party audio I/Os in your system?)

I tagged 2 different versions of Dorico because I just upgraded last night from 3.5 to 5 and I’m still having the issue today.
My mac OS version is Ventura 13.1. I’m not entirely sure if I figured out the last restart correctly but I believe it was june 3rd.
My mac model is a 2020 Macbook Pro and the processor is 2 GHz Quad-Core Intel Core i5
The only custom thing in my MIDI setup for dorico is that I use noteperformer instead of the midi instruments provided with dorico.
As far as other 3rd party instruments go, I used to use East West’s composer cloud (with logic only) and I use some vsts/effects such as kiloheartz, OTT, etc. but again, only with logic.

Thanks for your help!

If I were in your position, I would definitely restart the computer. Nothing to lose (and a chance to stand up and stretch), and strange sound-routing behavior seems (to non-expert me) at least as likely to be system-related.

I’ve been on Sonoma (now 14.5) on my M1 Max Mac Studio for awhile, but I don’t ever remember having the trouble you’re describing. (I have, however had the system suddenly not play system sound effects through the Mac Speakers.)

I’m running Dorico Pro 5 (latest version) and NP 4 (latest version), as I assume you are.

By the Mac’s Audio/MIDI Setup I was referring to the utility app on your Mac, not anything inside Dorico. By third-party audio I/O I meant an external DAC for sending sound to external monitors or headphones.

Hi @WilliamT and welcome back to the Forum.

In macOS (CoreAudio Device Settings dialogue in Dorico) you can try to uncheck Automatically Configure Devices: if this option is checked, the Mac will change the output to Headphones if you insert your headphones (or external mixer) in the jack connector, and will switch to built-in speakers if you disconnect the jack. Maybe unchecking this option, and selecting your desired output, can help with your issue? (I also uncheck the microphone input, as in Dorico is not use for it.)
You find the dialogue in menu Edit → Device Setup-> Device Control Panel…

Another suggestion, (with the option unchecked, and an output chosen) is to use Loopback, a fantastic software to re-route (and selectively mute/unmute) your audio signal from any app to any output (is faster that entering the CoreAudio Device settings)

2 Likes

Hi @WilliamT , is it really that the device switching comes out of the blue? You are working with Dorico and for no apparent reason the switch takes place? If that is the case then I suppose you have some kind of hardware bug.
The next time it happens, please select from Dorico’s menu Help > Create Diagnostic Report and post the corresponding zip file here. Thanks

Thank you for your response and sorry for my late reply! It’s been a long week. That definitely helps as it switches from headphones to no audio output now instead of my computer speakers (meaning it doesn’t start playing things out of my computer speakers at whatever volume they’re at). Unfortunately, it hasn’t completely solved the problem though.

Thank you for the loopback suggestion. I’ll look into that this weekend.

It does come out of the blue. It’ll randomly occur while I’m listening to the playback, inputting notes, etc. I’ll generate the diagnostic report when I use Dorico later tonight or tomorrow if it happens (which I’m sure it will).

1 Like

I have the same problem of Dorico sometimes switching between headphones and speakers when not wanted and I must then go into Edit—> Device Settings and manually change it. I am running the latest versions of Dorico 5 and Mac OS Sonoma 14.5.

@Ulf Here is the diagnostic report. Thank you again for your help
Dorico Diagnostics.zip (637.4 KB)

Hi @WilliamT , thanks for the data.
In the logs I can see quite often following line:
ClientCallback::audioDeviceBaiosChange: deviceWasReset
This happens every now and then and at the en?d of the log 2 occurrences quickly after another.
But who or what did the audio device reset?
I don’t know, I may happen because also another app wants to access the audio device. Do you have other audio apps running in parallel?
Or it could be some hardware issue. Since you use Built-in Audio it can’t be a plug-and-play thing… But maybe there is a hardware issue with it, I can’t rule that out.

We can get some more output from the CA2ASIO component which mediates between AppleCoreAudio and the ASIO world. Please follow the instructions that I gave in this thread. And again, let it run until the switching happens.
Thanks a lot

1 Like

Same thing happening to me. I’ve got a MacBook pro m1, macOS 14.5, dorico 5.1.40.2138. All other audio apps, (system audio settings, iTunes logic pro go through the headphones). This has got to be a bug in dorico, right?

Hi @res ,
it is likely a bug, yes, but one that will be difficult to find and fix. In order to do so, please help us. In my previous posting in this thread is a link to a description of how to get more debug output. Please also try to follow those instructions and provide me the data.
Additionally, when you go to Edit > Device Setup and click in there the Device Control Panel button, a little window appears. There is an option for Automatically configure devices. If you toggle that option, does Dorico behave differently then?

Hi Ulf,

It seems to be working now(by turning off automatically…). I’ll let you know if it happens again. Thanks!

1 Like