Dorico kills computer sound for other programs?

Hi,

I’m observing that with Dorico open and ready to playback thru my PC speakers (the same ones used for web browsing sound and other casual sounds, as opposed to my more serious audio connections) that all other uses of those PC speakers no longer work (are silent).

Once I close Dorico, all goes back to normal.

Obviously it is possible for programs to share the PC speakers. Indeed all my other programs do!

So far as I have seen, only Dorico seems to present in this way.

Is this a mis-configuration of Dorico on my part? Is there something I need to do to change to fix this?

OTOH, if this is indeed bad behavior by Dorico, I’d like to comment that it’s really a problem and is worthy of a prioritized fix IMO.

See Here
https://helpcenter.steinberg.de/hc/en-us/articles/115001124024-Windows-Dorico-No-sound-in-other-applications

In the new version, this won’t be an option anymore.
Edit: See here https://www.steinberg.net/forums/viewtopic.php?f=246&t=187083&p=989431&hilit=Option#p989431

The article you mention is correct, but the option mentioned in that article will continue to stay.
You are talking about a different option in the Dorico preferences. That’s different.

Thanks 6620, that information is on target!

However, this instruction:

Solution

Please go to the Generic Lower-Latency ASIO Driver settings in Dorico via Edit > Device Setup > Device Control panel and turn off the checkbox labelled “Allow ASIO host application to take exclusive control of selected port configuration” which allows both applications to play audio at the same time.

did not work for me at all. Turning off that checkbox turned Dorico’s sound output into hash.

What seems to work for me is to switch drivers to this:

I’m not even sure where the Direct X driver originates, but I have it here and at least preliminarily it does allow Dorico to playback OK while not shutting down my other PC audio.

Thanks for your comments also Ulf!
Dorico - ASIO Direct X Driver.jpg

If you are happy with that driver, well, go for it. But it should also work with the Generic Low Latency Driver. If the ports dissapear when you switch off that ‘Allow exclusive’ option, then you need to change something on Windows side. You want to know what?

Hi Ulf.

The situation here wrt. Generic Low Latency Driver is not that I’m seeing ports disappear, it’s that the sound quality of Dorico playback disintegrates (no longer sounds like music at all) when I uncheck the “takeover” box.

As it happens, the ASIO Direct X Full Duplex Driver does not manifest that same problem (so far anyway).

If you have technical insight as why I might be observing this difference (or even where the ASIO Direct X Full Duplex Driver might have originated), I’d be happy to understand it better.

Seems weak, I know, not to be aware of where a driver originated, but I do have quite a bit of music software on this computer these days!

In this case, the “sound card” is not really a card, but just what’s built in to the computer’s ASUS P9 X79 LE mobo.

I think the Direct X driver got installed in the past with Cubase but then dropped at some stage. I don’t know if it is actually a Steinberg driver or 3rd party.
I don’t know what causes the sound to disintegrate, it’s really unusual. Maybe you better try with a bigger buffer size.

And also the free ASIO4All driver is worth trying out.

OK. I do have ASIO4All as well. Thanks!

Since you asked for some background… If ports are disappearing when you use the Generic Low Latency Device then that means that Dorico isn’t able to access the devices because some other application has them open in Exclusive Mode (eg Youtube in the browser).

Exclusive Mode was added to the WASAPI driver model because the old DirectX method had massive latency. If a device is opened in Exclusive Mode that means that no other audio applications can use it, so that (eg) one application is able to set the sample rate and know that other apps won’t be able to change it. Exclusive Mode will also allow the controlling application to have lower latency. I think the default setting for the windows driver is to enable exclusive mode, which leads to this problem with Dorico + Youtube. There are two settings that you usually need to change if you have this problem - one is the exclusive mode in the ASIO Generic Low Latency Device (see the video below from about 9:00) and the other is in the system audio device settings (see from about 11:30 in the video, and in particular the bit around 14:13): https://www.youtube.com/watch?v=5BcPJd92zqU&t=547s

The ASIO Generic Low Latency Device, ASIO DirectX and ASIO4All are all adaptors that simulate an ASIO soundcard, but actually connect with soundcards via WDM (windows driver model) or DirectX. You will almost always get better results with a proper ASIO-compatible soundcard - even a cheap USB one should be better for music than the motherboard soundcards. If you want to do real-time MIDI recording then they’re virtually essential.

Thanks Paul!