Dorico loses sound when switching from bluetooth back to built-in playback, only comes back with computer restart

Dorico 3
MacBook Pro 2015
MacOS 10.14.6

When I change my working built-in playback device to bluetooth, it will work through the bluetooth. When I then disconnect the bluetooth and switch to built-in, I have no sound. VSTs show signal as if it is playing back, but no sound.

Quitting and restarting Dorico does not fix this, the only fix is restarting the computer. I can reproduce this every time.

Anyone have any ideas (other than “don’t use Bluetooth”)?



This may have to do with something regarding the needing use an aggregate device mentioned in some other threads. Adding the device brought back the sound without the need for a restart


I have done absolutely nothing and now the volume is only coming in the left earphone. I am so confused.

Could you please open a simple project, switch to BT phones, wait a moment, then switch back to built-in audio.
After that do Help > Create Diagnostics Report. That creates a zip file on your desktop. Please attach here.

In addition to Ulf’s advice, which will allow him to see specifically what’s going on, you may certainly find that defining an aggregate device that includes your Mac’s speakers/headphone port and your Bluetooth headphones helps, because then the OS is responsible for routing the audio based on which devices are available, rather than leaving that choice up to Dorico’s CoreAudio2ASIO component.

Thanks for the replies. I’ve attached the diagnostic

My issue right now is consistency. Unfortunately, now the aggregate device is not helping anything.

Every combination of System Audio> Built-in, Bluetooth, Aggregate and Dorico> Built-in, Bluetooth, Aggregate where at least 1 of the settings is aggregate produces no sound in Dorico. The correct Bluetooth playback is the “ATH…(2)”.

For now, I’ve been able to get some consistent playback by doing:

Turn on bluetooth earphones (Mac switches over to bluetooth)
Open Dorico
Change audio set up to Bluetooth

Then, when I’m done with bluetooth:

Change audio set up to built-in
Change playback to built-in
Disconnect bluetooth earphones

Of course, now that I’m trying to reproduce the problem, the sound is switching fine when I disconnect the earphones before changing Dorico’s settings [like a car working when you try to show the mechanic it won’t]. I don’t know if simply having the aggregate as an option does anything, because it’s not selected in any of this.

[With regards to the “playing in one speaker” that turns out to be one file, so copying it and pasting everything to a new file fixed it. I’m not exactly sure what I did, but that’s another story.]

Anyway, thanks again for responding and bearing with my frustrations.
Dorico (406 KB)

I’m a bit busy because there are so many issue I have to deal with right now, but I will take a look in due time and come back as soon as possible.

I no longer have the issue (I’m not sure why I did before, and why I don’t now), so I don’t think the diagnostics will show anything, so there’s absolutely no urgency. Thank you for responding.

Thanks for the feedback. Then, if you don’t have that issue anymore and I’m so busy with others, let’s close this thread. But please come back if you run into trouble again.