Dorico - No Sound

I’m new to Dorico (and Steinberg) and a fairly well-rounded notation software user (MuseScore, Sibelius…and Notator) but am stumped with no sound being produced when simply trying to play back a demo.
I’ve watched the youtube video (watch?v=5BcPJd92zqU) that seemed promising, especially at about the four minute mark where there was an obvious difference between Anthony’s hitting the virtual keys on the virtual keyboard producing both sound and visual cues where I could only see the keys “moving” with no reaction on the MIDI light or level meter at the top of the window. I was disappointed when, after his “keep watching” message at about 4:50, he didn’t address what to do in the event that the Halion sounds are present but simply not responding. I’ve run Dorico completely solo after rebooting, but do still have sound when re-testing with other software, including YouTube of course.
I’m running Dorico SE 3.5 (to test it out) on a Windows Surface Pro X with 64 bit ARM processor, if that makes any difference.
I don’t think I’ve wandered off the path laid out by the instructions I’ve read and watched in my hour-long experience so far and would be grateful for any help with getting sound out of the software.

Welcome to our forum jbenoit.

I guess it is an audio driver issue. Which ASIO driver do you use in Dorico?
Please check under Edit > DeviceSetup. I suppose you currently have the Generic Low Latency driver selected. Please also try the generic drivers ASIO4All or FlexASIO, they are both available for free on the web, just have a search.
If you still cannot get sound out, please do Help > Create Diagnostics Report and post the corresponding zip file here. Thanks

Thanks for the reply, Ulf.

Generic Low Latency ASIO Driver is the only option that appeared from the start.

In other (M-Audio, Avid) software I have access to Windows Audio and DirectSound, but only Windows Audio produces any sound that I can tell so far.

I’ve now tried installing ASIO4All. It only produces a spinning circle when I try to select in in Dorico. If I become impatient and click anywhere, even to try to move the Configuration Window, Dorico crashes. Re-starting Dorico show that the Generic Low latency ASIO Driver is still being used and that ASIO4All is still an option, but it still only crashes the software. I unistalled ASIO4All and, after a fairly long hunt, I eventually came across an installation file for FlexASIO, but Windows is not impressed and would rather I not install this “unrecognized application”.
I don’t know the programmer and have no idea if the file I downloaded is safe or not, so I haven’t tried it yet.

I’ve attached the diagnostic zip file produced by Dorico.

Dorico (348 KB)

FlexASIO is a common installation; you should be able to install it without concern.

Thanks for your comforting input, DanKreider.
I tried, but after installing FlexASIO, Dorico did not start. After rebooting the computer, Dorico starts, but FlexASIO does not appear as an option.

Okay, then let’s stick to the Generic Low Latency driver for the moment.

Could you please stop Dorico and then delete the folder C:/Users/josep/AppData/Roaming/Steinberg/Dorico 3.5 AudioEngine ?
When you then relaunch, do you get sound out?

If not, we might better have a remote screen sharing session.

I’ve deleted C:/Users/josep/AppData/Roaming/Steinberg/Dorico 3.5 AudioEngine_64 and relaunched Dorico.

The folder has been recreated, but still no sound–even after rebooting the computer.
I thought at first it could be related to the older version/automatically updated message I was getting when I first launched the program (Ce projet a été créé dans une version antérieure de Dorico. Il sera automatiquement actualisé pour la version actuelle."), but there’s no sound wether loading any of the sample scores or starting a new one.
Could this be a Windows 11 (updated from Windows 10) or ARM64 (Microsoft SQ2 @ 3.15 GHz) compatibility issue?

Hm, difficult to say. I guess it’s an emulation issue, because the Dorico code is compiled for Intel processors and not for ARM, therefore some translation/emulation takes place in order to run it on your Surface. Maybe there is some error on that end.
Could we have a remote screen sharing session? Send me a private message and we can clear the details.

Sure. Is your address somewhere on the Steinberg Website or will you send it to me to my registered address?

I’ve sent you a private message via this forum. Please check

Thanks for taking time to help with the solution to this problem.
I now have sound.
The solution was to disable ASIO’s taking exclusive control of the “selected port” in the Generic Low Latency ASIO Driver settings and then to wait more than a few seconds to see the effect. After a little while other audio devices appeared in the (same) window.
In my French-language version the steps to get there with Dorico (3.5.12 1066 dated Feb 15 2021 exactly) running on a Microsoft Surface Pro X ARM64 with Windows 11, v. 21H2 are:
1 - Clic on Édition → Configuration du périférique (last item, way at the bottom, so that you have to scroll to get to it)
2 - Clic on the Panneau de configuration du périphérique button (on the top right side of the “Configuration du périférique” window)
3 - In the “Pilote ASIO générique à faible Latence - Version - 64” window that will pop up, unselect (remove the “x” in the box next to) “Autoriser application hôte ASIO à prendre le contrôle exclusif de la confiruatio de port sélectionnée”
4 - Wait. Just a bit. Really. (If you close an reopen the window due to impatience or because you expect an instant result, just be sure that the box is still unchecked.)
“2752H (Surface Qualcomm(R) Aqstic™)” will still not work, but “Speakers (Surface Qualcomm(R) Aqstic™)” will. I assume that any other device you have plugged in, such as speakers or headphones, will appear and work as well since my “Haut-parleurs (AdioHub Speaker)” appeared and is working now.
5 - Select either “Speakers (Surface Qualcomm(R) Aqstic™)” or another audio output device and …voilà! (for me, at least).

Now to really try out Dorico…

Merci encore, Ulf!


So…I may have done something silly. Since Dorico 4 has just come out, I figured that I would save some time by installing it in place of Dorico 3.5. After the usual slogging through the installation/access/activation process I’ve ended up, once again, without sound.
My above solution for getting Dorico 3.5 to work isn’t helping. The settings are the same.
I did not uninstall 3.5, since I was under the impression that both could exist side by side after reading one 2016-2017 forum question regarding that fact, but I’m now wondering if that was not quite true. Perhaps, at some point during the installation, the sounds were either deleted or lost. The Steinberg Library Manager is showing sounds installed in my C:\ProgramData\Steinberg\Content\HALion folder.
Any thoughts?

In any case, Dorico 3.5 and 4 can happily exist next to each other. Today I even had them both open at the same time for comparison. Which may actually not be a good idea as I think they share the same audio engine, but nevertheless, it worked.

Thanks, PjotrB, for confirming that uninstalling 3.5 is probably not the issue.

Hi @jbenoit , the install location for the sounds is correct. Please run the Steinberg Library Manager and see if all HALion libraries are correctly registered.
Then start a new project from piano template, enter some notes. Go to Play mode and start the playback. Is the metering flickering in the lower mixer zone, especially on the master fader?
Depending on the outcome of this little test I give further advice.

The library manager shows 8 sound libraries with files sizes and installation dates. Clicking on “Details” shows lists of sounds.
Creating a new piano project, I heard no sound. Playing it back produces no sound nor any flickering whether I select HALion Sonic SE or Dorico Beep sounds.
As an experiment I also tried giving the “hôte ASIO” (on my system) exclusive control (and not) of the port. That had no effect either way.

Reinstallation of HALion 3.5.0 has succeeded in allowing Dorico 4 to find its VST sounds.
Thanks for taking more time with me, Ulf.

Hi Ulf,

I thought I’d share a screen shot of what popped up on my screen as I booted up my Windows Surface Pro:

It’s the same thing that has appeared when installing Dorico 4.
Clicking on “Annuler” grays out the button at first and looks like the window will stick around, but by the time I’ve arrived at this point in my email, it has now disappeared.
If it will be of any use to you, this tablet has:

  • Microsoft SQ2 @ 3.15 GHz 3.15 GHz

  • 16,0 Go (15,5 Go utilisable)

  • Système d’exploitation 64 bits, processeur ARM

  • Prise en charge du stylet et de l’interface tactile avec 10 points de contact
    and is running “Windows 11 Famille”, version 21H2 (22000.434) (upgraded from the original Windows 10 last November, 2021) with “Expérience” Module d’expérience de fonctionnalités Windows 1000.22000.434.0

It seems to have no effect on Dorico 4, but I thought that the information could be a symptom of some other, hopefully benign, problem. At worst, so far, it’s just an annoying slow down.

I’m more annoyed at not being able to load and try out XML files of a project on which I am working due to it having more than two “players” at this time. This is what pops up when I’ve tried this:

Have I downloaded the wrong trial version. or is the trial version simply enough to allow the creation of lead sheets or music with only a few (two?) parts, as I now assume?

I hope the data is of some use and thanks again for you time–twice now.


I’m not quite sure on both of your questions.
For the redistributables, I think they are used by the eLicenser Control Center. If you launch that one, does it work?

And regarding the Dorico trial, well, as far as I know, there is no Dorico Pro trial, yet. It will come soon but I don’t know when. Therefore you are running now as Dorico SE (the free edition) which only allows 2 players.
And see, the software as such is same for all Dorico editions, it’s the license you hold that decides as to which edition to start up to.
I don’t know if this really helps you…

The first part was simply information for you, in case it would be useful for any updates.
In response to your question: The eLicenser Control Center is still working but, of course, requests that all other software be halted before it can complete it’s maintenance–although it looks like only Dorico 4 needs to be stopped, so I assume only Steinberg software is included in the “all other software”.

As for the second, thank you for confirming the two player limit.