Dorico not saving a project

One of my projects seems to be corrupted somehow…
It seems to be stuck in a version, which was last modified 27/11/2022…I just opened it yesterday and noticed that my chord symbols where the wrong font. I didn’t think much of it and just started to clean up the arrangement. I did A LOT of work and when I opened it just now, the chord symbols were again, the wrong font. I checked the rest of the score and yep…like I had done nothing yesterday.
Every other score works. But with this one I tested multiple times to edit a note and save. Then closed and reopened the project, the note was back where it was before…

It’s been a long BB.dorico (1.1 MB)

I was able to make an edit in your project, save it, close it, reopen it, and see the edit preserved.

Do you keep your projects in a cloud-enabled folder like Dropbox, iCloud Drive, Microsoft OneDrive, or similar? If so, try moving the project to a location local to your computer, open the project, edit it, save and reopen it from there. Are the changes preserved?

That’s strange…mine is still not working.
The project is stored on my local hard drive. There is also an error poping up (that I forgot to mention earlier) every time I open Dorico after the 4…11 update, the new-new update. It didn’t appear yesterday. It looks like this:

Kuvatõmmis 2022-12-07 220035

I have to close this error window before I can get into Dorico. But there seems to be no problems with playback or the audio in general. Don’t know what the AudioEngine is refering to then…

Regarding that audio engine error. Have a look at C:\Program Files\Steinberg\Dorico4\VSTAudioEngine\Skins, is there a skin.srf file?
Actually, as you say, you click away that alert and everything works fine, but it should not appear in first place. Did you do something in the application folders, did you delete that file?

Hi again!
Thank you for your replys!
I did a complete reinstall of Dorico and the Skins error no longer appears.
The “not saving” error still ramains and it actually effects most of my projects (if not all). When I wrote my initial post, I only tested one other project and that seemed to be working, so I automatically figured it was only a one project thing…but no. Today I opened up one of my pieces and this also is not saving…I came up with a workaround, where I save the file to the Desktop with “Save as…”, go to the projects folder, delete current one and drag the one from the desktop to the project folder.
The workaround works for now, but my muscle memory is strong. Just now, I did a quick session (approx 2.5h) of composing and then closed the file after just saving…as soon as I had closed Dorico I remembered…it was all gone.
Don’t get me wrong, I don’t want to whine, but that really drove me nuts. I want to find the exact problem and a solution with your help, so that no-one else has to experience what I had to…
Is there a way I can send you some logs or other system information about my installation? Perhaps it’s Windows 11 that’s causing the problem?

All the best

Hi @joonas , what you can do is, choose from Dorico’s menu Help > Create Diagnostics Report. That creates a zip file on your desktop containing log files and other data of interest for us. Please attach that file to a reply here. Thanks

Dorico (1001.0 KB)

Here you go

Hi @joonas , thanks for the data.
Dorico always keeps the logs of the last 10 runs, and I had a look through all of them, but there was no indication whatsoever that any saving or other operation was failing. There was one run where Dorico started up and immediately shut down again, because it could not connect to the license engine, but that was the only failure. Everything else looks totally normal and running fine.
Now, could you please induce the problematic behaviour again and then do another diagnostics report? Even best if you write down the time when you try to save and it does not work. Thanks

1 Like

Hi again!
14:08 - I opened a project, made a change, saved and closed it
14:09 - I opened the project again and the change isn’t there.
14:11 - I made the report

Here are the project I tested and the report:

Dorico (850.9 KB)
Percusssion sketch.dorico (863.8 KB)

I foun something really interesting! I don’t think it’s Doricos fault.
Dragging any one project or even the whole “Dorico Projects” folder to my desktop somehow fixed it.
But when I moved it back to the Documents library, it stopped working again…perhaps I should go to Microsoft forums? :smiley:

That’s a really interesting finding though I still don’t know if Dorico or something else is to blame, but I would like @dspreadbury to take a look again and hear what he might has to say on this.

From the logfiles I see that your documents folder is on drive D: which is either a second partition in your installed drive or an external disk.

The documents folder on drive C: is usually directly connected to OneDrive, so there might be a synchronisation problem, but drive D: should not have that link by default.

Do you have eventually linked drive D: to OneDrive as well? If not, if D: is an external disk, what kind of disk is it? A USB-drive or a network drive?

In case of USB I would try a different port on your computer, to see if that changes something.

Another test could be to open any kind of document (Word, Excel, whatever has some kind of complexity…) on drive D:, that has some similar size as the Dorico project, try to modify it and save it there. Does this show the same effect?

1 Like

Does Save As… behave any differently?

There’s nothing in the application logs that suggests the save operation is failing.

Is the D:\Documents folder managed by a cloud service like OneDrive or Google Drive, or anything like that?

Hi all!
Sorry for the delay…been busy

Save As…forces any aplication to “create a new file” so yeah, that works.
My documents are on a local hard drive D: and I don’t use any cloud servives to sync it.
But as the days have passed, I have detected more bugs in my computer in general. For example notepad not opening and now even jpgs and pngs…so my windows installation is probably corrupt somehow. I’ll repait windows (mabye even reinstall it) and then I’ll let you know, if it had effects on the Dorico problem.