Dorico only playing back one instrument at a time

I’ve been having an intermittent issue in Dorico recently that, while tough to reproduce exactly every time, has been a bit maddening as it stops me from working a number of times during the day: Dorico gets into a state where it is only playing back a single instrument.

In the simplest example, I might have two players:

  1. Treble clef staff sketch - Tied to Keyscape piano
  2. Grand staff sketch - Tried to a different Keyscape piano

Everything will be working well and then suddenly it will only play back the treble cleff instrument, nothing will sound on the grand staff one. This will include just hitting play (in both Write and Play views) as well as clicking on a notehead or typing in a note while writing.

No instruments will be soloed or muted. And if I open the actual instance of the VST (in this ex: Keyscape), I’ll see that the VST thinks something is playing (ie if it has a volume meter, it’ll show it going up and down), but nothing is making it into Dorico (that channel in the mixer shows no activity).

Sometimes this will persist across closing/re-opening a project.

I’ve tried turning the sound engine off and back on and that doesn’t work. Sometimes closing and re-opening Dorico will work. More often than not, what I have to do is either go into the VST and change the instrument entirely or reload the playback template; the latter of which is really disruptive if I had customized the instrument so that the playback template resets it.

I’ve attached one project where it does seem to be persisting across reloads.

Any ideas as to what’s going on?


MTC2 - W5 - Assignment 5 - Secondary Dominant and Line Cliché - Initial idea.dorico (791.2 KB)

I don’t have Keyscape installed so I can’t open up your project and hear how it’s playing back for you, but I substituted Pianoteq for each instance of Keyscape, and it works OK. I’d be interested to know whether you run into the problem if you use another set of virtual instruments?

Just a quick idea, if you assign one instrument to another piano, not Keyscape (HSO piano or whatever) then does the problem occur (just wondering if it is Keyscape itself)…

Well now I’m getting an even weirder issue: I created a new VST slot (BBCSO) and assigned it to the grand staff instrument but even though that says BBCSO, it’s playing the Keyscape instance that I couldn’t get to play previously. And when I click the e icon it loads Keyscape instead :upside_down_face:

The steps I took:

  1. Opened the project file and went into the Play tab
  2. Went to VST and MIDI and added a new instrument (BBCSO)
  3. Went to the track Inspector and routed the grand staff (called Wurlitzer in the screenshot) to BBCSO
  4. Hit play – it played it with the Keyscape Wurlitzer sound that previously wasn’t working.
  5. If I click the e icon to open the BBCSo VST, it opens Keyscape instead (Notice that the keyscape window says 04 which is the slot BBCSO should be in?)

Just looking at your uploaded file, should they both be set to port 1, channel 1? (I haven’t looked into your reply just above …)
EDIT, I see you have another instance, what if you used just one, is it possible? (out of interest, although probably getting away from the problem) :slight_smile:

Maybe then, reset the playback template (or delete all VSTs) and reassign again? I have both playing with Pianoteq without dropouts (so far).

arco: Unfortunately not possible because those two instances of keyscape are different “instruments” (ie in Keyscape you can pick from a bunch of different pianos).

Also I’m not totally sure it’s Keyscape related, I’ve had this happen with my other libraries (like BBCSO) as well.

Re: Resetting the playback template - yea, that is what most commonly fixes the problem, however it’s why I came here to see if I could find a better solution. Having to redo all of the VSTs every couple of hours is pretty disruptive. :smile:

Thanks for trying to help with it!

If you’re finding that there are unexpected VST plug-ins in the rack, that certainly might explain why you’re getting unreliable playback in general. Are you habitually activating and deactivating the project as you work?

It’s in an unexpected spot but as noted above, I did add that VST, based on the suggestions above about how to troubleshoot. I was just noting that after adding, it seems like something is jumbled up about how those VSTs are loaded.

I’m not activating or deactivating the project as I’m working (outside of trying that once it stops working).

I would suggest that to get back to a known good state, you could start again by going back to e.g. the Silence playback template, then manually add your two instances of Keyscape, and manually assign them to your two instruments.