Dorico printing double sided only

I’m on a Mac Pro Big Sur running Dorico 4.2. Using a Brother printer. This seems to be a new issue that just cropped up.
When i try and print single sided by putting duplex printing to “One side only”, it is still printing double sided. I’m having to export the PDF and then print that. Any tips?

’m having the same problem, Brother printer. The only workaround is t export as a PDF and print from a PDF app.

It seems to be a relatively common problem with Brother printers. See Austin’s solution here: Force Brother to print NON-duplex - #10 by austintaylor55

Thanks. I just tried those solutions. I managed to make it now so that Dorico prints single sided, but it will now not do double-sided in Dorico anymore. It looks like with the PDF I can still do either one, so that’s fine I suppose.

FWIW, I have two older Brother HL-5250DN printers on Windows 10 that function as they are supposed to – single or double-sided. :man_shrugging:

It’s not just brother machines. I’m directly connected to a big Samsung industrial copy machine via usb and I have no control over duplexing from within dorico either. It ALWAYS defaults to double sided (long edge), even when I deliberately choose otherwise (thus it doesn’t even print double sided correctly with landscape scores: I have it set to flip on short edges, which it never does).

This is the only program I use that behaves this way, and I can only presume that a.) there is some flaw in the Qt framework that doesn’t correctly translate preferred settings to printers and b.) the copy machine is set to default to duplex, so in light of ‘a.’, I end up with duplex prints whether I want them or not, since dorico isn’t overriding the printer defaults. Again, I do not have this problem with any of my other software, however.

Isn’t this just because Dorico uses its own print engine rather than the [edit: Mac] System print facility? The latter includes the choice for duplexing, which defaults to No. With Dorico you get the printer’s default, which is Yes unless you set it to No.

Would it be difficult for Dorico to offer this choice internally in the same way?

I’m using two different Canon printers and both are printing single- or double-sided correctly.

From the print menu in Dorico I can select all configured printers in my Windows 11 system, including a Fax printer, so Dorico seems to use the print system from Windows.

Yes, this is a Mac issue.

1 Like

You CAN choose duplexing options from within Dorico’s native print dialogue; the problem is it doesn’t always communicate your choices to the printer the way you’d expect. (At least on Mac, it would seem.)

I’m having the same problem (macOS Big Sur 11.6.8) with a OKI C542 laser printer.
Only double-sided printing (solved by exporting as PDF and then printing it.

Anybody any suggestions how to fix this ?
Tried the video , but the the server asks for a user name and password.
Which user name and password is meant. Printer Admin & password or my computer password.

Got the instructions in the video to work. User name & Password from printer are needed.
At the end of the procedure your your computer name and password.

Tested one-sided and duplex printing and both work now.

The CUPS web interface normally asks for your Mac user account name and password.

Most printers don’t have user/password logins. ??? :confused:

1 Like