Dorico Pro 3.1 Changing Time Signature Issue

Hello Dorico crew and colleagues,
I’m having the following issue:
Originally the piece on the screenshot below is in 3/4 but I would like to extend the selected/enclosed in red/ bar 21 (which actually should be 22, but I don’t know why it is duplicated - this is the second issue) by one time making it in 4/4.
Here is the screenshot:
Dorico Pro 3.1 Inserting Time Signature Issue.png
Here are my steps:

  1. In order to prevent any note position changes in bar 22 firs I used to insert time signature of 3/4 into it. (This is logical)
  2. Then I inserted TS of 4/4 in the previous Bar 21.

The problem here is, actually the bar is still in 3/4, doesn’t matter that there is signature of 4/4.
When I made it into 4/4 Dorico didn’t add quarter pause at the end of the bar 21.

How can I fix this issue?

Thank you in advance! :slight_smile:

Best regards,

When you modify a time signature, Dorico does not add beets. You can do that by typing shift-B, 1q, which will add 1 quarter note to that 4/4 bar.

Haha typo, I’m glad Dorico doesn’t do that. I hate beets. :unamused:

Specifically, select the 3/4 time signature (the second time signature in your screenshot) and type Shift-B 1q Enter.
As to the bar number, at some point you may have copied and pasted a time signature that had a Bar Number Change attached. If you don’t remember ever having created a Bar Number Change, is there a possibility that this file originated as imported MusicXML? If so, it may be that the software you exported from works with time signatures in a slightly different way to Dorico. Either way, select the 3/4 time signature, right-click and go Bar Numbers > Bar Number Change. Then set to Continue Primary.

Dan hello,
Thank you for the help! :slight_smile:
Well, about the beats is matter of taste. :wink: I would prefer Dorico to automatically add beats in such case (at the end of bar, if it’s populated with notation). Such feature could be added to the Preferences for those of us who would like to turn it On, or Off.
Imagine when you are working with many apps… It’s not possible to remember the whole key commands for all of them…
I prefer to remember much more important things like Music Theory and instrumentation… :slight_smile:

Best wishes,

Dorico will rebar according to the time signature automatically, but only as far as the next time signature. There are occasions where you might want to bring the following music forward, and other occasions where you might actually want to add a beat somewhere. Dorico does its best to be non-destructive, and to be predictable.

Leo hello,
The problem with the bar number appeared after I copied and cut the notes from bar 21 to 22, because I forgot to record the part which is now in bar 21.

Best regards,

Actually, there is a weird oddity that I’ve not spotted before: If you increase the numerator of a time signature, and that bar is immediately followed by another time signature, an explicit bar number change is added. This looks like a bug to me.

Leo, I also think this is a bug. Yes, the bar numbering could be corrected, so it is not a major issue, but surely should be fixed.
Anyway… the overall development of Dorico goes well. :slight_smile:
We’ll see what the next update will bring to us. :slight_smile:

Greetings :slight_smile:

Following on from the previous comments about time signatures - by default, Dorico indeed doesn’t automatically change the number of beats when you change a time signature. Time signatures last until the next existing time signature or the end of the flow, whichever comes first. This means that you can end up with an incomplete bar at the end of that range unless you have Insert mode activated. (As Leo alluded to, there are cases where people wouldn’t want extra beats added despite changing the time signature, so Insert mode gives you that choice.)

If you activate Insert mode (in Write mode, press I or click the button in the Notes toolbox on the left) before changing/inputting time signatures, Dorico then adds any necessary extra beats to make sure the last bar is full according to the time signature.

Lillie hello,
Thank you very much for the explanation! :slight_smile:

Best regards,
Thurisaz :slight_smile: