Dorico Pro 3.5 Can't Playback Large Templates Hosted Internally

Hello dear Dorico team,
I hope you are all doing well! :slight_smile:
I am now an audio issue when loading the BBCSO Pro Template.dorico . Once the project is fully loaded I’m not able to get sound out of Dorico Pro while using the MIDI keyboard, nor when I’m pressing the Play button/Space Bar. No matter that the Audio Device is properly set, Dorico indicates incoming midi signal and the Spitfire Audio Player indicates that the instrument is actually playing . I’m starting to get this issue with another, customized template, too.
I had tried to change my RME Fireface UFX Buffer Size from 256, to 512 and 1024 samples, but nothing helped.
By the way I’d noticed the same issue with other, lighter, projects when I’m trying to insert plugins e.g. Altiverb in the Mixer.
Probably Dorico needs some improvements in order to work fine with heavy projects hosted internally?! That’s the second major reason for me to ask for Vienna Ensemble Pro 7 Template.
I’m using Dorico on Windows Pro 10 1909, HP Z820 2x 8-Core Xeon E5-2670 @ 2.60GHz, 64GB RAM @ 1333MHz . The BBCSO Pro is installed on 1TB Samsung 970 Evo Plus NVMe m2 SSD attached to PCIe via Angelbird PX1 adapter.

Thank you in advance! :slight_smile:

Best wishes,

How big are your projects? I have seen customer projects with 30 BBCSO instances and they play fine, though it takes quite a bit of time to load such project. Would you be able to share such template with us? Please send to ‘u dot stoermer at steinberg dot de’. Thanks

@Ulf hello,
Thank you very much for the reply! :slight_smile:
Well, for example this project doesn’t work for me:
When it’s fully loaded I can’t get audio out of Dorico, no matter what I’m doing.
On the same computer I have experience with Cubase with much larger templates and they work fine.
The Workstation is more than enough powerful for even triple larger templates (if I add more RAM).

Thank you in advance for the help! :slight_smile:

Best wishes,

Thanks for the data. I actually don’t have BBCSO installed, so need to ask colleagues to check, but we do. One question though: How long does it take on your machine to load that project? 60 instances of BBCSO is a lot and it won’t happen in a snap. Just recently we identified an issue in the audio engine, that if loading a project takes too long, the port mapping goes wrong and the project stays completely mute. Could be the same issue here.

Hi Thurisaz

I don’t have a problem loading that template, but there is also a change in v3.5.12 (available from the Steinberg Download Assistant or Dorico 3.5 Updates and Downloads | Steinberg) that might make a difference - please try that and let me know.


Please hold on and wait, the Windows update installer we provided is broken and won’t install. We’ll give you notice when the problem is solved.

Hello @Ulf and @John_at_Steinberg,
Thank you both for the replies! :slight_smile:
I already installed 3.5.12 but still doesn’t work! :slight_smile:
Please, don’t force me to install the newest eLicenser, it doesn’t work for me… I have problems with VE Pro (no possible to launch it), Cubase and Dorico (both can’t be launched one after another) .
I’m sticking to the older 6.11 version of eLicenser. With it everything works fine here.
Here is a screenshot from the tests:

Take a look at the enclosed in red sections of the screenshot! :slight_smile:

Thank you once again! :slight_smile:
Best wishes,

Does it work if you use outputs 1&2?
I don’t think this is an elicenser issue, Dorico is running fine.
However, for your other issues it might be worth updating the elicenser if you haven’t recently as there have been a number of updates just this month (the latest is now

Hi @Thurisaz, in that case I’ll provide you the Dorico binary via different means. I’ll come back to you soon.

Unfortunately it doesn’t work on any other channels…
I can’t upgrade the eLecenser, because just the new versions doesn’t work here… I have problems with starting VE Pro 7… I can’t start Dorico and Cubase one after another.
Here is the topic about the eLicenser issue I’m having:

Ulf is already aware of it. The problem still persist, even with the latest eLicenser.
I need to wait for what @Ulf is going to provide me…

Thank you guys! :slight_smile:

Best wishes,

@Ulf , you had asked me how long it takes to load the full BBC SO Pro Template.
It takes around 7 minutes until the green dot on the Spitfire Audio Player stops blinking.
… and unloads for even more minutes around 8 - 9.
I don’t know if it’s too long, or not… having in mind the Samsung 970 Evo Plus NVMe m2 SSD where the library is stored?! :slight_smile:

Best regards,

Oh, under that condition you definitely run into that issue I mentioned. I’ll pack you up the new version and send you. A little patience please. Thanks

@Ulf , danke schön! :slight_smile:
I’m patient. I will wait! :slight_smile:
Just I’ve noticed that I didn’t answer this important quest of yours, so I decided to conduct more correct test and give you a feedback. :slight_smile:

Best wishes,

@Thurisaz , please check your private messages on this board.

@Ulf thank you very much! :slight_smile:
I’m now reading the instructions of yours! :slight_smile:
I will inform you as soon as I complete the things.

Thank you once again! :slight_smile:

Best wishes,

Unfortunately the problem still persist… ;( The loading time is now around 8:20 mins (until the green dot on the Spitfire Audio Players stops blinking) and the unloading is around 7:10 mins.
There is no sound out of Dorico while pressing keys on the MIDI Keyboard.
After entering notes and pressing Space, the green cursor doesn’t move. Sticks at the beginning (this was there with the previous version, too)
If you need some more information about my system?! I tried with Kaspersky Internet Security off, but doesn’t work…

Thank you for your hard work and help! :slight_smile:

Best wishes,

Hi Thurisaz, I’m sad to hear that. In order to help you, it would be best if we could have a remote screen sharing session via e.g. Zoom. Do you know that and are willing to do?
Secondly, please do Help > Create Diagnostics Report and send me the corresponding zip file. Thanks,