DORICO PRO 4: MUTE and SOLO are not working

Hello everyone,

Under DORICO 4 PRO I have 3 tracks (this is an example) - - in PLAY WINDOW, each using a KONTAKT instrument, PLAY works fine but when I select MUTE on any of those 3 tracks the track(s) selected is/are NOT muted. When I select SOLO on any of the tracks then EVERYTHING is muted.

Thank you very much.
Lys K

Hi @LyS_K_MuSiC , could you please post the project file or a stripped down version of it with just the mixer/instrument setup and all notes deleted? Thanks

Thank you but how does one attach a file > 4 MB here ? Zipping it didn’t do anything.

You can post a link to the file in a cloud storage service like Dropbox or Google Drive.

Please keep me in the loop if ever someone finds the reason. I had the same behaviour before.

@LyS_K_MuSiC , or send directly to u dot stoermer at steinberg dot de.

Thank you so much. I have emailed you the file.

Hi @LyS_K_MuSiC , thank you for the project file and I can confirm your finding.
The interesting thing is, that in terms of audio setup the project is completely messed up.
The mixer state thinks that only one Kontakt instance is there but in reality there are three and also the channel routing is a mess. All the channels for the Kontakts are missing and therefore the Kontakts get muted if you press solo on any of the other shown channels.
So the bug is not mute/solo here, because that works as expected, but how the project could get into that funny state of wrong audio setup.
We had occasionally similar bug reports, but were never able to reproduce them. Could you please tell us how you worked on the project? Probably you started with HSSE, but when and how did you add the Kontakts?

Well, I am no Sound Engineer :slight_smile: but I did like I always do in Cubase Pro 12 or Ableton Suite. With DORICO PRO 4 I used the already created “Orchestra” Template then I added 3 instruments. In PLAY I saw that you can add your own VST to any instrument. So that is what I did - I mean doesn’t everyone does that ? - I selected Kontakt for each of them and selected Kontakt instead of HSSE for those specific instruments. As I did not have any sound for those instruments (why?!!) I remembered that I had to switch Kontakt to OMNI although in Dorico Properties it gives some specific channels but matching those channel in Kontakt that didn’t work. OMNI in Kontakt worked. Why can’t Dorico Pro 4 be as simple as Cubase Pro 12 ? That is the question :slight_smile: and not being a sound engineer what can’t mute and solo work like in Cubase Pro 12 (which I love) ? Thank you Ulf !!

See, there is obviously a bug (pretty big one) here in Dorico. And we have to somehow find a way to reproduce it, that’s why I’m asking so stupid. But with your description, I will try to do something similar and see if I can get Dorico to the same point. I will do that tomorrow morning.
Any further hint from your side is also highly appreciated.
The toughest part in bug hunting is always to reproduce the bug. Once we have a recipe, fixing the bug is mostly easy thereafter. I’ll be back…

I’d be glad to help in anyway. Again just pull the orchestra template. Add 2 or more instruments. In PLAY load a different VST for those extra instruments. By default the VST from the template will be selected. Select the new VST from the list (in my case Kontakt). Then as you add Kontakt instances you will get "Kontakt 2 / Kontakt 3 etc (you can change the name I noticed to something more relevant). Then you will see that Dorico assigns some “ports” but assigning those ports (I think I had “12” and “14” [the rest was blank]) into Kontakt (I thought I had to do that) = no sound. Go into Kontakt and use “omni” and you get sound. But then no solo nor mute. Again ports and channels are a little bit of mystery to me - I am just a humble composer who truly love Dorico and Cubase. It is just not very practical to solo something using the sliders. No problem in Cubase ! Thank you again Ulf and please do not hesitate to reach for me directly if needed as you have my email.

Remind me why your are adding instances of Kotakt instead of assigning the first instance to all the added instruments and using separate channels to prompt the several instruments?

ABACADACoda2.dorico (1.0 MB)

At the same time, I have to admit the Solo/Mute functions in Play seem to play odd tricks.

It’s my choice. Having several instruments in one instance = more CPU power needed and less RAM needed. Several instances = More RAM needed and less CPU usage.

I also use multiple instances of Kontakt (I find it more convenient for swapping in/out different instruments). And I too am pretty much ignorant of the world of vsts.

The workflow in D4 seems more complicated than D3.5 (not helped by the continued absence of Play mode documentation!). But this is what I do (assuming you create a project with the HSSE+HSO default template) - and it works for me:

  1. When you add new players to a project, they are added to the Halion vst and will be assigned a new channel number.
  2. So, when you add a new vst for your new player, always change the routing to port 1 channel 1. (You should not need to change anything in your vst. Normally the first instrument always listens to channel 1).
  3. Remember, your instrument probably won’t play correctly with the Default expression map. You will have to create and assign your own.

Sorry, but I can’t replicate your trouble with mute/solo.

It shall not matter if you use one instrument per Kontakt instance or multiple, it is supposed to work properly in both ways.
But luckily, I actually can reproduce the problem now as well. That is good news as we now can have a look and fix it.
Many thanks for reporting the issue, @LyS_K_MuSiC

Actually, it turns out to be not a bug, but in the end logical behaviour of Dorico, it is just hard to comprehend. I will try to explain and write it down later in detail, so that you better understand.

@LyS_K_MuSiC , instead of setting Kontakt to Omni-mode, you just have to set Dorico to the right port and channel number. Because for example, if a player was routed before to HSSE port1 and channel 3 and you change over to Kontakt, then it will continue using that port and channel. But Kontakt might not have a sound assigned on that port and channel, that’s why you set Kontakt to Omni and it will receive on any channel, but Dorico does not know about that. So instead you better change the routing in Dorico and send to Kontakt on port1, channel 1. Given that, then also the channel assignment will be correct and also the solo/mute logic works properly.
I’ve also just talked with Daniel about this and he agreed that we are lagging here some proper documentation on what Dorico is doing, resp. assuming when you are using other VSTinstruments than HSSE. So we will make up on that in the future.

Is there some reason muting (say) the Clarinet in Play in the file I attached above does not mute the sound or have I just not understood your explanation here?

I do not use Kontakt often, so I may be missing something.

That’s what I’m saying, it is so complex…
First, I don’t have the same Kontakt version and libraries like you, so loading your project I first need to load other sounds, but I think the audio setup should be the same.
But in my setup it is quite clear. The Clarinet is set to MIDI channel 2 and therefore Dorico assumes that audio for the Clarinet will come from the second output of Kontakt and that is the Clarinet channel in the mixer. But actually the audio for Flute, Clarinet and Bassoon is put out by Kontakt via its first output (the Flute channel in the Dorico mixer). So muting the Clarinet channel does nothing and soloing it would just mute everything else.
Does this make more sense now?

Beats me! And more bizarrely, how can Dorico even allow this state to be created…?

Well, the aim was to make things easier for customers. On one hand we succeeded but on the other it became more complex and difficult to understand. So we have to work on it to better explain the mechanisms behind the whole thing.

2 Likes