Dorico refuses to give me harp diagram

harp diagram
I could not get Dorico to give me harp diagram instead of notes. I have “show harp pedaling” turned on in page layout options. Any clues?

Does this help?

https://steinberg.help/dorico_pro/v3/en/dorico/topics/notation_reference/notation_reference_harp_pedaling/notation_reference_harp_pedaling_partial_allow_disallow_t.html

Procedure

  1. Select the note name harp pedal diagrams for which you want to allow/disallow partial harp pedaling. You can do this in Write mode and Engrave mode.
  2. In the Properties panel, activate Partial pedaling in the Harp Pedals group.
  3. Activate/Deactivate the corresponding checkbox.

I think if the property for partial pedaling is activated for this harp pedal, you can’t then switch to the diagram. Deactivate partial pedaling, and then switch to the diagram and it should change its appearance.

I am sorry. Where is the partial pedaling that you were talking about? I clicked on the Appearance button many times and nothing changed.

First, deactivate “Appearance”. Then, with the harp pedal selected, you should now see the “Partial pedaling” property. Deactivate that, then reactivate “Appearance”.

Sorry, after I deactivated “Appearance”, nothing changed, no “Partial pedaling” property showed up.

Can you share your project here? If you don’t want to share all of it, save a version of it that just contains the bar with the harp pedal diagram and maybe one or two bars either side.

Harp pedaling issue.dorico (577.1 KB)
Here is the file. The first bar has no problem showing the diagram. But the second bar always show note names instead of diagram (even if it is set to show diagram).

Curious, for me I have no trouble getting it to show as a diagram in the 2nd bar - I think the difference is when the property scope is set to “Globally” nothing happens; if you set that to “Locally” it behaves fine. (And yes the difference between me not seeing the “partial pedaling” property until the “Appearance” was unset was because in my project, harp pedals were set to Note Names as the default for the layout.)

The reason it appears with letters in the 2nd bar is your Engraving Options are set to allow partial pedaling (i.e. only displaying the changed notes not all notes) for up to 3 pedal changes.

Mmm… as you said, if set to “Locally” it works fine. But isn’t it supposed to also work “Globally”? Can you verify that it is a bug?

I’ve passed it on to the team.

Thanks Lillie.

I tried disabling the Engraving Options for allowing partial pedaling, but now the opposite has happened, and I cannot change the pedaling to note names (if property change set to “Globally”). So the key issue here I think is that things don’t work properly when set to change “Globally”. Hope it will be fixed so that I don’t have to go the harp part to fix every individual pedaling.

In the meantime, if you set the pedaling how you want it in one layout, you should still be able to propagate properties to copy those settings to other layouts.

Well, I just tried your advice, and it’s still erratic. I clicked on a diagram in the full score, and use “Propagate Properties” to try to copy the setting to the part, but the diagram in the full score now changes to note names. The only way is to go to the part and change the note names appearance to diagram. Something is just wrong within the linkage of the harp pedaling between layouts.

Maybe a dumb question, but what version of Dorico are you running?

Yes you’re right, the issue is still there with propagate properties. Apologies in the meantime.

Dan, my version is 3.5.10.

Couldn’t hurt to update to 3.5.12, though I don’t think that’s related.