Dorico - rhythmically shifting notes super slow compared with Sibelius

Hello,
Using option command left right in both Sibelius and Dorico, you can rhythmically shift notes left and right. This is super slow on Dorico compared with Sibelius, making the quick auditioning of rhythmic possibilities painful in Dorico. I’ve attached a gif to show the comparison. I hope this can get fixed soon.

Thanks,
Nakul

Welcome to the forum, Nakul. From a technical point of view, comparing the speed of an operation in Sibelius and Dorico is pretty meaningless, since the two applications are completely different, take completely different approaches to solving similar problems, and have nothing in common aside from some of the people who worked on both of them being the same, and both of them being applications for working with music notation. However, I understand that from your point of view as a user, you want a new program to be as fast, if not faster, as your old program. Edits in Dorico are more complex than those you make in Sibelius, and Dorico is doing more work than Sibelius is doing whenever you edit the music. You don’t get much additional benefit from Dorico’s smarter internals for simple edits like this, but the good news is that in the aggregate you will save a huge amount of time compared to working with Sibelius. I can’t promise specifically that this particular editing operation will soon get much faster, but we are always looking at the performance characteristics of our software and how to improve its performance.

Don’t forget that if you move your Sibelius example back, it can’t correctly turn that minim/half note back into a minim/half note. Now which software’s faster? :wink:

Hi everyone,
Sorry for the delayed response. I had forgotten I had posted this once I realized that there was a facebook support group as well. Thanks for the response Daniel. And Leo, good point.

I’ve jumped back onto this thread because there is actually more of a caveat to this problem than I thought. It appears that when I first load Dorico, the shifting operation works quite quickly and within a completely reasonable timeframe. However, if the application has been open for a while, the operation can start can start to take over 1 second, 2 seconds, etc. until speeds become painful. In fact, deleting notes takes a long time after keeping the application open for a while too. Is there any solution to this?

I tried looking into a potential solution from this link you commented on (https://www.steinberg.net/forums/viewtopic.php?t=120457&start=25), but I can’t seem to find the menu items that you speak of.

Thanks,
Nakul

If you need specific help finding particular menu items, please specify which menu items you’re looking for, and we can help you locate them.

If you are finding the application slows down after it’s been open for a while, perhaps there’s something leaking memory. Are you using any VST instruments or effects beyond the default HALion Sonic SE/REVerence pairing that Dorico uses by default?

May I make an observation here please.

I have had major problems for many years with programs slowing down and coming up with the dreaded ‘program not responding’ problem. I have Windows 10.

A few weeks ago after having to press CTRL/ALT delete I found that Google Chrome was eating up an incredible amount of resources, which didn’t make much sense to me because I had only had Chrome upon for about 10 minutes with Dorico running.

I decided to change the browser to the latest version of Microsoft Edge, and since I did the problem of ‘program not responding’ has disappeared.

As Daniel suggests you may have some sort of leaking problem. I am certainly not in any way qualified to say that this is so.

Best wishes and I hope you resolve your problem quickly.

Keep healthy and keep creating.

seeya.

Paul.

Chrome has a nasty habit of keeping many threads running in the background to make load faster the next time you open it. There is an option (in the Advanced options, I think) for turning that “feature” off. It is a huge resource hog; best to have it close all those processes when you exit the browser.

Thanks for the responses. I don’t use Chrome (I use Safari), so I’m not sure why I’m experiencing this problem.

Daniel, this is your post that I was referring to. I can’t find the Staves and Systems Page that you had referenced. I’m hoping that this will fix the problem, but this might only be salient to an older version of Dorico.

It’s still there, as far as I can tell.

Thanks Leo. I wasn’t able to find the layout menu in Dorico’s contextual help, but I was able to google the keyboard shortcut. The setting dd not seem to improve the situation unfortunately.

It’s on the Setup menu, in Setup mode, or in the bottom right corner of Setup mode, or just Cmd/Ctrl-Shift-L (from any mode).