Dorico still closes badly and prevents a reopening

Dorico still closes badly and prevents a reopening. This is because the software interface normally disappears when closed, but the executable remains open in the task manager. It must be asked for “end of task” to really close it and allow a reopening. I am in Win 10 up to date, with Dorico pro 3.5 latest version (3.5.12. 1066). But it’s not my main music computer, so I only have a Komplete audio 6 as my interface. Maybe that’s it. On my computer, with an Atlas of Prismsound, everything is fine. But the problem may be elsewhere, I don’t know. I tried to open a ticket for technical support, but nothing works on this side. There is a loop back to the support page, with no possibility to open the ticket.

I’ve had this happen at times as well. I’ve noticed it’s rare if I’m using all Steinberg VST3 plugins, and stick to my audio device(s) native/unbridged ASIO drivers. Actually, I don’t think it’s ever happened to me when I’m not doing crazy stuff, or using third party plugins.

More common in projects that use a lot of white-listed third party VST2 stuff.

Leads me to wonder if the Steinberg engine isn’t hanging around waiting for a plugin to close that for whatever reason isn’t shutting down, or reporting that it’s done and safe for the host to exit. Or, if it’s some kind of hang up with an audio device/driver.

In my case I’m not really surprised though, as I tend to do all kinds of freaky/unconventional things with plugins (bridges with bidule and the like).

I also run an ASIO Link Pro or Jack2 bridge quite often. I can’t help it…addicted to the endless audio routing and networking possibilities such utilities provide.

The good news for me is…it’s stable and performs well despite by intentional introduction of all sorts of ‘potential problems’, so I can live with manually closing a process every now and then.

I understand. Here I use 12 or 15 instances of Vienna Instrument Pro, which only exists in VST 2. Maybe that’s it. But as I said, on my other computer (WIN 10 too), everything is fine.

I forgot to say that I have tried several relocations and that it does not change anything.

Does that audio device in the problem system have native ASIO drivers, or use the Steinberg ASIO bridge?

Might try ASIO4ALL to see if that hangs too?

Native. Ok, I’m trying.

I had heard this intermittent problem might have something to do with the latest eLicenser (with the suggestion that I roll back to the next to last version). I would think that if this had something to do with the audio engine the program would start and fail somewhere around the 60% mark when it tried to access the audio engine, but that may not be the case.

I just decided to put up with it (and become intimately acquainted with the Windows Task Manager) until the new licensing system appears.

It’s true that it’s not that long to do, but it’s curious. For eLicencer, if I move it to my other computer, it doesn’t do that. So, it’s not the eLicencer here. The difference between my 2 systems is the interface (among other things).

Hi @cmbourget, could you please do in Dorico ‘Help > Create Diagnostics Report’ and post the corresponding zip file here? The contained log files might give us a hint what is going on. Thanks

Hello Ulf. Here is.
Dorico (529.8 KB)

Thanks for the data. I see no crashes but only Dorico not starting up properly some times. That indeed could be eLicenser related, but I also asked the guys from London and I’m waiting for an answer.
And I have more questions.: Do you have the Dorico license on the Soft-elicenser or a USB-eLicneser? If it is the latter case, how long in total is your USB-eLicenser in cm? Thanks

USB. Almost 4 centimeters with inner grip. I have another longer one, so it’s the shortest version. But as I said above, it’s fine on my second computer. Another similar PC, but Intel instead of AMD Ryzen.

So you have already the newest type.
Well, yes, that’s very typical in that it is not consistent. On the vast majority of machines no problem, but then with some rare machines massive troubles. That’s one of the reason why we are in the process of abandoning eLicenser technology, but that does not help you at the moment.
Do you maybe have several USB-ports and could try to plug in the USB-eLicenser to a different port? That also sometimes helps

Leaving the Elicencer is an excellent idea, I think shared by all.
I will try to change port and I give news here. Thank you for your communication, Ilf. It is very much appreciated.

Update: 1 The eLicencer was on an additional port in front of the computer. I connected it on a direct port and it seems to be getting better so far.
Update 2 : No, the problem is back… so it wasn’t that.

I have the newer eLicenser too. Is there any chance this could be a Ryzen issue?
(I’d send you a diagnostic, but this time Dorcio started up without a hitch, which is the case most of the time.)

@cmbourget : Excellent, I hope it stays that way.

@Derrek : Actually, we don’t know. And since we abandon eLicenser anyway, we won’t spend any effort anymore on finding out.

Do you know if Vienna (VSL) will also abandon eLicencer?

No, the problem is finally back…

Yes, Vienna Symphonic Library has already announced its intention to move to iLok. (Steinberg will not be moving to iLok.)

I’ll send you a time-limited activation code for Dorico that you can install on your computer’s Soft-eLicenser (disconnect your USB-eLicenser before you use it, and keep it disconnected when running Dorico), and hopefully that will help in the meantime.