Dorico stopped playing sounds. Says Halion not registered

I updated to the latest version of Dorico 5 on my Mac. Now, there are no sounds when inputting notes or playing back. I received an error that no license was found for Halion Sonic. Also, upon launch, Dorico gives me an error message that Groove Agent SE 5 and Iconica Sketch cannot be found. I have attempted to uninstall and reinstall the Steinberg folder, including Dorico, Halion, Groove Agent, and Iconica Sketch, but errors and lack of playback continue.

It sounds like you might have updated from Dorico 4, or an earlier version. Could you first make sure that you have downloaded and installed all the components listed in the Steinberg Download Assistant:

If you are still having problems, could you then run Dorico, do Help > Create Diagnostic Report, and post the diagnostic file here.

Hi Richard,

Here is the diagnostic report.
Dorico (685.2 KB)

Hi @Mark_Minasian ,
you have a license or setup error.
Because: You have all HALion derivates installed, i.e. HALion Sonic SE 3.5, HALion Sonic 7 and HALion 7. In the Dorico preferences (on the Play tab) you set it up to always use the best HALion derivate and that is the full HALion 7, and because you have that installed, the audio engine detects it and also tries to load it. But then comes the error, because you have only a Dorico Pro 5 license. Included in that is only a license for HALion Sonic 7.
So you either need to change the preferences to always use HALion Sonic or you need to get a HALion 7 license.

Hello Ulf,

I went to Dorico Preferences, Play, and tried every combination of Halion Sonic. Nothing. I went to Steinberg’s Halion page, downloaded the latest Halion Sonic player, and installed it. Still nothing.

I think you need to set these two options in Dorico’s Preferences as follows and then click Apply:


That will tell Dorico to use HALion Sonic for new scores instead of HALion. For existing project files that are already using HALion you may need to reapply the playback template to get them to switch over to use HALion Sonic instead. If that still doesn’t work can you start Dorico, create a new project, wait for it to try to load the sounds, and then create a new diagnostics file and upload that here?

As Ulf says, the problem at the moment is that Dorico is trying to use HALion 7 and you don’t have a licence for that. (You might want to uninstall the full version of HALion and just keep HALion Sonic.)

1 Like

Also, it looks from your log files as though you still haven’t installed the Iconica Sketch content or the Groove Agent SE content, so you will need to do that too if you want to use playback templates that use those instruments.

1 Like

The preferences are set to HALion Sonic. Still no sound. I have downloaded Groove Agent and Iconica Sketch multiple times. Dorico doesn’t recognize them.

Could you please attach a new diagnostics file as requested, now that your Preferences are correct?

Also, could you open the Steinberg Library Manager, find Iconica Sketch, and click on “Remove”:

And then try reinstalling it again?

Also, I see from that screenshot of Preferences that you are using the “HALion Sonic Selection” playback template as your default. That’s fine, but there is a known problem that affects some people for the HALion Sonic Selection content specifically. The fix is to follow these steps:

Ok, I installed the Cubase plugin fix. I reinstalled Groove Agent and Iconica. They still do not show up in the library. I shut down and restarted my Mac and restarted Dorico. Still no sound.

Dorico (652.7 KB)

I may be off beam here, but Halion Sonic 7 is not the same as Halion 7.

It looks like you’re opening an existing file (In a Sentimental Mood.dorico) rather than starting a new file. My guess is that the existing file has ended up with a reference to the full version of HALion rather than HALion Sonic, so you will need to re-apply the playback template to get it to start using HALion Sonic instead of HALion. You can do this from the Play > Playback Template dialog. You might want to try starting a new project first, just to double-check whether the sounds work there.

That’s a separate issue from the fact that the Iconica Sketch and Groove Agent content hasn’t been installed, though. I can see that the samples have been successfully downloaded from the screenshot of your Downloads directory, so what has probably happened is that they haven’t been installed from there into the Steinberg Library Manager. Can you try double-clicking on one of those files in the Downloads/Steinberg/OSX/Iconica Sketch directory? That should launch the Steinberg Library Manager and install the files. (Normally the Steinberg Download Assistant handles all of this behind the scenes, but that seems not to have worked for you.)

It worked! Re-applying the Playback Template fixed the problem! Thank you, Richard! I’m up and running.

However, Dorico still doesn’t recognize Groove Agent or Iconica Sketch. I removed and reinstalled both, went into the Steinberg file, and double-clicked on a sound file for each. The library manager opened and seemed to go through the motions of moving the files, but then would give an error message that the manager was not the correct version. It is the latest version of Library Manager. Neither library appears in the Library Manager. Any ideas?

Hi @Mark_Minasian and @Richard_Lanyon , sorry, I need to step in here.
It is not a good idea to install the vstsounds in the download area. I just recently had a customer who did that and ended in quite a mess. First, for some time it worked, but then he decided to clean up disk space and deleted everything in the downloads folder, thus deleting all the contents.
So I propose to do the following:

  • Go to Steinberg Library Manager and for every registered library there click on the Remove button.
  • Then delete the Steinberg folder in your Downloads folder
  • Go to Steinberg Download Assistant and install everything again. Even explicitly use the Install All button at the top of the list.

I know, it is a lot of data and it will take a long time, but I’m sure afterwards everything will be fine.

Apologies Ulf, I had thought that when you double-clicked on the files in the Downloads folder it would then go on to copy them into the correct (normal) location if it could, rather than registering them in place.

In any case - do what Ulf says, he’s the expert!

Hi Ulf,
Library Manager does not work. I deleted it and downloaded a fresh copy. Upon clicking on Remove, I get an error message stating that the privileged helper has the wrong version. I went ahead and deleted the Steinberg file from the Downloads folder. Shall I hunt down the sound files manually?

Hi @Mark_Minasian ,
either you go and delete every *.vstsound file you can find on your computer, or maybe try to follow the advice given here, but do at your own risk. If you are suspicious about that CCleaner, you can maybe set the startup objects yourself. Here is a description of how you do that in general.

Thanks, Ulf! That did it! The Steinberg startup objects were turned off. Once those switches were flipped to ON, the error messages vanished. I was able to delete the old files and reload the entire library. Now Dorico starts up with no error messages and accesses all sounds! Thanks again!

1 Like

@Mark_Minasian, I’m glad to hear that! But just to make sure, when you now click on the Details button in the Library Manager, what path does it say? Default would normally be /Library/Application Support/Steinberg/Contents