Dorico very slow

I upgraded to Mojave because I wanted to use Dorico 3.5. Before I was in El Capitan and Dorico 2.2, working fine.

I can barely work now. Everything is painfully sluggish. Every action takes many seconds waiting with the watch and sometimes even the beach ball appearing.

I have tried everything. Checking the MIDI input in the Play preferences to make sure nothing was interfering, closing all other programs, etc. Activity monitor shows a low use of CPU or RAM, and yet everything is dead slow.

It’s so bad I am considering downgrading back to El Capitan or perhaps High Sierra, and to Dorico 2.

Anybody at Steinberg knows what the problem could be?

Thank you

By the way, I have tried using Dorico 2 with Mojave, but things are the same. It seems that the problem is Mojave with any version fo Dorico, 2 or 3.

Hi Pluton4 !
For what it is worth, I have Mojave, and Dorico has never been as fast as now (3.5) so the issue might be elsewhere… Don’t lose patience, I am confident you will find the cause of it.
Can you attach the diagnostic file here for someone from the team to have a look at it? You create it from the help menu, it’s created on your desktop.

Thank you for your answer, Marc.

This morning it seems it’s freezing less, which puzzles me. I am going to wait until night again (when the sluggishness occurred) and see if it resumes. That will give me more clues. It is definitely something related to the upgrade in the OS, but obviously just in my own system, since you and others are experiencing no problems with a similar configuration.

It’s very easy to say “the problem started when I upgraded, so the upgrade is the cause.” But that’s not always a correct assumption. (Similarly, some problems get fixed by updating, but the update itself wasn’t actually responsible.)

Sometimes, an OS upgrade can reveal existing problems, or make them more pronounced.

Also, In making a large ‘jump’ from El Cap to Mojave, it’s possible you’ve got older software that no longer works well with Mojave. If there are processes running in the background, they may affect other software, like Dorico.

Make sure that everything is up-to-date and confirmed compatible with Mojave. Check what Login Items and Launch Agents you have running in your user account.

Dear Pluton4,
I just thought about this, maybe totally irrelevant. A cause of major slowdown is the presence of infinite loops due to strange repeat bars. Do you use repeats in your file?

Is it possible that you’ve inadvertently set up a MIDI feedback loop? If you use any software MIDI buses, such as the IAC bus in Audio MIDI Setup, then it’s possible for this to be set as both an input device and a playback device, in which case you’ll get a MIDI feedback loop that can choke the application. Try going to the MIDI Input Devices dialog on the Play page of Preferences to check that only a single MIDI input device is active.

If that doesn’t help, please do Help > Create Diagnostic Report and attach the resulting zip file to a reply here.

Thank you all for your answers.

I don’t have repeat bars, I checked already the MIDI input devices (as I said in my first post), and deactivated programs launched at start–and still I had problems. Dorico is today less sluggish, yet I haven’t touched anything. I am inclined to think that indeed some random processes in the background, due to Mojave interacting with other software that had no problems with El Cap, are to blame.

I’ll keep investigating and will post here if I don’t get it solved.

Thx again

The behaviour you describe pluton4 is very similar to what I experience, very very sluggish Dorico. I use 3.5 on a MacBook Pro 15" (2018, OS 10.15.7, 2,6GHz, 16GB).

I am guessing it has to do with the external display I am using in addition to the MB-screen(?). Unplugging my Keyboard (Yamaha P45), does not do anything. Also untick the MIDI-channels on my RME Fireface does nothing.

Any help is appreciated. It is quite stressful working with deadline for orchestral arrangements, when Dorico use about 6-8 seconds completely stalling (and with spinning wheel) each time I press save or just by coincident every now and then.

Please, Daniel, or other users/developers, is there anything I can do to help this?

best,
Jan Martin Smørdal

Jan Martin, can you please send me the project you’re working on, together with details of which specific operations are slow? It could be that there is a specific performance problem that your present project is bringing to light.

Hi Daniel, thank you for replying. Here is the file in question:
https://www.dropbox.com/s/es940txfkxxxgm3/Backbeat.dorico?dl=0

Also, there is a video (audio) attached to it, which I am not allowed to share.

I am now on my second - and very similar - arrangement, and the same thing occur: first everything is smooth and fine, then within 5-10 minutes gradually things get slower, the spinning wheel last longer each time the program stalls (mostly at save, cmd+s). And after perhaps 15-20 minutes things are so sluggish, Dorico has even problems quitting.

Hence, I quit and reopen Dorico all the time, to get to work.

Any help is appreciated.

Thanks for providing your file. Could you say more about what kinds of operations are slow? Is it only saving? Perhaps you could start Dorico and use it as you normally would, then when it becomes very slow do Help > Create Diagnostic Report and upload that zip file.

The whole program just gradually stalls more and more often, longer and longer each time. And each time with a spinning wheel. Here is the Diagnostics Report:

https://www.dropbox.com/s/pqoyfi8rhe4yhle/Dorico%20Diagnostics.zip?dl=0

(sorry for all the links: the Forum site does not allow me to upload anything)

I have a hunch that NotePerformer, or something in the playback engine is causing this, as I can see from the Mixer that “volum” (long after stoping the playback) is falling (the green in the meter) very very slowly after some minutes of use.

There’s no obvious smoking gun from the logs. Most operations appear to be completing in less than 1/10th second, with the exception of things like deleting a selected item (which is taking closer to 1/4 second) and saving (which is taking 5 1/2 seconds on average).

Could you try a few things to see if any of them make a difference?

– Try applying the ‘Silence’ playback template in Playback Templates
– Try switching off your MIDI keyboard again
– Try making the Dorico window much smaller on your external display

I’d be very surprised if any of these make any difference. I have a similar MacBook Pro to yours, though it’s the 16" model and it does have a stonking fast i9 processor, but I’m also driving an external 4K display, and it doesn’t make an enormous difference to the operating speed of Dorico in general.

Can you also let me know specifically where you are in the project and what you are selecting and deleting (page, staff, bar number, etc.) so I can try and reproduce those specific actions?

Thanks Daniel

Silence mode do actually do a lot of difference. Saving now takes estimated 0,5 seconds (of stalling/everything hangs, opposed to the other 5,5 seconds you mentioned).
I’ve stoped using my MIDI keyboard since yesterday, which seems to do just a little on the positive side.
Smaller window has no impact at all.

In short: it really seems to me the stalling/that everything hangs has something to do with the playback. In silence mode I now do not get any spinning wheels, but it does stall for 0,5-1,5 seconds when saving.

Where I am at in the project has nothing to say for the stalling. I can select something, scroll (I use my bluetooth mouse, cmd+scroll and shift+scroll), save, or start playback. I think that is all the situations where the lag happens.

Since I am on a deadline for tomorrow, I will work mostly in silence mode now. But for later, and maybe for other users, it would be fantastic to try to find a fix for this. I really enjoy working in Dorico, when it just works.

Saving takes longer if you have lots of VST data. And if you have auto-save set to a small time value, then you will get stalls while Dorico is busy with the saving.

I don’t think project size has been mentioned, which Dorico is sensitive to. I work in large orchestral projects and with bigger libraries such as BBCSO pro Dorico slows to a crawl. Pushing the VST’s elsewhere via VEP7 or virtual MIDI ports makes a vast improvement, but it’s still pokey.

Some operations such as changing the rhythmic grid are too slow to use unfortunately, except from the pop up directly (using the shortcuts is too slow).

Thanks benwiggy & RedtideMusic - useful feedback. I do work in larger files, mostly orchestras. But I do not use large sample libraries (just NotePerformer).
Still a bit puzzled.

NotePerformer is normally pretty lightweight, and adds very little in terms of file size and thus delay when saving the project. I’ve never really been aware of the use of NotePerformer having any kind of negative impact on the speed of the application. The only other thing I might suggest, unlikely as it seems, is that perhaps you could try saving your project to a folder other than your Dropbox folder, in case somehow the syncing behaviour of Dropbox is having some impact on the speed of saving?

Yes, NotePerformer is perhaps the smallest/least demanding sound library I know of. I try now to save files to a non-backuping drive, do not know if this has effect yet. Thanks for the thought/tip.

To sum up, what’s been most effective: No MIDI-keyboard, use less/no soft instruments.