Dorico won't launch

I’m trying to run (install) Dorico Pro 4 on a new computer, an M1 MBP running Monterey 12.3.1.

I ran the installer from the Steinberg Download Assistant, and it went through a blizzard of permissions and steps that at times seemed very redundant. I then ran the Steinberg Activation Manager, which confirms that Dorico is activated.

But when I launch Dorico, it gets to the splash screen, and as it does, I can see a couple of random dialog boxes behind it, but I can’t read them because they appear for only a split second and are obscured by the splash screen. The Dorico splash screen shows me this:

But then hangs there and never recovers. If I switch to another app, the splash screen disappears and never comes back, even if I click on Dorico in the dock. My only solution is to force-quit Dorico, but then the next time I launch it, same thing.

I searched for help instructions, which included the recommendation to re-download Dorico, restart the computer, and re-run the installer upon fresh boot with no other apps open. I did this, and it still results in the same thing.

I also tried trashing the app, and re-running the installer. Same result. It hangs on the splash screen on a slightly different message, but the same hang that doesn’t resolve:


Hi @user450 ,
sorry to hear about your trouble.
Is that the only Steinberg product that you have installed on that machine?
If not, try to go to /Library/Application Support/Steinberg and in there temporarily rename the subfolder Components to something different. What happens if you then launch Dorico?

Furthermore, please go to /Users/[yourname]/Library/Application Support/Steinberg and zip up the Dorico 4 subfolder.
Similarly for the Dorico 4 AudioEngine subfolder under /Users/[yourname]/Library/Preferences

The zip files please post here. Thanks

Thank you @Ulf.

Dorico is the only Steinberg product I have on this machine. I did try renaming the Components folder, and that didn’t solve the problem. (Though, interestingly, as I launched Dorico, I did see an alert pop up under the Dorico splash screen, and this time I was able to see it for a split second more than yesterday, and it said something about “you need to launch the Activation Manager” which maybe hints that this has something to do with activation. However, I did launch the Activation Manager which shows Dorico is authorized. (Note that Cubase Pro 12 is not installed on this machine at all.)

Then, as requested, here are the zip files of the prefs:

Dorico (16.4 KB)
Dorico 4 (11.1 KB)

Thank you!

Hi @user450 , very strange, if I interpret the logs correctly, then you must have a VSTAudioEngine process that is somehow stuck and not responding anymore.
Please have a look in Activity Monitor for a process called VSTAudioEngine and if it is there, then kill it (or simply reboot the machine). When you then launch Dorico again, what does happen, again stuck?

Thanks @ulf. The problem persists. I did force-quit VSTAudioEngine in Activity Monitor and tried again (same result), and also restarted the entire machine and tried again (same result). Slightly different message in the Dorico splash screen though:

I also tried one other variation: launching Dorico, waiting for it to hang, going into Activity Monitor, and then force-quitting the VST Audio Engine, in the hopes it would help Dorico get over that hump. It doesn’t. Dorico remains hung.

Okay, so it is the audio engine process that gets stuck at start up. Then we have to try something different. Please rename temporarily the following 3 folders:

/Library/Application Support/Steinberg/Components

Then kill the audio engine process and try again to launch Dorico. How does that go?

If it succeeds, well, then we know that in one of those renamed folders is a component that the audio engine chokes on. We then have to find out which one.

If the problem persists, we have to look in a completely different direction, but first let’s see.

And a remote screen sharing session with you could speed things up immensely, but that is not a must, just an offer from my side.

@ulf thank you again.

Ah. This led to some breakthrough. After renaming all three of those folders and launching Dorico, it did finally get past the splash screen, albeit with a warning that I needed to install “Dorico Pro 4 Sounds” via the downloader. (However, I checked the downloader app, and there is no file named exactly that. The only file that might be that is the “Content Dorico Pro 4 (recommended)” which I’ve already installed.)

I then tested further with your renaming idea; I found that the problem exists with BOTH VST folders. If either VST folder has its original name, Dorico will hang. But if both VST folders are renamed, Dorico will launch properly, except for the sounds error. (The first item, Components, doesn’t make a difference.)

So I guess that tells us something…but what?

I’m happy to do a screen-share, but don’t know what times might mutually work. Feel free to PM me. I am in the US on the west coast, and on Friday I’d have time in the afternoon.

Okay, great, this now leads into the right direction. So it is some dodgy plug-ins then. You can find out yourself now, it will only be a little time intensive.

The procedure is pretty simple: Start with the VST3 plug-ins. Rename the original folder and create a new, empty VST3 folder. Then you start copying plug-ins one by one into the VST3 folder again and try to start Dorico. If Dorico launches, fine; if not then you know that the last plug-in you copied in is somehow rotten.
Depending on how many plug-ins you have, this procedure can become really long and boring. But you can also change the strategy slightly, by copying groups of plug-ins, e.g. 5 or 10 in one go. So if Dorico chokes again, you know one of the last group is the culprit. Then you throw out the last group again and continue with the original strategy.
And then of course repeat the whole thing with the VST folder (for the VST2 plug-ins).

I’m really curious on your findings.

Done, and now mostly solved.

The culprit ended up being the PSPAudioware folder inside both the VST and VST3 folders. If either of the PSPAudioware folders were inside the VST or VST3 folder, Dorico would hang.

This is a new laptop I’m just getting set up, and I do know that I had run some of the installers for PSP plug-ins, but had not yet run their authorizers. Therefore, it seems likely that the hangup might be something having to do with the authorization of those. PSP otherwise writes really solid plug-ins. Perhaps the plug-ins were trying to display some kind of authorization screen/prompt. If you want to dig deeper into this, you can download demo versions of PSP plug-ins direct from their web site, and it’s likely you can reproduce what I saw.

Anyway, thank you for your help – I’m now able to launch Dorico.

With just one caveat. :slight_smile:

The first time I launch Dorico following a restart, a split second before the splash screen appears, I see another window that says something about “Now launching Steinberg Activation Assistant.” I’m not sure why this appears, and it’s only there for a split second before the Dorico splash screen obscures it, so I can’t be sure exactly what it’s saying or asking of me. But it does not launch the Activation Assistant, and if I manually launch the Activation Assistant, Dorico is properly authorized. So I’m not sure what’s happening there.

I haven’t actually gotten into using Dorico so I can’t be sure that everything is working 100% yet. But I can get to the welcome screen where I can create new documents or open old ones or work from templates. So, fingers crossed, I think I’m OK.

Any thoughts on that Activation Assistant prompt?

Ah, good to hear you found the culprit(s). Yes, I will download and try them myself. Maybe indeed it is like you say, once they are authorized they probably won’t pose a problem anymore.

In regards to the Activation Manager, to be honest, I don’t know, but I suppose that it is not a problem. Maybe @dspreadbury can give a better answer.

IIRC the SAM launches every time Dorico opens but is usually so quick that it is not noticeable. Someone (I think it was Daniel) mentioned this in another thread.

1 Like

Indeed - if you see the dialog about launching SAM just briefly, then it’s not a problem. It takes slightly longer for Dorico to look up its licence information on some computers than others, and so there can be a period where it doesn’t yet know whether it has a licence.

Thanks @richard_lanyon; that’s very helpful to know!