Dorico won't read LoopMidi port

I’m on Windows 10. My goal is to have both Dorico and Cubase listen to my same MIDI keyboard. The example below isolates the problem down to just Dorico.

In LoopMidi I have one loopback port set up: “v-Keyboard” (for ‘virtual keyboard’). No other loopbacks.

In MidiOX | Options | Midi Devices I’ve selected one input: “My Keyboard” and one output: “v-Keyboard” . I’ve selected no other devices.

In MidoOX | View | Port Routings I’m routing “My Keyboard” ==> “v-Keyboard”. No other routes.

If I launch Cubase (and select “v-Keyboard” as an input Midi port in Studio | Studio Setup | MidiPorts), Cubase receives key presses.

However, in Dorico (on a fresh boot, and no other programs open):

  • I create a new project (just to be sure I have a clean slate)
  • In "Edit | Preferences | Play, “v-Keyboard” is the one and only input MIDI device selected. NOTE: it lists ‘v-Keyboard’ as ‘v-Keyboard[1]’. Why the ‘[1]’? Is that germane?
  • Midi Input is of course enabled.

RESULT: Dorico doesn’t recognize keypresses. Indeed, the green midi indicator in the lower right does not flash on keypresses. (Yet, Midi-OX shows activity on both ‘My Keyboard’ and ‘v-Keyboard’)

If I disable ‘v-Keyboard’ and enable ‘My Keyboard’, Dorico works.

What am I missing? I’m grateful in advance for your assistance!

Hm, I just tried here with something similar and it does work for me.
I have an AKAI midi keyboard, routed to loopMIDI and in Dorico I disabled the AKAI, but I do get MIDI input (via loopMIDI) in Dorico.

Could you please do Help > Create Diagnostics Report and post the corresponding zip file here? Thanks

Before I drone on…the first thing I’d try is disabling WinRT MIDI support in ALL of your Steinberg hosts that show the option (In case you also run Cubase or Nuendo).

You can find this in Edit/Preferences/Play (scroll down to the very bottom, and untick the box if it’s ticked. Do this for Cubase/Nuendo as well if you happen to use those in tandem with Dorico).

Why? It’s worth a try. I have some kit that for whatever reason doesn’t work in Steinberg hosts if that is enabled.

The droning part…
I’ve been doing this for years because my Akai controllers won’t work with multiple hosts otherwise. The first one that runs grabs the device, and from there it no longer shows up in subsequently launched hosts. So…I have something like Bidule or Bome grab the device and route it to a virtual port that is properly attuned to supporting multiple hosts.

Here I start with a stand alone instance of either:
Bidule [Free Early Bird Evaluation version runs through March 8, and you can usually get a fresh demo for free after that date as well if you don’t find Bidule interesting enough to register)
Bome MIDI Translator (The Classic version is free for personal use with a nag screen)

Either of these utilities provide interesting real time MIDI monitoring/manipulation.

Bidule goes several extra steps by also doing the same for audio streams, plus the added benifit of OCS client/server features. Registered versions can also be hosted as a plugin in Dorico (chain and manipulate other plugins inside Bidule instances).

Whatever you use as a ‘bridge’ between the MIDI device to the virtual port…It MUST be launched before any Steinberg host (Dorico, Cubase, Nuendo, stand alone instances of HALion/Groove Agent/Etc).

These can serve as a ‘bridge’ from the MIDI controller into a Virtual port like loopMIDI (This is the one I use).

I haven’t used MIDI OX in a long time. If it is capable of creating a bridge from the MIDI controller to the virtual port, it should work! The main thing is be sure to run it BEFORE you launch Dorico (or any other Steinberg host).

Why? Steinberg hosts currently grab all available MIDI devices. Some come with better drivers than others, in that some are fully muli-client compatible/aware, while others are not.

I tried and it works for me with both, WinRT switched in Dorico on and off. And I also use MIDI-OX to establish the connection between the AKAI and the virtual loopMIDI port.

1 Like

That comes from WinRT.

I should add that in sessions where Cubase runs first, I don’t ‘need’ an external bridge (Bidule/Bome/MIDI OX/Etc).

I can allow Cubase to grab the problem device, and simply use an empty MIDI track in monitor mode to route it on to a virtual port that other hosts can access.

My diagnostic zip is here: (“too large to upload”)

Thanks for the data. I actually see no reason why it should not work.
Dorico “sees” in total 19 MIDI input ports and only “v-Kawai [1]” is enabled for streaming, so from that port Dorico should receive MIDI by all means.
What if you disable WinRT (Preferences > Play > Advanced Options), still the same?
To be honest, I have no other suggestion. It should just work…

I turned off WinRT at it works! I’ve rebooted twice and it still works – I’m hopeful!

Many thanks to you all!

Good to hear. I don’t know why it does not work with WinRT MIDI. With me here it does, but…
On the other hand, you only really need WinRT MIDI when connecting with BlueTooth keyboards.