Dorico's audio engine not always making sound

I’m using Dorico More than half the time I launch Dorico, it won’t make any sound. That is, when I’m on the Play tab, the Output fader will show output, as will individual instances of HALion (or NotePerformer). But I don’t actually hear anything.

When this happens, I’ve learned the hard way that there’s no way to fix it. Quitting and relaunching Dorico doesn’t help. Searching for “VST Audio Engine” in Activity Monitor doesn’t help. (It’s never there when Dorico is quit.) The only thing that helps is restarting the entire computer.

I wonder if this is perhaps tied to my audio hardware (UA Apollo), which I sometimes have to disconnect and reconnect from my studio depending on where I’m working. It’s well-known that the UAD drivers don’t like multiple users, and maybe that’s playing into things because I have to log out all other users before I use the UAD stuff. However, in Dorico, I’ve also tried switching to built-in audio (this is a 2021 MacBook Pro) and I get no sound there either.

Are there any other tips/tricks for getting Dorico’s audio playback back again?

I’m attaching the diagnostics file in case it’s useful. This was captured in this state in which Dorico is not making any sound.

Dorico (1.1 MB)


It could be a coreaudiod problem. Perhaps kill that process?

Hi @user450 , thanks for the data.

According to the logs and things, it looks more like a mute/solo issue.
In the moment when you created the Diagnostics Report,
some outputs of the first NotePerformer instance were in a solo state,
so that other channels implicitly get muted.
You can check the mute/solo state of all Dorico channesl in the mixer view (F3).

If that is not the problem, then it would be good to have a remote screen sharing session with you.

I have the same version of Dorico. I use the fabulous Universal Audio Volt 4. On Windows 11 Insider Preview. I don’t have any trouble with Dorico, but using other programs the Volt sometimes just cuts out for a while and then comes back. I have no idea why. I have not bothered to chase this up. But I just thought I would mention it, since the Volt is closely related to the Apollo. I am using the UA ASIO driver. My other interfaces such as PreSonus don’t do this.

@ulf thanks for that hint. At the moment I captured this diagnostics report, I was indeed having a problem with NotePerformer, which I thought was separate than my general issue with Dorico’s audio engine frequently failing. I would note that (after the diagnostics report) I switched from NotePerformer back to the stock HALion and was still not getting any sound. I will come back to this later (after a complete restart) and switch HALion off, then try and capture a diagnostics report with only the stock HALion player when it’s happening. Thanks for your offer to help and I will definitely need it!

I documented a separate NotePerformer anomaly but haven’t posted it yet because I didn’t want these two issues to get confused!

@benwiggy interesting idea; I’ll try force-quitting that next time this happens.

@Ulf I’ve now force-quit coreaudio in Activity Monitor, then relaunched Dorico, tested NotePerformer playback (it’s completely silent), switched to HSSE, that’s silent too, then saved, then quit Dorico, force-quit coreaudio again, relaunched Dorico, and the HSSE project is still silent. In other words, after every kind of resetting I can try, I still can’t hear playback.

I took another diagnostic report (attached) but at this point I have to restart the computer entirely, which will fix the problem…but only for a matter of hours or a day or two, then it’ll happen again.

Again, I’m an audio pro and this is the ONLY app I have that behaves this way, so that’s why I’m being a stickler about it, because I’m constantly having to restart the computer to use Dorico properly, which upsets a lot of my other workflows like windows and apps that are open and in-progress. :slight_smile:

Dorico (1.0 MB)

@user450 , I’ve sent you a private message. Please check.

Update: It turned out that user450 has a utility running that can redirect audio streams and by accident he routed Dorico’s output to somewhere else.


Wouldn’t be Voicemeeter would it? :slight_smile: [A troublesome app in my experience.]

No, this one: Rogue Amoeba | SoundSource: A Superior Sound Control


Yes, huge thanks to @Ulf for jumping on a video call with me.

I have no idea why SoundSource was doing that, because I haven’t touched SoundSource in many months. (I had forgotten about it! It was installed during Covid to help route audio to specific places, like Zoom.) For some reason, when my computer would boot, everything would be normal, but later (through some process I never knew about) SoundSource would reroute Dorico to my AirPods (even though my AirPods were closed in my pocket), and that’s why Dorico’s metering looked normal but I never knew why I couldn’t hear anything.

Those of you who have AirPods know that Apple does some fancy stuff to make it auto-switch to your phone or to different devices automatically when you insert them into your ear. I wonder if there’s some logic in there that was causing this. I don’t remember EVER sending Dorico to my AirPods, even momentarily.

I’ve now disabled SoundSource completely (since I don’t really use it at all anymore) and I’m willing to bet that this will solve my mysterious “Dorico isn’t making any sound” problems.

Thank you again, Ulf.

1 Like

I also run SoundSource (and a number of other Rogue Amoeba apps), and have seen this happen with the headphones as well, but this is almost certainly actually a bug on the Apple “auto-connect” side of things in recent versions of macOS, as I have seen it happen with Apple Music as well! No, macOS, you cannot connect to the headphones when they are in my pocket. Sorry. :joy: Hopefully you happen not to hit it going forward, but I would not be surprised if you do, as I do not think it is a SoundSource bug per se—though the fact that it can reroute like that means it is definitely less likely to hit you even if macOS messes up.

@chriskrycho that’s really interesting to hear. The mystery would be why SoundSource was switching only Dorico to the AirPods and not other apps or not the global system audio. It’s a mystery.

I do agree Apple does some weird switching stuff in an attempt to try and be smart. I very rarely use AirPods with my computer; I almost always use them with my phone.

I don’t use SoundSource much anymore, so I’ve simply disabled it for now. If I ever do need it again, I’ll know to keep a close eye on it.