Double click for note input inconsistent

Has anybody else run into a situation where doubling clicking on a bar does not enter input mode?

I have a file (170+) flows, and double clicking seems to stop working after a certain amount of time. Or certain new files exhibit the issue as well. I haven’t pinned it down to anything specific yet, but was wondering if others have had this issue?



Could it be that having so many separate Flows in one file is responsible for the lag?

Does d/clicking cause just a delay; or does it never get to Input?

I thought the same thing… maybe there is a lag, and that could be possible.

No delay… it just doesn’t work. I have to type ‘enter’ to get into note input. It’s not a major issue, as I have other means to get into it, but I was curious if anyone else had this issue. Or is this something I experience on machine only?


I constantly have difficulty trying to double-click just before the first note of a measure and instead having the barline selected, which throws me out of position vertically (to the top of the system) as well.

I suspect the issue is probably somehow related to having layout-specific music frames. Depending on exactly what you are selecting, and whether you start in Write or Engrave mode, you may see this inconsistency. Normally making an explicit selection of a note and then hitting Return or Shift+N should work reliably even when using a layout-specific music frame, but that may not be true for double-clicking.

OK, some of that could be the case… I have a file with 3 layouts. Full score (which is Dorico’s default), I have the Part layout (never touched this one, as it is Dorico’s default), and one called book layout (I created for setting up the independent music frames, graphic frames, and text frames.

I create all the music in Full Score layout, then in Book Layout I lay it out. What I have noticed when I add new flows, when working on the Full Score layout, that is where the problem seems to occur. Once again, not consistently, so I am not 100% sure. I am also 100% of the time entering music in page view. And yes, pressing ‘return’ does work very reliably.

I have also noticed that around the time the problem begins to exist, another type of issue occurs. I click outside of the measure, which if I recall correctly, used to take one OUT of note input. If I double click the staff, I enter note input mode, then if I click elsewhere, the orange caret is still visible. And I am NOT taken out of input mode. I have to hit the escape key. Not sure if this is a ‘new’ feature, or new ‘behavior’, but I don’t recall it doing this before, and I believe I see the double clicking issue occur around the time I start to notice this.

I can send you the file if you’d like to take a look at it, but it sounds like you are already aware of some this issue.


In testing the file once more, after reading response and writing a response, the double click does not seem work at all in getting into note input mode on this particular file.

Once again, this is trivial as I have other means to enter note input mode. I just thought it was worth mentioning.


I have never had this problem in the past, but now that I’ve updated to Dorico Pro, double-clicking to activate the caret no longer works at all. I’ve tried it both with Allow Note Input with the Mouse activated, and without; neither works.

V2.0 bug?

I don’t think there’s a general bug with this, Lew. Is your project especially large? If you start a brand new empty project for a single instrument and double-click on the staff, does it work there?

I’ll check it with a new file tomorrow, Daniel. I’m not sure whether or not you would consider the current file large; It’s around 240 bars long, with 12 staves.

That may be large enough if it’s a performance-related problem. I believe James, one of our developers, has been looking into this but I thought he had made a fix prior to 2.0 going out into the world. Let me know how you get on with a smaller or completely empty project. Thanks.

As far as I can tell, I remember having had that kind of small issue. Usually, closing the document and opening it again solves it, so I do not make a fuss about it, but still it should not happen.

I checked it with a new wind quintet file, Daniel, and it worked as it was supposed to. I even added 500 empty bars to it, and it still worked. Hope that adds a little information.

Could you email me your large project, to d dot spreadbury at steinberg dot de? Please try double-clicking to start note input at various points through the music, e.g. at the very beginning, in the middle, and at the end, and let me know in your email whether you find any difference in where in the project you try to do it.

I had this behavior on modest size projects with only one flow.


Daniel: As you requested above, I tried double-clicking through the piece—the beginning, the end, and several points in between—and no luck.

And per your request, I’m emailing you the file.

As always, thank you for your help.

I am having the exact problem that Robby reported. It is as if I have passed a file size limit and after that the double click stops working. But my file is not large at all 1 flow. 70 measures. 8 instruments.

I went back to backups. All the files saved through last night work. All the files saved today fail. I attempted to incrementally delete measures, trying to find if there was something in the music triggering this problem. If I delete some measures, double-click does start working again. But it is not any specific measures. I can cut out the first 10 measures and it works. But cutting out the LAST 10 measures makes it work too. Cutting out one instrument makes it work. It just seems to surpass some space limit. I’d rather not post the file publicly because of possible copyright questions, but I would be happy to send it to anybody via PM. (Daniel, I have sent it to the address you mentioned above.)

I have the problem and I have not entered any music frames. I don’t have an “inconsistency” per se. When it is not working, it is consistently not working, even if I completely reboot. But if I delete a little bit of content randomly, it may start working, and it doesn’t seem to matter what content I delete, so that feels like an “inconsistency”.

On edit, it may be a performance-related issue that is highly inconsistent. I have now seen a case where I waited several minutes, then clicked on a measure in the System track (without taking any system track action) and the double-click started working. This was with Dorico showing practically 0% CPU the entire time. Unfortunately this does not seem to work on the Dorico file I have actually been editing for real. I will leave that file open for awhile to see if it ever starts working.

Has anybody found a work-around for this problem? I’m dead in the water at the moment.

I’m not sure this constitutes a workaround - the instruction manual lists it as the first way to begin note input (see screenshot). Does it help, though?