Double-click Intermittently Works in Cubase 9 / macOS


I’ve done a load of trouble shooting and still cannot fix this issue…

Double clicking intermittently works within Cubase 9 on macOS. If you want to edit a MIDI part and open up the Key Editor or Rename a Track those are all things that do not work when you double click.

I’ve tried everything down to a complete wipe of my OS and fresh install of JUST Cubase and Cubase alone to make sure no plug-ins were affecting the software and it STILL does not work.

Would appreciate ANY help at all on this. Is this a known issue? I read on Google that NI Replika plug-in was causing this but I do not have that plug-in installed nor have I ever.



Are you using an Apple Magic Mouse? If so I had exactly the same problem and logged a support request with Steinberg over a month ago. (I’m still waiting to hear back)

I don’t remember when the problem started but Cubase used to work fine and then all of a sudden double clicks stopped working but were fine in all other apps and the OS. I think it was maybe after an OS update that the mouse polling changed and this affected Cubase in some way???

I tried everything I could think of, reinstalling Cubase, reinstalling OS, upgrade to Sierra, upgrade from Cubase 8.5 to 9, changing mouse, re-syncing Bluetooth etc. It was driving me nuts! Then one day I bought a new mouse pad and it got even worse and I realised the problem had been staring me in the face all along…

I got rid of my mouse pad and now just use the mouse direct on the desk surface. Double clicking works all the time for me now in Cubase!!

Yes… here too… double click is not working like it’s used to since sierra and cubase 9

Same here - driving me nuts!

WTH… OK so yes I do use a Magic Mouse and I do have a pad. I just placed it directly on my desk and it now works maybe 65% of the time vs. 10% of the time.

What does this mean???

This is a REALLY bizarre issue.

With mine it went from 10% of the time to 95% of the time. I still get the occasional double click not working if I try to do lots together.
i.e. create 20 MIDI tracks and then double click in each one to create a MIDI part one after the other with no rest in between occasionally one part won’t create. If I leave it for a split second between creating parts it always works.

Make sure your batteries in your mouse are healthy and then try adjusting the double click speed in System Preferences > Accessibility > Mouse - mine is set to around 80%

Thanks Mike.

So is this a bug? It has to be right? Have you submitted to Steinberg? I cannot get a response from Steinberg. This is just a major slow down in my process for sure.

Learned my lesson, will not upgrade to a .0 version only .5 versions from Steinberg.

Here too. In 8.5. It works fine, since 9.0.1 not (also one click on cue-sends)

Anyone else have this issue? I did a clean wipe and just cannot imagine that I’m the only one with this - not sure how this isn’t a major bug that’s being reported?

I have similar dramas but most notably on single clicks. When I click the little “e” on inserts, often Cubase thinks I want to drag the insert around. I honestly think this problem may have started in Sierra but I’m not sure. I seem to have the same problem in Cubase 8.5 within Sierra.

Are you folks having similar issue to this with a single click as well? Happy to provide a vid to better explain it if the problem is not clear.

I’ll likely roll back to El Capitan at some point to see if that fixes it.

It honestly is driving me nuts too.

P.S.: I can confirm that double clicking also only works about 80% of the time here.

P.P.S: I’m also using a Magic Mouse but I have also tried with a Logitech mouse on my Mac, still the same dramas with that too.

Yes I reported it to Steinberg 01/01/17 but as part of the general Mac OS sluggish GUI issue.

I have had a confirmation that my report was received but nothing further.

Thinking back my problems started when I installed Sierra. I was running Cubase 8.5 before it was deemed compatible by Steinberg and was expecting some kind of update but was surprised when Steinberg announced compatibility with no patch.

I bought the upgrade to Cubase 9 hoping it would fix it but it made no difference.

So I think Apple changed something in Sierra which affects how the mouse gets read by Cubase. So not necessarily a bug in Cubase as that didn’t change but rather a Sierra compatibility issue.

I also had the single click issue the others have mentioned - like the mouse is too sensitive to movement when clicking on an insert in the mixer - but this also went away when I removed the mouse pad.

Hi everyone, I’ve done some more testing this morning.

I installed El Capitan along with Cubase 9 on a separate partition and tested this.
I then cleaned that partition and installed Sierra along with Cubase 9 and tested it again.

Result: This problem was ABSOLUTELY introduced in Sierra and is apparent immediately. I couldn’t reproduce the problem at all on El Captain but could within seconds on Sierra.

What I must say I’m disappointed by here is Steinberg’s Sierra qualification. Any Cubase user would notice this IMMEDIATELY (as we all did here) once upgrading. This absolutely should have been picked up by beta testers. This is yet another reason why Steinberg should adopt more public beta testing.

I’ll raise a case on this too with Steinberg, but in the meantime, I’m thinking of re-installing El Capitan as I honestly couldn’t live with this bug.

I must admit that no other software on my system is affected by this problem though.

Thank you for this, crazy that this was missed? It couldn’t have been missed, it was probably just swept under the rug.

Such a bizarre issue, I pray it gets resolved somehow or another!!!

Likewise :slight_smile:

I have decided to definitely downgrade to El Capitan so I’ll report back to confirm if it does the trick on a longer-term basis than my quick testing today.

So I’ve been back on El Capitan for several days now and done plenty of production work. I did not come across this same annoyance at all in El Capitan so I’m now pretty damn sure it’s Sierra related.

In fact, outside one minor sampler bug, I have not had any problems at all with Cubase 9.0.1. Initially, I had several crashes, but I isolated those to certain plugins by specific manufacturers. I’ve reported the issues to those vendors and they actually have reproduced them and are working on a fix. So after disabling all their plugins in the meantime, I’ve had an absolutely rock solid system, more solid than I have ever had.

Great, so Sierra issue. SO does this mean Steinberg wouldn’t be able to address this issue? Apple would?

Having the same issue.

I can’t reproduce it, probably because it’s a fresh installation of MacOS Sierra and no preferences from earlier Cubase Pro versions have been imported. Unfortunately, every system differs from the other so I would suggest giving a safe start a try:

If the double click works perfectly fine while on safe start mode, you will need to reset the program preferences. In order to do so, open the Finder, press the Keys “Cmd + Shift + G” (Or Go to -> Folder) and navigate to the user’s library:

Rename all the “Cubase” folders you find there or move them out of that path to your Documents folder for instance.
Cubase will create a new preferences folder during its next start.
Select an empty project and configure your VST Connections if needed. Close Cubase.
Open a Cubase project from “File -> Open project”.
Older preferences that might have taken a lot of time to configure (for example the KeyCommands.xml) can be copied from the newly renamed preferences folder onto the recently created one. Make sure that Cubase is closed before doing this.

Thanks for your help but I have actually done a full Sierra OS re-install and completely fresh installation of Cubase 9.0.1 and can instantly reproduce the problem. Would a video demonstration help? I’m more than happy to put one together.

The easiest place to repro this in on inserts. Try to click once on the little “e” icon to open the insert. Do this a dozen times and you should notice that many times, Cubase thinks you want to drag the insert instead of open it.

Similarly, create a MIDI clip and double click to open it, repeat a dozen times and you should notice that sometimes, it simply won’t open the editor for the clip at all.

I’m using an Apple Magic Mouse (if that helps at all). The type of mouse could potentially be a factor.