Double Click issues in Cubase Pro 12 for Windows

Anyone on PC having double click issues with the mouse?
It often takes me 3, 4 or even 5 double click attempts to open a midi editor or rename a track. Regardless of the mouse control panel settings in window, i cannot improve the behavior back in Cubase with either wired and wireless mice.
This has been ongoing for 2 or 3 years, it’s driving me mental, finally had to post something about it, as you can imagine it’s incredibly frustrating for the workflow, desktop systems (i don’t use a laptop)

I can’t say I’ve encountered this and I have been using a desktop pc for years on every version

Thanks for the input. I’ve tried 2 wired mice since and still the same issue. I revert to just pressing enter to open a midi or audio editor whereas i would normally just double-click the part. Renaming a track is the absolute wort tho, at least 3 or 4 double click attempts to rename a track. I’m sure i’ll solve it, but this is specific to Cubase, in normal windows apps this does not happen. It’s a system i built this year, high spec desktop, it simply should not be happening. I’m very fussy with the mouse as i use it full time for music production, so it has to be super lightweight and on the larger side to make it comfortable for 10 to 12 hour days here in the studio.

I’ve never experienced this either. Sure sounds like a bad mouse, but then it would happen everywhere.

The only thing I can imagine is that Cubase is spinning its wheels trying to do something & it’s impacting realtime performance. Does this occur in a new blank Project with Cubase started in Safe Mode & all plug-ins disabled?


Wow… Great tip raino, that worked! Blank session with no 3rd party plugins and double clicks are perfect everywhere first time. I guess i have a starting point to troubleshoot what may be causing the issue, prefs, plugins, instruments, i have many and i can’t live without them, but maybe just ONE is the culprit, possibly my Console 1 plugin and hardware (just a starting guess),
I’ll report back when i have something to report!

1 Like

Yes I’ve noticed exactly the same problem and solution. If I have a large template with multiple vstis and loads of Kontakt instances double clicking is a nightmare as you’ve described. Takes so long to do anything, particularly renaming rendered tracks. Fresh project with nothing loaded and double clicking works perfectly. Something to do with video memory perhaps? I’m running Windows 10 Pro on a 5950x desktop with 128 GB Ram and a decent modern video card btw. I’m not getting this with any other program. It’s a massive waste of time and bad for my blood pressure! :slight_smile:

If you’re using this large template a lot and keep having the issue, an easy thing to try is re-optimizing your mouse click speed via the control panel. I’d open a big template in the background then do the double click optimization. Hopefully this will compensate for any delay caused by the template. Easy potential fix, so worth a shot?

1 Like

Thank you. Worth a look but it doesn’t happen in any other program and as I said it works perectly with smaller templates. I wonder what could be causing it? As Rexxyboy said whene it happens I have to double multiple times just to get it to register. Very odd.

Don’t assume it is actually caused by the size, although it could be. A larger Template also creates more possibilities for a ‘bad’ plug-in being loaded.

It still happens daily, i’m kinda used it but also really over it! Sometimes i’m double clicking the track name on either the arrange page or the mixer MULTIPLE TIMES until it finally clicks in and lets me change text. On an empty song i don’t have this problem, but as soon as the session grows, the issues happens. Its not my mouse at all, i’ve tried many, both wired and wireless.

I also have this problem in big projects. I find it comes and goes. It was not a problem for me running Open Stage Control, but I broke my ipad so I’m back to using a mouse for a lot of things.

The only solution I have is to assign Shift+K to open key editor in Key Commands.