Doubling tempo of midi notes


Often I want to double the tempo of a group of midi notes when I use the midi editor.
In the logical editor (in standard set 1) there are funtions called double tempo and half tempo, but if you want to use them on only a few notes that are not at the beginning of the midi event, here is what you get (with double tempo here) :

Before :

And after :

Apparently this problem has been around for quite some time :

Any idea?


Unfortunately, this is the correct result of the Logical Editor “script”. The only way to fix it is to shift the notes back afterwords.

All right. Yes, maybe this could be done with Logical Editor too, by getting the position of the first selected note inside the event, and then after the operation, shifting the selection back to this position. I don’t have enough experience with LE, but if anyone knows…


Unfortunately you cannot ask for the distance of the MIDI Note from the MIDI Part start. Sorry.

This is easier to do in the Project Window than using the Logical Editor.

Use the option on the Select Tool ‘Sizing Applies Time Stretch’

  • To double the tempo drag a MIDI Part’s length in half
  • To half the tempo drag the Part’s length to double the length.
  • To only do some Notes, Split the Part so one section has only those notes, resize & glue back together.

I didn’t know this ‘Sizing Applies Time Stretch’ tool. It’s pretty cool because you can chose the ratio by which you change the length.
But it is still quite challenging to do it on just a few notes while you are “drawing” them in the editor.
Doing it by a simple selection followed by a shortcut key would be awesome.

Thanks for your answers!

@raino : this is awesome - and so simple! How comes I didn’t think of this myself?? :thinking: