Downgrade to previous Cubasis 3 version


Is there a way to go back to Cubasis 3 version before 3.2 update…?
Too much bugs for me on this 3.2 version, I have neither the patience nor the time to list everything and especially to provide reports in the standards…

Previous version works better for me using Ipad 10,5


Hi arakatak,

Thank you for your message.

So far we are unaware of the steps to officially downgrade an app version.
But you might give Google a search for tutorials etc.

Normally, the update should work better than the previous version.
Please give the following steps a try:

(1) Load an empty project
(2) Close all running apps, including Cubasis
(3) Shut down the iPad

Does this help to solve the current issue(s)?


Hi Lars,

Thanks for your answer,

Obviously I have already did steps you have described, and this does not help…
Indeed the update should work better than the previous version…
Ok, so I go back to Cubasis 2 while waiting for Cubasis 3 new updates, that’s easiest…

Best Regards,

Hi arakatak,

Cubasis is updated on a regular basis, and we do our best to resolve as much user issues as possible with every release. However this works only, if we’re aware what’s broken and able to reproduce the problem.



It looks that the new Cubasis 3.2.1 update for the time being have solved my problems.

Thank you,

Hi @arakatak,

It looks that the new Cubasis 3.2.1 update for the time being have solved my problems.

Thanks for the feedback, glad to read that Cubasis 3.2.1 seems to have resolved your issues!


Hi. Version 3.3 doesn’t let me play with Roli Seaboard Block.
To verify this you just create a new project, create a midi track with a continuos sound (e.g. an organ) and try playing together some notes.
It will very often stuck notes continuously.
So I have to go back to previous version that was working very well since yesterday.
How can I do it?

Hi @adolfoweb,

Thanks for your message and welcome to the Cubasis forum.

From what we know, Apple does not provide an option to go back to previous iOS app versions.
Alongside, the Cubasis 3.3 update should not have broken the usage of the Role Seabord app.

Please give the following steps a try, to see if it helps:

  • Load an empty project
  • Close all running apps, including Cubasis
  • Fully shut down the iPad

Once relaunched, does the Roli app works fine again with Cubasis?
In addition, please make sure to share the issue with our friends at Roli too.


Tried shutting my phone many times.
And it has nothing to do with Roli, also happens with my Artiphon.
Maybe you forgot to test it with iPhone (xs)?

I also tried to reinstall Cubasis

Some time ago I had big problems with Cubasis 2 and ROLY Seaboard application, you can check my post and read all by yourself. In short - this is not Steinberg problems, but ROLI has no interest for it, I’m so sorry.
Two days ago I got Cubasis 3 for two possibilities - to work with it from keyboard shortcuts (R anc C NOT WORKS))) and in hope, that may be it’ll decide my problem with ROLY - answer NO)))
Keep quite, this is The Way)))

If you’re interest, please find this my post by yourself, hope there are some interesting))

It is not a Roli problem. Also Artiphon has this problem.
Seems the stuck note problem is with Cubasis + IPhone XS + iOS 14.5.1
I went deep and logged midi input in Cubasis using StreamByter as midi effect.
Playing a couple of notes in rapid progression the problem occours and the logs are this:
90 41 08
90 43 01
80 43 00
80 41 00
90 41 1A
90 43 01
80 41 00
Translated: there are 4 midi on and 3 midi off so one note is stuck

Why not, sorry, its a little bit difficult to me to understand this up to 100%. Im just a musician, I have a problem- I ask technical assistance. And Steinberg staff try to helps me, but ROLI staff - no.

@LSlowak any updates on note off missing messages?