Download Assistant fails, no error/reason

I’ve been trying to download Cubase Pro 10.0.50 over the past two days but the Download Assistant fails with no error given. When I retry it starts from the very beginning.

Is it possible to get meaningful logs indicating what the problem is? Are there actual working/useful troubleshooting steps? I’ve seen posts about not installing aria2 and updating java etc., but maybe that is not the place to start.

After this latest download I was able to catch that it fails on the ‘verifying’ step. I renamed the file to .zip extension and attempted to extract and it did indeed error out, so it’s true there was a corrupted download. However as I downloaded this 21GB file over 5 times I believe there is likely a problem on the DA side.

I ran the uninstaller but then noticed that aria2 was still present in the program’s “third party” folder, so deleted it, re-ran the installer with ‘aria2’ option unchecked, and used regular HTTP for the download, which worked.