Download assistant not working!

what`s that!!!

since i updated the download assistant, everytime i try to launch the download assistant, it says “log in”, when i try to do so, a blank site pops up!
so it`s impossible for me to download anything! :blush:

This is also happening with me.

Steinberg help?

That’s the same question driving me crazy. Is there any solution?

Same here =(

the same thing for me
paid update on nexway and download not possible ???
ticket sent … no response.
steinberg don’t make me regret my purchase.

Same for me - I clicked “Sign In”, the browser opened so I signed in and authorised the browser to open the download assistant again. Back to “Sign In” again. Round and round.

i have send the same issue for 3 days now , no response , they give us lesson to not upgrade again.

Same from 2 days, No cubase 11 for now -.-

Same here, tried 3 different browsers and same thing in all. Never had this issue before. WTH?!!

Had the issue, make sure your system clock is correct in your OS. fixed for me

The clock, that was it. Thanks!

I went around and around with this today. St Download Assistant getting stuck in this “Sign In” window and then when the website opened, I kept getting a “St Download Assistant” needs to be authorized window that never went anywhere. The system clock was correct, but I went ahead and took it off ‘auto’ time updates. I deleted all cookies, and then made Firefox the preferred browser. And when the window came up to allow Firefox to open St. Download Assistant, I checked the allow box. I then started St. Download Assistant in Administrator mode.

At that point, the Download Assistant opened rather normally, did a small update of its own, and then correctly showed the files to download for Cubase 11. Not much fun overall. And I dont know what actually facilitated the correct opening of St. Download Assi! Just a few things to try.

Seems like a lot more hassle than I remember previously, including now having three different 'accounts for Steinberg. One for the forums, one for the Shop, and one for Steinberg licenses.

Thanks for your post. Unfortunately it did not work for me.I have tried everything I can think of and wasted hours trying to open the download ass.
Three different browsers firewall. cookies, time, etc… and still not able to open it.
I hoped you had it but nope.

None of the above works for me.

I fixed it by downloading the software on another PC (laptop in my case) and then went back to my main PC.

While I could get SDA finally open last evening, it is not working this morning. Same ‘Sign In’ and ‘need to authorize SDA’ which never completes. I am sorry to hear of all this frustration around this.

it is still not fixed!!! why!!!
Steinberg could you please fix this!!!

As an update St. Down. Assis. is still not working on my system. As per another thread (which I dont have a link right now) it was suggested to get on a Steinberg “Chat” and that the Chat person will give you links to a site to download Cubase 11 and associated offerings.

It took about 2 minutes to connect on “Chat” and another 3 minutes for the associate to come on board. I was asked what the issue was, what was I trying to download, and within a minute I was provided a link and password to a site where I could download everything. While on the chat, I connected to the link, and sure enough all of the files are there. Downloading starting now!

So I would try this. I think all those other things I was trying was just hit or miss depending on an opening at Steinberg’s servers. Although the wakefulness of my cat may have something to do with all of this.